Allo USBridge board


#1312

yep that fixed it
before it worked on 0 with no issues same environment, I guess with updates and such it was more and more needed


(Angel Catala) #1313

I received this afternoon my new USBridge with (Allo) DietPi 6.1. I have tested it with my current Roon 1.6 and HQPlayer Embedded 4.7.1 and it worked fine. I played a few songs from Qobuz with no problem at all, even I have jumped from song to song.

After that, I have updated HQPlayer Embedded to 4.8 and I have update too DietPi from 6.1 to 6.19, from console, of course. After a long update process, because it patches DietPi from 6.1 to 6.19, everything is still working.

So, no problem with my setup :thinking:


#1314

thanks, it seems it was an old parameter that when I was on a older firmware worked fine but somehow wasn’t working anymore and after changing to the recommended Allo value it is working fine now


(Sean) #1315

Thanks @zbyte !


(Sean) #1316

Hi @rahulkc_s, how do I make this HQP change on the DigiOne, running DietPi?

It doesn’t work with the same command for USBridge.

My DigiOne is having the same issue with NAA.


(Dick Vliek) #1317

Maybe

pico /DietPi/uEnv.txt

and edit the file.


(Sean) #1318

But unlike on USBridge, that file is empty on DigiOne/RPi3 (it just creates a new file). Same the nano command.


(Dick Vliek) #1319

Yeah on mine too (I checked but i dont use HQP). Maybe just write the config-line and save?

aotg.urb_fix=1


(Sean) #1320

That’s not the full config line though… there is more than just “aotg.urb_fix=1” when I look at the same file on USBridge.

And I don’t think I can just copy what I see on USBridge over to this.

It’s Sparky vs RPi3.

Hopefully @rahulkc_s can help.

My NAA on DigiOne/RPi3 isn’t working with HQP NAA anymore. Works with RoonBridge though.


(Dick Vliek) #1321

I didn’t know there was more to that file. I wouldn’t try it, even if you could.


(Sean) #1322

I could but like mentioned above, I definitely won’t :wink: It’s Sparky vs RPi3. Can’t just copy stuff across.


(Sean) #1323

I’ve just updated HQP Embedded (new version released today).

And now everything works again.

No idea how that changed anything (no reboot even needed) but yay! lol


#1324

@allo.com Johan, what is the max current output for the 5 volt out on the USBridge host USB port? I want to use a USB powered DAC (Topping D10) and wonder if there will be sufficient power to run it (DC 5.0v @ 500ma).

Thanks in advance.


#1325

Glad to hear Sean, let me look at the HQPE changelog I’m curious and will ask Miska if he has time to reply as well


(Phil Knowles) #1326

My Allo USBridge dies just before Christmas and allo were out of stock then. I got one from Modmypi Ltd. Good service and quick and the price was a little cheaper than direct from Allo taking postage into account.


(David Lemieux) #1327

Roon can’t find the USbridge @rahulkc_s once MacBook wakes up. I’m a few days into my Roon trial and attempting to integrate my 1 week old USBridge as an endpoint. It takes a reboot from my DAC/DSP and reboot of the Allo each time the MacBook (core) starts up. Here’s my set up- MacBook serving as the core- USBridge attached to MiniDSP 2X4HD. I uninstalled Roon Bridge and reinstalled; updated to v6.19.7- issue persists. Why is Roon losing my USBridge and DAC every time the computer sleeps? Any help is appreciated. I’d like to continue with Roon, but with a streamer that isn’t working properly I’ll need to move on including returning the Allo.


(Angel Catala) #1328

Yesterday, I noticed that with the USBridge, now I can play native DSD through Roon Bridge and NAA as well. Now, I have not to use DoP and can avoid the ugly pop noise when I started and stoped playing due to the change from PCM to DSD and vicecersa.

I upgraded DietPi from 6.1 to 6.19, I don’t know if the upgrade has anything to do with this, but I am happy :grin:


(Jon Mansey) #1329

I found the special USB port was not able to power the D10 reliably at all. Its not a matter of current capability, the D10 only draws about 150mA once its running, any USB port should be able to deliver 500mA, but maybe there is a peak draw at the moment of powering up that causes the USB port to go over current and shuts off the 5v. The built-in ports worked fine, but somewhat defeat the object. I ended up using an iDefender and iFi PSU, but its an extra $100 I shouldn’t have needed to expend to get a working rig IMO.


#1330

Thank you @Jon_Mansey, I’ll skip the D10 and go for the D50 which uses a dedicated 5V power source.


(johan ) #1331

500ma will be provided, I think the max is about 600ma