Allo USBridge board


(Angel Catala) #1332

I have noticed that I am getting the message “Roon lost control of the audio device” every first time I execute Roon. Then I click play again and it works with no problem. After that, it does not fail again until I execute Roon the next time. Not a big deal, just a curious issue.

My NAA is USBridge + DietPi 6.19.7. The stream is DSD128.

I have checked the /DietPi/uEnv.txt file and it already contains the string aotg.urb_fix=1


#1333

If you are not using HQP then the value should be 0


#1334

If that doesn’t fix it don’t worry about, it happens to me all the time with HQP, just the 1st time then it plays just fine. I have Amanero connected to my NAA


(Angel Catala) #1335

I have tried to set the value to 0 and it didn’t work well, so I have rolled back to value 1. Now it only happens the first time. As I said before, not a big deal, but I wish it will be corrected in future updates.


#1336

it’s been happening to me too for months already :slight_smile: I believe it is related to the DAC initialization by the NAA, not a big deal


#1337

Thanks.

BTW the latest dietpi update that I was prompted to upgrade to once again bricked my USBridge. When are you guys gonna get your :poop: together?


(Paul Hermans) #1338

Just did the update, all via ssh.
On DigiOne OK after one update.
On USBridge, needed to run the update twice and then needed to ssh in again to finish the second one.
Thereafter everything OK.


#1339

Did you manage to sort this out? My digione has also had the same problem. ssh in, two updates and now no longer recognised. Great!

Update: I had to reflash the memory card for my digione, and I am current runnng 6.18.14 but I am obviously hesitant to update (I have included this on the digione thread). I also have a USBridge which I am also hesitant to update. hmmm.


(Dan Knight) #1340

Hi,

Thanks for the report.

I’ll open up a ticket and try to replicate the issue:

In the mean time, please can you all verify:

  • SD card used (make + model)
  • Power Supply used (make + model + rated amps)
  • Was the current image (before update), provided by Allo, or, a manual flash using latest DietPi image?
  • List connected USB peripherals

#1341

Thanks @Dan_Knight for quick response.

I will respond to you in the Digione thread.


#1342

Allo USBridge/Sparky on-board eMMC
Allo provided 5V 3A
Manually flashed using latest (at the time after last bricking) DietPi Allo GUI image downloaded from dietpi.com
Topping D50 DAC


#1343

Nope, thrown the USBridge in the rainy Sunday afternoon project drawer :smiley: Went back to a vanilla RPi and Ropieee…


#1344

In the name of science @Dan_Knight , I tried to update the USBridge aswell as the digione. I ssh in and I can update and I am fairly sure it just reported updating to 6.20.? however when it completed and it needed to reboot, I let it. Now going back in via the allo web browser, it is now saying it is at 6.19.7 and an update is available. I have stopped short of doing anything else as taking the next step is what caused the issue with the digione.


(Angel Catala) #1345

I updated DietPi on USBridge the past weekend via SSH to the version 6.19.7, the latest. I have just logged in and it says me nothing about updating to 6.20 :thinking:


#1346

I received my USBridge yesterday with software 6.18. Updates with the web control bricked my bridge twice and I had to reinstall Dietpi on the Emmc card. After that I tried to update with ssh without “sudo”. It tooks a long time and after reboot it was 6.18 again. After that I made a update via ssh and WITH “sudo”, which leads to several reboots (like Win 10) but the update to 6.20 was successfull.

It was a pain in the…


(Paul Hermans) #1347

Allo USBridge/Sparky on-board eMMC
Allo provided 5V 3A
Manually flashed using latest (at the time after trying to update the just delivered bridge) DietPi Allo GUI image downloaded from dietpi.com
Then updated to 6.9.17 via ssh.
Pre Box S2 Digital

The update to 6.20 took 3 trials:

  • 1 seemed to have succeeded, but after reboot still 6.9.17
  • 2 after restart roon not detected
  • 3 (just reconnecting via ssh) and some installation continued.

#1348

I read that the ticket for this item had been closed on the dietpi site so I had another go at updating. It wasn’t straight forward and I thought I had bricked it again, but I could go in via ssh and it basically continued the update. Then I thought I had bricked it (as in, no roon access, no allo web access). So I went back in again via ssh and ran the update again and this time, it worked. Now sat on 6.20.6 and can access via the allo web page too. This was the same, pretty much for the digione and USBridge.


(Dan Knight) #1349

Hi All,

Apologies for the issues. We’ve tracked it down to a patching issue.

Micha has now resolved the issue, any updates should not function correctly.

If you experience continued issues with the updates, please let me know.


#1350

Ok, thanks for tracking down and fixing @Dan_Knight.


(Mike Ormerod) #1351

I just tried to update to v6.20.6 via ssh, appeared to go ok. Rebooted, logged back in and it says I still need to update. I ran the update again and it failed with

So I re-ran the update again and it says it was OK!

So I rebooted and now I can’t access the device :frowning: