"An audio file is loading slowly."

I had a lull of several months when I was in the middle of a move. When I restarted Roon on my MBP 2015 (15") I upgraded to the latest version (1.2 build 142, 64-bit). Network setup was the same: SMB 3 connection to a Synology DS1515+ share. Possible confounding factor is that the NAS was updated to the latest OS (now DSM 6.0-7321 Update 7).

So that’s the setup.

When I start Roon and go to play an entire album, the very first track played back results in Roon going totally silent after maybe 30 seconds of playback, while playback continues (little animated EQ icon moves, track progress bar appears to move to the right, etc). After another half a minute or so Roon skips to the next track after which the music plays just fine from that point onward.

Right when Roon switches from the “silent” track to the next one, a small box – black background, orange text – pops up for a couple seconds that reads: “Roon: An audio file is loading slowly. This may indicate a performance or hardware problem.” I managed to screenshot it:

This happens regardless of what album is chosen to be played back first. After “passing through” the above process, Roon has no trouble playing any other track to its completion.

Weird, huh?

I’ve tried entirely removing the share from Roon, witness through several restarts of Roon that the database is totally lost, then adding the share back in. No improvement.

Hi, I’m wondering if it’s related to a network issue … is it hardwired or WiFi?

Hey KJL,

I suggest verifying that local playback works fine first, by creating a watched folder on your MBP and copying 1 or 2 albums into that location. Disable the main storage location and enable this test location. Test the playback. If it still has issues, then I would also check to see if there is another process running on your MBP that is consuming processor power.

Also, can you provide some additional information about your network setup. What is the network path like from your MBP to your NAS, like MBP > ethernet > netgear 318 switch > ethernet > NAS
And what DAC are you using and how is it setup?

Darn it, yes I should have tried a local copy of the albums as a test. I will try that tonight: it’s so easy there’s no excuse!

At least I can say that this occurs even with my Sennheiser HD800S plugged into the MBP’s headphone jack. So the path is:

headphones -> MBP -> wifi (Ruckus R710 AP) -> ethernet -> Cisco 3560CX-8XPD-S switch -> ethernet -> NAS

I’ll also test a “direct” Ethernet connection between my MBP and my network when I have a moment. The quotes are because the MBP requires either a USB or Thunderbolt Ethernet adapter. I can test both.

I had that exact behavior last night.
Windows 10 NUC, music on a built in SSD, streaming to MicroRendu/Geek Pulse.

1 Like

Apologies for reviving this one, but I’m a Roon newbie and am having the same issue.

I run a MacMini connected by ethernet to my QNAP NAS. I have intermittent problems exactly as described by KJL in the first post - Roon looks as if it is playing but the progress bar doesn’t move, then it skips to the next track, and so on.

I have no problems when the same (24/96) tracks are on a USB drive attached to the Mini. I could of course fix this by using a local drive (and used to run things this way with Audirvana) but it is much neater if I can use the NAS in another room.

My question - how do I best troubleshoot the NAS to check why its performance on the network seems to be the issue?

Other than this, loving the Roon experience and already a paid member - I found a whole load of music which I either never knew I had or had forgotten, which was one of the points!

Thanks very much


A common source of this problem seems to be having jumbo frames enabled on your network so that would be one thing to check. See this for more details.

Thanks - I have checked, and I don’t have Jumbo frames turned on.
Following some advice elsewhere on the forum, I’ve also disabled AFP networking so that only SMB is turned on. In addition, I have started to use two ethernet connections to my NAS, setting up port trunking to improve the speed. It certainly appears quicker when accessing files through the Finder. However, I’m still getting the problem of “loading slowly”.

It is more likely to happen with high definition files, which intuitively makes sense. However, it is also happening sporadically with CDs ripped to FLAC (16/44.1)

One other thing I tried was loading the same high res file onto a USB share - and it worked flawlessly. So it’s definitely a network thing, but I’m not at all sure what else to test - and all the hardware is ethernet hard-wired so speeds shouldn’t be an issue…

Any suggestions please? Thanks!!
Best regards

It might be the switch that is the issue. Some managed switches are more trouble than they’re worth.

Thanks Geoff
Sadly, the TP Link SG108 is exactly the model which I just bought. 3 of them…

Aargh - it came highly recommended and everything else on my network is working great.

Is this something that may fixable by Roon (it’s a pretty popular switch) or do I have to buy something different?

Best regards

Flagging @support - any suggestions to tame this TP Link switch for Roon usage? Thanks.

Hi @Andrew_Buglass

I just scanned through the manual for this switch and have the following suggestions (based on past pain that still gives me flashbacks :slight_smile: )

First off, disable IGMP Snooping

Without going into gory detail of what’s happening IGMP snooping allows the switch to look inside certain types of packets and switch them to the appropriate ports only. Very, VERY good thing on a big corporate network, but in order to function properly other items on the network need to be configured a certain way. If that’s not the case then the switch will get into a fight with another device and/or drop multicast packets (which Roon relies on for discovery).

In general (very broad-brush general) if you have a manged switch DO NOT enable IGMP snooping.

Reboot the switch and see what happens. If the problem is solved then stop here.

If not, before you continue check your router and/or wifi access point for any settings related to IGMP or UPnP. Make sure they’re disabled. Reboot and try again.

Next up, Storm Control. This could be a problem as the switch may be seeing the multicast chatter as being an issue. It shouldn’t but…

Try disabling for all ports and reboot the switch.

Finally, Loop Prevention (otherwise known as Spanning Tree). This likely isn’t a problem unless you have SONOS devices on your network. If you do then I would recommend powering all of them down and rebooting the switch. Test again and see if that helps. If it does then you should check the Loop Prevention settings in the switch:

If not already set it to “Disabled” and reboot the switch. Add the SONOS devices back in and see what happens. If this is a fix, great. If not then this one gets complicated.

Make changes one at a time and always reboot the switch. You want to be sure to force all of the devices on the network to drop and renegotiate. Also, I’m not at all familiar with the ins and outs of this switch so make sure that the configuration changes are applied and saved so that they come back in the next boot. This is an issue with Cisco switches (changes lost unless explicitly specified otherwise) but I’m not sure about this one.


Roon uses multicasts to detect devices i would switch of any multicast service on the switch

1 Like

Thanks Andrew, that’s incredibly helpful.

I’m just back with my computer after a couple of days away, so will try the changes to the switch

Much appreciated!
Best regards


I am having very same issue. My audio files are on a Bluesound Vault. I would like to know if that is an issue, which will be fixed when Bluesound rolls out Vault update and Roon rolls out 1.3