Android controllers can not open multi-disc album

I’ve upgraded all systems roon 1.2 to 1.3.

Many Android controllers can not open multi-disc album(or it includes many tracks).
Google Nexus 5X only can open multi-disc album.
Windows controller has no problem.

I’ve rebooted the server and restarted the controllers.
I’ve reinstalled the controllers.
Any other ideas for me?

Server Arch Linux (Intel Core i5-5200U) Roon 1.3 #196
Windows 10 Desktop Roon 1.3 #196 :OK
Sumsung Galaxy Tab S2 9.7,8.0, S7 edge 1.3 #196 :NG
Huawei Tablet 1.3 #196 :NG
LG G3 1.3 #196 :NG
Google Nexus 5X 1.3 #196 :OK

My moto g 3 works OK drop down list of CDs and my pioneer xdp-100r works too.

Hey @Takeshi_Imazu – can you be a little more specific about the issue you’re having? Or can you post some screenshots?

We’re not having any issues accessing multi-disc sets on Android here, on either tablets or phone, so let me know a little more information and we’ll look into this. Thanks!

It seems that my android controller does not open if album has more than 22 tracks per 1 disc.

Sorry, do not have that issue. I have a box set where every disc has over 22 tracks and I can open and view it find in an android browser. Galaxy Tab S2.

Can I rebuild the problematic album data?

I am having this problem also, any updates on the issue or is a fix pending?

I am using a Samsung Galaxy Tab S 8.4, Android 6.0.1. (The bad multi-disc albums works fine on my Iphone … )

What happens is either:

  1. Roon remote crashes when I try opening a “bad” multi-disc album, when restarting I get message “Error loading saved page”. Also there seems to flash by a message “There was a network error…” or something simular, but it is to fast to read.

  2. “Loading album…” appears in screen never finishes.

  3. 1 time in 20 the album actually opens … I don’t see any clear “why” this happens sometimes.

Did some checking of the logs. The main difference when things crash/“go bad” and works seems to be that
when things go bad some version of the following appears:

03/11 10:44:09 Trace: [metadatasvc] REQ … (removed end)
03/11 10:44:10 Trace: [metadatasvc] GOT (189ms) Sooloos.Msg.Metadata.TranslateAlbumIdResponse:
03/11 10:44:11 Warn: Error in web request NetworkError (The remote server returned an error: (502) Bad Gateway.)
03/11 10:44:11 Trace: [push] request to manager failed
03/11 10:44:11 Trace: [push] retrying connection in 6873474ms
03/11 10:44:11 Info: [brokerserver] Client disconnected:
03/11 10:44:12 Info: [brokerserver] Client connected:

Edit, maybe I was wrong seems that only these four lines are consistently present:

03/11 11:08:57 Trace: [metadatasvc] REQ
03/11 11:08:58 Trace: [metadatasvc] GOT (521ms) Sooloos.Msg.Metadata.TranslateAlbumIdResponse:
03/11 11:08:58 Info: [brokerserver] Client disconnected: …
03/11 11:08:59 Info: [brokerserver] Client connected: …

Any updates on this issue, with a headless Ubunto installation of Roon this issue is extremely annoying, as it means that your are not able to listen to opera as now this issue is also on my Iphone… … so now the only way to play opera is to go to my WIndown machine and use the Roon Remote on that.

Of my top 10 most played 7 are operas … I guess this will change now when you cannot access them anymore.

Are there mulit-disc albums which you can open consistently?

Edit: Sorry missread your question, I will see if I can find a multi-disc album that does load, the first post was albums that does NOT load.

Thanks for the question, one that does load is:
The Salzburg Recital, Sokolov, [16/44.1 DL]

Maybe it is that the High-res that does not load, will investigate more later.

Old post:

Yes the albums that does not load is completly consistent, some examples:
Mozart, Don Giovanni, Currentzis [24/96 DL]
Verdi Aida, Pappano [24/96 DL]
Mozart, Die Zauberflöte, Böhm [24/44.1 DL]
Bizet, Carmen, Rattle [24/44.1 DL]
Mozart, Le Nozze di Figaro [DSD64 SACD rip]

It seems that it is not the number of tracks that is the problem as albums as:
Bowie, Five Years [ 62 tracks] and
Ultimate Sinatra [26 tracks]
bort load despite having as many tracks as some of the multi-disc sets.


Then What are some of the problem discs. When I rip Operas, I keep the disks separated into their own folders and not all together in one directory. And I have never had an issue with any of the Operas I’ve ripped. Was hoping to see if we had one in common to compare.

No it is not related to High-res.

Verdi: Forza del destino, Serafin [24/96 DL] does load.

Thanks that would be very helpfull. :slight_smile:

Yes I also try to keep the discs in seperate directories when I rip, I will see if any of my own rips in this fashion does not load. The ones I have tried seems all to load.

Ok thanks Rugby! :slight_smile:

I have made some head-way on maybe finding the problem. All of my non-most-played albums seems to load so the problem was only for albums I play alot which made it seem like a big problem …

Also after trying about 100 old albums I retried the “bad multi-disc sets” among my most played albums and now they load ???

Explain that one … caching???

Ahh, I misread. Just to verify the Currentzis Don Giovanni still has issues loading? I

The Currentizis album loaded after I had loaded alot of other albums inbetween…

Now I tested loading the Currentzis album on my Iphone, it failed to load. I cleared the cache on the Iphone still the album did not load. Then I loaded alot of other albums on the Iphone. Now the Currentzis album loads ???

Then I Went back to the Samsung, again the Currentzis album fails to load, annoying… and I guess the Currentzis album is not a true multi-disc album either so the problem is not related to multi-disc.

Given that the iphone had the issue, I’m inclined to think the issue is not specific to Android. it would be interesting to know exactly what happens when you click on an album. It seems like Roon, checks its own database, touches the physical files and makes a call to the internet to see if there is any updated information. Maybe something is hanging in one of those steps. @eric might be able to shed light on exactly what happens.

Can you describe your RoonServer, Music Storage and network setup?

Thanks yes of course:

I have tried to make the setup as Close to the recommended as possible:
Intel NUC NUC6i5SYK i5-6260U running Ubuntu server 16.04 LTS with all the latest updates
The Music is stored on a USB disc connected to the Nuc
The NUC is connected to an Asus AC2400 router with Ethernet
Samsung Galaxy Tab S 8.4, Android 6.0.1

Tried the opening alot of albums trick again on the Samsung, but this time I cannot make it work. But now there is issues with random albums, maybe the ones I opened in one of the preious opening “Sprees”. So maybe it is more a problem with albums that I have resently opened…

Can you move some of your problem albums to the NUC’s interal storage. If Roon does touch each album when it opens, then maybe there is an issue with the USB storage chain.

Hi again,

Yes I tried moving Le Nozze (Currentzis had too long file-names to be moved), still fails to load from the Samsung. :frowning:
Don’t notice any difference.