Android wifi problems when trying to use Roon

My Samsung Galaxy A3-2016 phone keeps having problems with Roon even after a software update on the phone as well as several Roon updates. The problem is that every time Roon tries to connect to the server the wifi connection gets lost. This happens about 19 out of 20 times and if it can get a connection it usually last for only a couple of minutes before the wifi kicks out. Tried it on two different wifi networks, same problem all over. Anyone know a solutions for this?

I could miss my phone totally if there was iOS playback for Roon. I only want to use my phone as a mobile battery powered endpoint, that’s all. My iPad would be nice as a mobile control and playback device. Any chance on iOS playback in the near future?

Hi @Sjef_van_de_Ven ----- Thank you for the report and my apologies for the troubles here. To help me properly evaluate this issue you are reporting, may I ask you to please provide me with the following:

  1. A brief but accurate description of your current setup as seen here.

  2. Can you please describe your network configuration/topology, as well as providing insight into any networking hardware you may be implementing.

  3. During your troubleshooting of this behavior have you tried running Roon remote on a separate device to check if the application is more stable? If so, what was the outcome of the test?


Hi Eric, thanks for your reply.

To answer your questions.

  1. System setup. Roon Core version 1.3 build 209 32 bit. Core is running on a PC with Asus SM87C motherboard with I7 processor and 16GB of memory. OS is Windows 10 education edition 64 bit version. OS is on seperate SSD, music is on internal SSD in this computer. On this PC there is also Roon version 1.3 installed as remote, most of the time not running.

Before this PC I had a Shuttle XPC G5 with e8400 Core2duo processor with GB ram and music stored on interal HD. In this setup I hade the same problems with my Android Phone.

Collection size is about 38000 tracks

  1. Network is a shared internet connection with my own sublan consisting of nothing more then a ASUS RT-AC-87-U router. Connected to this router is my decribed music PC and a backup NAS via cat5 cable. Connected via wifi is my macbook pro, a Asus zenbook, an Ipad mini2, a Lenovo tablet and two android phones. The shared internet connection has about 32 devices connected to it.

  2. Yes I’m running Roon Remote on my macbook, on my Ipad, on my girlfriends Android phone, on her laptop and on the Lenovo tablet. All work fine. Only my Samsumg A3 2016 seems to have problems with Roon.

Hi @Sjef_van_de_Ven ----- Thank you for following up with me and taking the time to answer my questions. Both are appreciated.

Have you tried reinstalling the application on the Samsung Galaxy A3-2016 yet?


Hi Eric,

I have tried reinstalling the app again today. Same problem. When the remote starts looking for a core the wifi gets disconnected. Tried another wifi network, same problem. Must be something with this phone. All other mobile devices work as remote but unfortunatly for me none of the other devices can play auduo via Roon. IOS support would save my day.

Hi @Sjef_van_de_Ven ---- Thank you for the follow up and giving the reinstall a shot. Sorry to hear that it has not yielded a better result.

From your feedback, I understand that you’re on a shared network with MANY devices accessing it (“The shared internet connection has about 32 devices connected to it”). If you were to disable the other devices, temporarily of course, in your house that are also accessing the WiFi is there an improvement in behavior on the Samsung Galaxy?

Furthermore, can you verify which frequency your Asus router is using, 2.4ghz or 5ghz?

From a quick Google search:

“The primary differences between the 2.4 GHz and 5GHz wireless frequencies are range and bandwidth. 5GHz provides faster data rates at a shorter distance, whereas 2.4GHz offers coverage for farther distances, but may perform at slower speeds.”


Hoi Eric, sorry for muy late supply, been really busey with work.
I think I just forget about the samung phone, whatever I do nothing seems to work with this device. Tried reinstalling, tried different network speeds (my wireless router is almost next to me, 3 meters away in the same room)

All I wanted is an endpoint for the bedroom. Unfortunatly I have three old android devices tha only run up to android 4.2 while Roon needs 4.4 as minimum. Too bad, could have been a nice purpose for thes older obsolete devices.

Hi @Sjef_van_de_Ven ---- No apology necessary :wink: I am more than willing to keep working at this with you so we can try to determine why the Wifi is getting knocked off when you are trying to connect to the core with this device.

When I read your response, I did a bit of research looking for any tools that can be used to measure the strength of the Wifi connection while using your Galaxy A3-2016 and came across this on the play store: Wifi Analyzer. There seem to be a few other options available but this was just the first one that popped up.

Furthermore, I see from your most recent post that you tried reinstalling and tried different network speeds. By chance did you try (temporarily) disabling some of the other devices in your home to see if a stable connection could be made/maintained with less traffic on the network?


Hi Eric,

My Roon setup is on it’s own sublan. On this Lan there are the following devices.
1- a desktop running Roon core and roon remote
2- my macbook, Ipad and samsung A3 phone
3 - my girlfriends asus zenbook, lenovo tablet and samsung android phone
4 - a backup nas

All devices except the desktop are connected via wifi and none of them have any problems running roon remote, exept my Samsung Galaxy A3. So I think it’s really a problem with the samsung A3. I allready have the same wifi analyzer from your link and it displays full signal. Should be, the router is no more then 3 meter away. I have also found out on various forums that there seems to be lots of connectivity problems with the samsung A3.

Meanwhile I have found a solution to get playback on my Ipad. I have installed a virtual soundcard / mixer called Voicemeeter on my windows desktop that runs Roon core. Voicemeeter can send audio over network to my Ipad via it’s own VBAN App. It’s a workaround but sofar it seems to work.

Hi @Sjef_van_de_Ven ---- Thank you for your patience here.

I have been doing a bit of research to try and see what other Samsung Galaxy users have reported to us in regard to their experience with the device acting as a remote and I am finding varying responses :head_bandage:

My instinct is telling me that if others Galaxy users are able to function properly, then the device should be working as needed. Also being as this is the ONLY remote device in your setup that is struggling, while others are functioning with the same Wifi/Roon core I have to think that something about that device is making it “unique”.

I am not a Samsung user myself so I can not comment if there are any known Wifi issues with the device but also running a quick Google search (“samsung a3 Wifi dropping”) revealed the following:


Seems the A3 as well as the A5 can have WiFi stability issues with Android 6 as well. Sometimes moving from 2.4 to 5 ghz can solve things.

1 Like

The stability issues where also there also when it had android 5. My hope was that updating to android 6 would solve things. It did fix some stabilty issues but not with Roon. The A3 doesn’t have 5 gHz wifi. I might try a factory reset some day and see what that brings me.