App "crashing" for no apparent reason

Occurs when trying to use the app on iPads and Mac systems. The only device that never seems to have a problem is my iPhone, even if I’m in airplane mode with WiFi the only network enabled. All other instances of Roon crash. On Macs I get presented with black box with musical appreciation, and then the app crashes. On iPads I don’t even get that far. If I reboot the iPad and start the app it launches and I can start playing on, for instance, music from either library or internet radio. But soon the app crashes though I can still see it “running” (selecting all apps) and it’s window (small as it is) shows Remote Connect banner and “Waiting for Remote Core”. Picking up my iPhone the Roon app shows the dCS Zone functioning and I can use the app fully to stop playing or choose another song/station. Same for all other zones.

Network is as follows:

Nucleus with USB drive attached. Ethernet wired to D-Link 5 port switch (dumb). Switch wired Ethernet to dCS Upsampler. Switch also wired to Eero WiFi access point. Been on the phone with Eero support. Checked all possible config settings and even did factory reset. Same results.

Appreciate any help in trying to isolate the source of the problem.

Update: after taking a break for a half hour or so I started the app on one of my iPads while discussing things with my local audio dealer.

Lo and behold, though I got a strange pink encased bit of text along the lines of a problem loading the page, I was now able to run Roon. It’s as if some sort of invisible dust storm had come and gone.

No other changes had been made to either the Nucleus, network settings or apps. Obviously something had changed. Maybe it’s Roon cleaning up old cache or other bits in it’s state. Rebooting the Nucleus had not “fixed” things, nor restarting Roon Ready devices, or reinstalling apps on some iPads or a Mac.

My dealer tells me they occasionally have similar issues and find that waiting or switching cores (not an option for me) usually helps. Still puzzled why my iPhone’s Roon app seems to weather the “storm”.


Steve, what version iOS and roon app are you using? Likewise what build is your Nucleus running? They should all be on the current releases B390 for Roon and iOS should ideally up to date too - 12.1.4 currently.

Roon build running on macOS Mojave 10.14.3 is 1.6-390. And all the IOS platforms are running latest version of Apple code 12.1.4 and the 390 build of Roon.

Ok well that should rule out any version inconsistencies. Not sure where your core is running…is that on the Mac or is there a core running else where?

Core is running on the Nucleus.

Flagging @support here for you. I’m assuming when you say everything is running B390 that this includes the Nucleus too.

Yes. All Apple devices as well as Roon core. Checked last by going to the Nucleus web page. Indicates that in addition to the server sw being v 1.6 B390 the OS is Version 1.0 build 159 and what is referred to as Roon Labs Software version 1 build 9.

Interestingly, I’d been successfully using Roon the past hours playing music from my library. Just now when I switched to playing an internet radio station it started playing back music but the Roon app “crashed” as before. Meaning you cannot access Roon any longer from iPad or Mac. Could, as before, access Roon via the iPhone (same version of App as other IOS devices). Then after about 5 minutes things returned to normal. I could launch Roon from the iPad and then MacMini without the app crashing on either and navigate around the app.

Very puzzling…(beginning to wonder if this is in any way due to integration with the Qobuz beta I’ve added into Roon, though I’ve not added any albums or songs from Qobuz – just played things every now and again from their library).

I suppose that there might be some other app/service running on one or more of my active devices that’s creating problems over time. For example not long ago I began using Cloudflare’s apps and services for faster and more secure DNS on my Macs and IOS devices. Wondering if the Nucleus is adversely altered by using this service. Maybe the DNS cache is becoming corrupt or overly burdened in some way.

Also, in scouring the Roonlabs Community for references to similar crashes I did see that others have had issues with using the Psychomed stations (ones out of Greece). I use them when Rondo (out of Helsinki) becomes unavailable (a real pain). Seems that’s a known problem. I’ll avoid those stations until a new release of Roon becomes available.

That still cannot explain why my iPhone X never fails to work with Roon while all others crash or otherwise become unusable.

Hello @stevebythebay,

Thank you for your report. We are aware of a few radio stations with special characters that can cause this behavior and have addressed this issue in our next release.

Please keep a close eye on our release notes section for when the next release is published and we can revisit this issue afterwards to verify if the issue is resolved on your end.


Thanks Noris. I’m guessing that in all likelihood that’s what has been the root cause of what I experienced. Normally I use either local radio stations or Rondo. Since it seems to have “disappeared” within the past few days, I connected with the Psychomed one here:

Guess this is the one that caused the strange behavior on all of my devices, save my iPhone X.

Hi @stevebythebay,

Yes, I can confirm that the radio station you posted was in the list of those with issues.
To get out of this state until the new release is published you can do the following:

  • Open Roon on your iPhone X
  • Navigate to any zones which have had that radio station selected
  • Start playback of another local or TIDAL track without special characters
  • Clear “upcoming” in the Queue screen
  • Do this for all zones that had that radio station selected
  • Start the Roon app again on your iPad and OSX Remotes


Thanks for the detailed steps. Just one thing: why is it that the iPhone not affected by this situation? Is this a unique attribute of the IOS code that’s tied to the hardware chipsets in iPhones? Would re-installing the Roon OS have also “reset” things, had I gone that far?

How bizzare-just having identical problems in that iPad and laptop crashes but iPhone stable. When I open on laptop and then iPad, as iPad crashes the laptop does too BUT phone stable. Hope there is a fix soon.


@stevebythebay - Although the iPad is a mobile interface, the UI for iPad is based on the Desktop Roon version while phone interfaces have their own UI set. Reinstalling Roon and starting fresh would have also resolved this issue as long as the internet radio stations with special characters was not listed in the Queue/Now Playing.

@Ming_Lim - Thank you for your interest, we are addressing this issue in our next Roon release so I’d definitely recommend keeping a close eye on our release notes section for when it is being published.


Appreciate the information. Explains a lot as to why it happened as it did. Guess I “stepped in it, again”.

I finally searched in Roon support about my internet radio crashing Roon since the last version 1.6 . I’m not sure sure if what is described above reflect my situation.

When at my desk, I choose a 320Kbps internet station, Audiophile Baroque or Classical, and Linn Classical or Jazz, I see a small yellow dot, I hear the station for 1 second or less and BANG, Roon crash completely.

I have to restart the Roon program again. Back to the web radio screen, I can elicit the same trouble every time I choose those stations.

If I select another 128K or 320K station that give a big yellow dot, no problem.

If I select a FLAC station, with a big blue dot, no problem.

Those dots are just adjacent to the right of the station name

Situation is the same either at my desk (CORE) or with an iPad

Re-installing the Roon OS did not help.

Thanks for your attention.

Hi @Jacques_Legrand,

Audiophile Baroque/Classical and Linn Classical/Jazz are also on the list of stations that are addressed on our next release regarding this issue.


Hello @stevebythebay/@Ming_Lim/@Jacques_Legrand,

We have just released Roon v1.6 build 401 which addresses this internet radio issue:

Please give the update a try and let me know how it goes!


Works for me. I’m uncertain about Rondo as this site seems to have gone bye-bye for now, at least.

Hi @stevebythebay,

Glad to hear that it worked for you! I tried to add the Rondo station and am unable to add it on my end either so this seems like an issue with the stream link itself.

Since the main issue is solved, I’m going to go ahead and close this thread. Thanks again for contacting us!

– Noris