Apple TV not working with Roon 2.0

Roon Core Machine

Mac Monterey 12.6

Networking Gear & Setup Details

Wifi network

Connected Audio Devices

Apple TV

Number of Tracks in Library

110,000

Description of Issue

Roon 2.0 will not connect to my Apple TV. Everything was working perfectly until I upgraded to 2.0. I have ensured that my Apple TV is on the latest version and that both my Mac and the Apple TV are on the same network. Other devices can stream to the Apple TV with no problems. I have disabled the apple TV in Roon and reenabled it. I am prompted to enter a code, but when I enter it, the Apple TV does not respond. Is anyone else having Airplay problems with 2.0?

1 Like

Just updated to Root 2.0 and same issue. Hoping for some guidance on this.

Same here. Occasionally Roon 2 will show my apple TV2’s , TV4 and HomePods. System was faultless with 1.8

My ATV’s are not enabled, but when I view my About screen they are either both there, one there or none. And they can come and go while viewing the screen. One later gen HD, One 2nd gen 4K.

Also having this issue with my Apple TV 4K (first gen), I can’t even see the AirPlay option for my CXN anymore (in Roon’s Audio tab).

Can some of you change your Airplay settings on the ATV to test. Mine would only accept if a password is used (not an Airplay 4 digit code).

Just to clear things up for me.

Once you enable ATV in Roon it’s asking for the Airplay passcode (6 digits).

Code found in ATV settings under Airplay. Then select Allow Access. 6 digit code displayed.

Once entered does it work.

I have had no issues with mine so cannot help unfortunately with a fix that worked for me.

Just to chime in, I have three ATV’s. At least 2 of the three have the same problem. Haven’t tried the third ATV yet but assume the same. Again, all started with Roon 2.0 upgrade. All ATV’s running tvOS 16.0. Changing the setting to require password, e.g. using the generated 6 digit password, works. Help Roon!

Hi Paul, welcome to the Roon Community

Are your ATVs the latest 4k versions? I’m just wondering as mine is and I have had no issues at all.

How are yours connected to your internet? Wired or ethernet?

Thanks, Lewis. I’ve lurked around but first real post. All three are 4k, with two the first generation A1842’s and one 2nd Gen A2169. All exhibit the problem but can be worked around using the require password approach. They are all wired. I have a Ubiquiti Edgemax 4 router managing the system and a Netgear Nighthawk CM1100 modem with Xfiniti service.

I’d like to say it was me enabling the ARC feature this morning – had to configure the router for port forwarding – but this problem manifested itself before that.

Any insights you might have would be welcome.

Are you saying after enabling the ATVs in Roon and inputting the Airplay password/code that all is working, as in ATVs as endpoints.

The Edgmax is a router but do you use a switch, or have you got all ports on the Edgemax on the same IP range.

Also, Infinity might be CGNAT. If you click on the below link it’ll advise if you have a public IPv4

Yes, using the password option (6 digit not 4) Roon shows ATV’s as endpoints. As others said, not an ideal set-up and certainly different from pre-Roon 2.0. Yes, i do have an unmanaged, gigabit switch between the router and endpoints. All my internal IP’s are within the same range. The link shows that it is a public IPv4.

Cool

I’ve always had to have the airplay password setup to enable ATVs since I started using Roon with the ATV. It’s rare I use the ATV as an endpoint now though

Forcing the Apple TV to require a password fixed the problem for now.

  1. Go to Settings > AirPlay and Homekit.
  2. Under Allow Access, choose Require Password. A six digit password is displayed.
  3. In Roon Settings, go to Audio, select the Apple TV device (disable it first if it is already enabled), and then enter the six digit password.
2 Likes

All my Apple TV’s and HomePods have passwords set. If I go to Roon settings and select audio, I often don’t see the Apple TV’s and HomePods listed. Sometimes after a few refreshes one of 2 may appear. This problem has only happened since the update. This is a problem as these are nearly all my endpoints.

They all can be seen from my iTunes.

Ok, it seems Roon can’t see my HomePods and Apple TV’s when they are in ‘sleep mode’. If I play a song via my Apple Music App to my HomePods, via Airplay, they all wake up. I then go back to the Roon App and presto all my Apple TV’s and HomePods can be seen.

I never had a problem with Roon 1.8, but since 2.0 , Roon can’t detect ‘Apple airplay sleep mode’

Hi, I now have to ditch Roon ARC, and put my home network mesh system back to ‘route mode’ not ‘Bridge mode’ Now all my airplay units are behaving themselves with Roon, but no longer can use ARC. For me the Access to my Apple TV and HomePods were far more important.

In Bridge mode I could use arc, but Roon 2 had problems contacting my airplay units. Apple music had no problem with airplay. So I believe it’s a Roon issue.

Thanks! Setting a fixed 6 digit password for my Apple TV did the trick!