Apple TV repeat passcode request loop

All, I have seen other posts with folks complaining of similar issues. I did not find any of them to actually fix this issue. And with both Roon and iOS doing regular updates, the fix back THEN may not be the fix NOW.

I started out trying the (third party) Roon TV:Remote Apple TV app (so I could use the Apple TV remote and my large screen television to control Roon). Once enabled, Roon could see the Apple TV and one set up in Roon extensions, the TV:Remote worked. However, anytime I try to play a song to it, a pop-up 4-digit passcode pops up and will not let me get past that step. At first I thought it was the TV:Remote app, however Roon proper behaves the exact same way. There are no settings in the current Apple TV AirPlay settings that makes any difference. I think Roon and Apple are not playing well together in recent updates. Both Roon and Apple TV iOS are current. Anyone know of a workaround or do both Apple and Roon need to fix this somehow through future upgrade?

Can you verify that in the Home app, ‘Allow Speaker & TV Access’ is not set to ‘Only People Sharing This Home’?

1 Like

tvOS 15.3 (current version) menu does not have the options you are showing. However, I am guess when you say “home” you mean “AirPlay and HomeKit” menu. In which case, confirmed. I have tried both Everyone and Same Network options, both with and without password. Now I am additionally locked out of my Denon receivers and home 150/250 speakers. If I try to enable, they all ask for password. No clue on a wireless speaker and in receiver menu how to find anything about airplay or passwords.

I didn’t see a response that solved the issue. In spending a lot of time with different settings, the only way I found (currently) to make this work is force the password option. then go into each and every endpoint device previously setup in roon and input the password. For the record, on denon products this can be found in the HEOS app, I think devices, settings, at bottom. I learned all this the hard way, maybe I can save someone else some time by posting here. The thing that is frustrating is I have been using Roon/Denon/Apple for a couple years now, and this was all working perfectly without requiring a password. Trying the stupid Apple TV app (third party) is what triggered all this. For me personally, I wouldn’t enjoy using that app (now that I have played with it a bit) so save yourself a bunch of frustration and don’t bother. I do wish Roon made their own tool to somehow get their beautiful controller on a large screen. I’m out, this is resolved.

Stuck in the same loop. @support Is there any word on how to fix this permanently?

Hey @jasonheyd,

We’re so sorry to hear that you’re in a similar situation and struggling with this. There’s an issue with enabling some AppleTV devices that we’ve been investigating. While I don’t have a specific timeline for a fix, in the meantime, could you please try to:

A) Open settings on the AppleTV
B) Navigate to AirPlay and Homekit
C) Tap on “Allow Access”
D) Set “Allow Access” to “Anyone on the Same Network”
E) Set Require Password to “On” and create a password
D) Back out of the menu to the home screen
F) Try to enable the zone in Roon. It should ask you for the password

Does it help?

1 Like

Hello. It works, yes, but it looks like I need to keep the password in place for it to keep working. If that’s the case then it’s definitely a workaround, but it’s not a fix. I assume that’s the intent and the goal is to make it work without the password being required?

1 Like

Yes, a password is required at the current time, but we have an investigation ticket into functionality with a passcode.


Worked for me also.
But I only get 2 channel via that setup. Any way to get say 5.1 from roon to the apple tv via airplay?

Hi @Peter_Galvin1 ,

Roon only supports 2-channel Airplay content and playback of multichannel Airplay content is not possible through Roon.

So it is now November, did you guys figure out a solution for this problem? Because I’ve got this problem too with the newest Software all over. tvos 16.1, newest roon, etc.

Hi @anon47984560 ,

Please see the solution above:

Thanks. I had this problem too recently, took me a while to find this thread. Thankfully the workaround worked for me but it’s not ideal to have to provide a password. For me I trust everyone on my local network so this is an unnecessary layer just to occasionally play Roon through the TV.

Would appreciate this being fixed ‘properly’ if at all possible! Cheers

1 Like

Well, the workaround does not appear to be working anymore. I followed the instructions, set a password. Then when I enable it in Roon, I get the password prompt, enter the same password I set. And nothing, no feedback at all. Quite honestly, it appears that the password exchange is not even happening, it goes so quickly. The AppleTV is now enabled, can be selected and if I play something, it plays away happily with no sound. ROON, are you ever going to fix the root cause?