Apple TV suddenly stopped working (tvOS 11.4 beta) [Tracking]

Roon was working just fine via Airplay on my AppleTV and has suddenly stopped working. With ATV as the destination output, after clicking play the transport immediately stops.

OS X 10.11.6
Roon v1.4
Apple TV 4k, tvOS beta 11.3

Is 10.11.6 the latest for your Mac?

Yes, it’s an older laptop. However, I was having no troubles until recently using this OS…

Hello @umami,

Are you able to play to the AppleTV using other apps on your laptop such as iTunes? What specific error is Roon giving you when playback stops?


1 Like

iTunes works normally. Roon does not give any errors, it simply does not initiate playback when play is clicked on the transport.

Hello @umami,

Can you confirm what your AirPlay security settings are on your AppleTV? We instituted a change to our AirPlay implementation in Roon 1.3 to ensure compatibility, but you may need to change the settings on your AppleTV to match

A while back, Apple implemented a more secure pairing process for AirPlay devices. Among other things, this makes it more possible to deploy AirPlay in less secure environments.

If you are using an Apple TV 4, we suggest that you set it up in either “Password” mode or “First-Time Passcode” mode. The third option–“Passcode”–requires frequent re-entry of credentials, which is very annoying.


1 Like

In the ATV settings, I only see the option to toggle the password requirement on/off. The “First-Time Passcode” option is not present. Nonetheless, when I enable a password, Roon gives me the error “Airplay device refused password!” but does not prompt me to enter a password at any point. The device is then removed from the list of zones. Attempting to re-enable the ATV yields the same error message.

In Apple TV Settings, under Airplay > Airplay, what does it show under “Allow to Airplay” and Security - Require Code?

I have mine set to Allow to Airplay > “Anyone on the Same Network” and Security -Require Code > “First Time Only”.

When I Enabled the Apple TV in Roon, Roon asked for a 4 digit number which Airplay displayed on my tv screen. I entered the 4 digits and pressed Enter (important for it to save).

It’s working for me.

I show Version 11.3.

Cheers, Greg

1 Like

Same settings for me, except that the security setting simply has the option to require a password or not. “First Time Only” is not present.

Roon does not ask me for the passcode. I believe it used to.

Ok, go into Apple TV Settings > System > Restart (NOT Reset!)

After it reboots, it should go back to “First Time Only”.

See if that works.

Cheers, Greg

1 Like

No luck. I might do a full reset and see if that fixes things.

Does Apple TV not let you click on “Use Password Instead” and change it to “First Time Only”?

Cheers, Greg

1 Like

No it does not. That option does not appear anywhere. Currently doing a full reset. Will update shortly.

Well, a full reset and update fixed it. I still don’t have the “First Time Only” password option, but at least the ATV prompted Roon to enter a password. Bizarre. Given that this was only happening with Roon and not the system as a whole, I am still pointing the finger toward Roon here. Perhaps some kind of caching glitch that doesn’t allow it to forget the previously entered password?

The “old” ATV still appeared in the list of network devices in Roon settings, which is curious. Now, a minute or two later, it’s gone.

Ok, interesting, even though I have Updates set to Automatic, there was a new one in my Apple TV. So I just updated tvOS (although it still shows as 11.3).

Now I get the same setting as you. Security shows Require Password as Yes or No.

No = still gives me a passcode to enter into Roon and it works.
Yes = gives me a generated password. However, Roon give me the Airplay Device Refused Password in Roon. It didn’t even allow me to enter a password into Roon.

Clicking on Require Password and setting it to No still gives me the passcode which works when I enter it into Roon.

Cheers, Greg

@support, please note this change with the latest update to Apple TV (4K version anyway).


Thanks for following up on that, Greg. I feel a little less crazy, at least. :slight_smile:

1 Like

What other app has this level of user involvement and help? Three cheers!

This just happened again with the latest tvOS update. Resetting my ATV to factory defaults every time there’s an update is not ideal. Hopefully there’s a fix in the works.

Amend that–Roon no longer connects to my ATV. Again. After doing a full reset, I am not given a passcode to connect to the ATV.

Hi @umami ---- Thank you for updating this thread and sharing your latest with us. The insight is appreciated and sorry to hear of the troubles.

To help aide in our understanding of this behavior may I very kindly ask you to please verify the following for me:

  • Is you setup still the same as describe here?

    OS X 10.11.6
    Roon v1.4

  • In regard to the update, are you still running a beta version or stable, and furthermore what is the OS number?


Hi Eric,

OS X 10.11.6
Roon 1.4 (build 141)
tvOS 11.4 (15L5536c) As of the latest factory reset, I have beta updates turned off. This is the version that the ATV downloaded during the reset.