Apple tvOS 13 forced update BEWARE

Apple is overriding AppleTV settings and updating devices which are set to NOT automatically update. I think it’s due to the launch of the AppleTV+ service. They’ve done this to two of our AppleTV units which are signed in to different accounts.

Of course, now they don’t work with Roon at all, even after trying to do the Disabled/Enable dance.

Hi @Andrew_Webb,

Can you confirm which version of tvOS you’re currently on? We’ve heard reports that the latest release, tvOS 13.2, resolved issues with Roon playback.

13.2 I’ve restarted everything, and still no luck.

Hi @Andrew_Webb,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you describe how things aren’t working here? Are you able to see the device in Roon? Do you receive any errors?

I appreciate that you’d like to help, but I don’t feel like going through all of the hoops again. Eventually, you’ll ask me to rejigger my network and try again; I know, because that’s what you asked for last time. I don’t have time for that.
Every other device in the house can send to the AppleTVs via airplay without a problem. Macs, iPad, phones.

Roon asks for the device password, and hangs “Enabling”.

Mac running up-to-date Yosemite has the Core. Ethernet. AppleTV v5,3 is on Ethernet as well.

Wel, shoot, it looks like you already figured out that the update you released to save the early-Catalina-adopters from themselves screwed those of us who didn’t rush in… can’t seem to win for losing, sometimes, eh?

The Yosemite fix works. Thanks. You can close this.

I am having this issue also. today. Was working yesterday 11-1-19. Now no roon playback.
Tidal app on TVos works fine. ver 13.0 on apple TV. Model A1625 - 32Gb

Tried disable / enable which did not work.

Noticed the note about version 13.2
updated and its working again. Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.