ARC Bad Connection Issue

I am also having this issue. Roon ARC used to work fine but, for the last month or so, it has been dogged by Poor Connection issues. I have tried resetting the Roon ARC app, uninstalling and re-installing it, turning my phone off and on again, rebooting my iMac, router and internet connection. All of these things help initially but the Poor Connection problem soon returns.

my situation has unfortunately deteriorated per the screenshot.

there is a clear pattern for me. i reboot my imac and restart Roon. everything works fine for a day or two and then I get poor connection messages followed by core not available.

the problem is I am away from home during the week so I cannot just restart my computer.

Hey @Will_Mitchell,

I split off your replies into its own thread to make sure it receives proper attention. Following up on this, is it by chance an issue of your core device defaulting to sleep mode at some point?

If you could please fill out the additional system info needed below, that would be helpful:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Hi Ben,

Many thanks for looking into this. I have just had 5 days uninterrupted with no problems but alas the problem has reoccurred today.

Roon Core Machine

Apple iMac 2021 M1 running OS12 Monterey (latest update installed this weekend)

Networking Gear & Setup Details

My iMac is connected to my wifi network. Router is a TP-Link Archer VR600. I can use my router’s config software to confirm I have the correct port open and it matches the port that Roon has opened for Roon Arc to work.

Connected Audio Devices

All devices work fine at home. It is Roon ARC on my iPhone X that is not working. Today I got the dreaded Poor Connection message again and now I have lost connection to my core.

Number of Tracks in Library

I think it’s about 10,000 tracks

Description Of Issue

I lose connectivity between ARC and my core. It is all set up correctly and it works fine for a few days but then I start to get Poor Connection messages. This usually (but not always) happens when I am away from home and therefore unable to reboot my iMac and restart Roon, which fixes the problem.

I have set up my iMac to ensure it does not go to sleep and is always awake for network requests.

Roon ARC used to work fine last year but this year, I think perhaps post one of the recent releases, I have been having consistent problems.

Many thanks,

Hey @Will_Mitchell,

I would test out hardwiring your core directly to your router. Let me know if you continue to run into connectivity issues after that. :pray:

Hi Ben,

Unfortunately it’s impractical for me to run a wired connection to my router.

Out of interest, I just got home and Roon is not working on any of my devices including ARC.

Here is the error message I get when I try to set up ARC:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Surely a temporary outage of my Wifi shouldn’t cause Roon to become permanently unavailable like this?

I am sure if I restart Roon now this problem will resolve itself but the point is I shouldn’t have to keep restarting Roon.

Many thanks for your help

Kind regards,

Hey @Will_Mitchell,

I understand this may be the case, but it’s an important thing to test. Wifi is unreliable no matter how strong the connection may be. I’d be surprised to hear if the issue continued after testing this out.

The error code you’re seeing usually means that UPnP is working in the router but is having a hard time communicating with the Core. That could be because of wifi, or any VPNs / antivirus in play.

It could also be the case that the autoconfiguration is falling for an unknown reason. Have you tried setting up a manual port forwarding rule yet? That would be a good thing to test as well :+1:

Just wanted to circle back on this. I have been using Roon ARC trouble free now for 2 weeks. I have no idea what changed but the problem has disappeared. I am not sure if it is a recent software update that solved the issue. Anyway, thanks very much for your help guys.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.