ARC cannot connect to Roon Core (Orange ESP; Orange Livebox 6)

Roon Core Machine

Win 10 Dell Precision, 32gig ram Intel(R) Core™ i7-10875H CPU @ 2.30GHz 2.30 GHz

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi I’m getting this from the ARC setup in Roon core:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 85.49.15.65:55091, response code: undefined, body: undefined”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

Firewall is off, UPNP is working. Got this in the router setup:

RoonMobile_broker/69cc9387-61b4-4559-8f41-190cf96173dc 0.0.0.0 55091 55091 TCP 192.168.1.22.

Roon Core IP is 192.168.24. Port is set as 55091 in Roon Core.
Any ideas? Really not good with port forwarding stuff!

I had the same issue. All you need to open up the port on your router for this work. Somewhere on your router should be a section on port forwarding. Roon will let you know the IP and the port for which to set the rule up and you should be good. GLHF

Please give details of the ISP and the router (make and model number) that you are using.

Thanks. I found the issue about 2 mins after posting - isn’t always that the way??. The IP given on the auto config in the router UPNP wasn’t correct so I set up a new rule. Thanks for the very prompt responses. Can I just say this is great?'!!! I dumped Jriver a coupla years ago to go with roon/hqplayer but missed the network access. Thanks a lot

1 Like

2 posts were split to a new topic: Eero Mesh Network: Port Forwarding Issues

I keep getting bumped off. A coupla things I’ve found. The UPnP auto doesn’t work for me, doesn’t show up in the router software as being connected at all. I’ve set up a static IP for both wifi and ethernet connections fot my laptop. Then opened th
e ports manually, but wifi connections STILL keep getting bumped off. OK on ethernet. I’m in Spain using an Orange Livebox 6. The error code I’m getting on wifi is {
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 85.49.15.65:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

1 Like

Thanks for the update. To clarify, you’re having issues when your Core is connected to your router via Wi-Fi?

Looking through diagnostics on our end, we noticed traces suggesting you’re encountering a second layer of NAT, as the Core and ARC are registering variable external IP addresses from your router.

If you only have the modem/router combination from Orange in this network setup and no additional routers, the likely culprit is Orange Espana’s carrier-grade NAT. They offer IPv4 tunneling through dual-stack lite (DS-Lite), but as I understand it, you’ll still need to reach out to them to request a static external IPv4 address for your account. For a little more context, I found this article that I believe references a press release from Orange group in Spain.

It’s an unfortunate situation to find yourself in as a new user of ARC, but not an irresolvable one with many internet service providers.

Generally, reaching out to your service provider to ask if they support port forwarding will be enough to prompt them to explain their implementation and offerings (or lack thereof!).

If you’d like to be more specific, you can pass along the following questions:

  • Have you implemented DS-Lite for my account tier?
  • Have you fully implemented IPv6, or do you have static external IPv4 addresses available?
  • Can I request a static IPv4 address for my account?
  • Are there any ports you have reserved at the ISP level I should be aware of?

Thanks connor - I actually have it working on wifi now. I’ve always found portforwarding hard on Orange, really dunno what happens, it looks fine in the router, but then I have problems. I also find Upnp to be really variable, again no idea why. To get around this this time what I did was to run netstat –na from the command prompt, then found a udp port listed as currently ‘listening’ then set ARC to that port on TCP. Not elegant I know… but working. EDIT: Thanks for the link, >I’ll read that. In the router software despite IPV6 being listed all the open ports are IPV4 - none IPV6, and now Roon is listed under
IPV4

OK according to tech support IPV6 isn’t enabled… I can get a static ipv4 address but at cost. How would this help upnp?

Hi @Julian_Thomas,

What do you have selected for your DNS server in the Orange Box settings?

If IPv6 isn’t implemented by your ISP, then it’s always possible that they’ve dynamically assigned you an IPv4 address within a range. It appears Orange offers PCP to support port forwarding, so I’m hesitant to even blame the situation on carrier-grade NAT at this time. Looking through logs, that doesn’t appear to be the case. Is there any other network hardware in your setup between the Core and the Orange Box?

The interruptions look like timeouts despite decent signal strength, analyzing diagnostics from your report on the 23rd. So, we can try to remove variables one at a time and investigate what’s changing in your network to interrupt the port forwarding.