ARC no connection (Vodafone Gigacube)

Roon Core Ubuntu 20.0.4.5 LTSB Server
Firewall

Vodafone Gigacube Router (Mobile, 4G)
Upnp enabled
There is no option for port forwarding.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxx.xx.xxx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.178.1”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}

I am not a network specialist.
Vodafone offer not a public ip address- is this necessary?

Connection the Core via Ethernet->Switch->Gigacube

Read and checked

Thanks
Daniel

Edit: Ubuntu firewall disabled with no result

On most Vodafone networks you only get a shared IP that is Firewalled by Vodafone. So no incoming port isn’t working on those Networks.

Thanks Basti.

So roon use a technology wich is not usable for many users?
I can start my robotic vacuum cleaner from remote, have a look to my living room via 20usd camera from everywhere but can’t use the great 2.0 arc update for a 699usd licence?
Damn!

Depends on what you want. Your vacuum cleaner and the camera use “the cloud” to connect. Which means the producer exactly knows when the vacuum cleaner is running, and how dirty your living room is… And for the camera… Well, I would not use it…

Hi Daniel

If you – like me – are on Vodafone in Germany then this is a known issue, as I discovered when searching here yesterday. The good news is that it’s apparently being worked on: