Arc - Port Forwarding (UniFi Dream Machine Pro)

Does your Internet provider give you a public IP out do they CGNAT?

I believe CGNAT. I checked my xFinity modem IP address and it is slightly different from what I see when I visit a what’s my IP address website.

Found the below article about xFinity and port forwarding and now wondering if others with xFinity are having problems?

https://www.purevpn.com/blog/xfinity-cgnat-port-forwarding/

I have a unifi UDM Router and virgin hub in modem mode. I have enable UPnP and NAT on the UDM but still no joy. When you say you put your ISP router into bridge mode - did you therefore turn it back into a router rather than a modem? Therefore negating the UDMP as a router? Thanks - Just desperate to get this ARC 2 working!

Try forwarding the required port on both your modem and Unifi Dream Machine. Its what I did on my modem and UDM Pro and it fixed the issue for me.

Thanks Gary - this worked for me just now after hours of messing. Made no change to ISP modem/router - just set up this port forwarding rule in your screenshots - however I used the suggested port in my Roon ARC settings page… Now working so pleased!

1 Like

UDM pro user here. No other routers, just a fibre modem. Auto setup wouldn’t work despite UPnP and NAT mapping being enabled. Added a port forwarding rule as described here and instant success! Thanks.

1 Like

Same here, UDM connected with port forwarding.
But, I keep getting “Something went wrong while syncing to your Roon Core”
Any ideas?

Do you have yours setup similar to mine?

Via unifi.ui.com head to settings and then internet.

Apologies for the mobile screenshot. My laptop is out of action.

I have the UDR, and I believe the menu/options are the same. I was pulling my hair out trying to find this last night and overlooked the internet settings section. Enabled as seen in screenshot. Re-provissioned and all good and working. Hope this helps.

No port forwarding needed with this config.

No, I have a ISP modem and then the UDM connected to it. With port forwarding the check box is ok, i can login to Roon Arc but then I get an error…

I have a UniFi EdgeRouter 12.
I have port forward port 55000, and same port selected in RoonCore.
But get this diagnostic data:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“193.90.241.35”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

I have tried different ports, but can still not get Roon ARC to work.
What can I do?

A post was split to a new topic: Trouble Setting Up ARC

I got it to work by going to my modem’s settings and using IP Passthrough and inputting my UniFi’s MAC address from the down-down menu. But I don’t know whether that would work for different modems or setups.

Try removing the port forwarding rule and setting the UPnP etc as per my screenshot. I am under the impression the UDR, UDM, UDM Pro unifi.ui menu system is the same.

I have no port forwarding rules set, standard firewall rules and after enabling the 3 tick boxes mine just worked.

Is you ubiquiti gear all on the latest firmware?

Ref the ISP modem. Is it a modem/router/switch? If so, is it (if possible) in modem mode only.

I have an edge router, not in use though.

Try running the setup wizard again. I’m sure during the process there’s the option to enable UPnP.

Is this to say the ISP box is in normal modem/router/switch mode.

My problem got solved through another thread, I had to remove the Tags containing Music-objects and then it worked.

A post was split to a new topic: UniFi Dream Machine Pro, Port Forwarding Issues

@Athanasios_Stamatis, this thread is now solved. Please open a new #support thread. Thanks.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.