Arc - Port Forwarding (UniFi Dream Machine Pro)

Does anyone have settings for a UniFi dream machine pro ?

UPnP enabled port forwarding enabled no luck

2 Likes

UPnP does work (at least it did when I tested it months ago:

  • Under the configuration for the WAN interface
    • Enable UPnP
    • Then check the boxes for “NAT Port Mapping Protocol” and the local network for which you want to enable access
    • Save the configuration and it should be good to go

For static port forwarding here is an example of what the rule looks like:

Roon core is 10.10.10.25
The port configured in the ARC settings pane in Roon is 55001

Here is my nucleus screen where are you getting the core ip?


2 Likes

Is your dream machine behind a firewall from your ISP?

Yeah, this appears to be a double NAT situation. What is your ISP and what hardware does the UDM Pro plug into?

Your forwarding rule does appear to be correct.

I just figured it out:). had to put my ISP router in bridge mode.

Thanks for your help!!!

3 Likes

Same thing happened to me.

1 Like

I’m already in Bridge Mode. Any other suggestions?

I have the non-pro Dream Machine.

Does your Internet provider give you a public IP out do they CGNAT?

I believe CGNAT. I checked my xFinity modem IP address and it is slightly different from what I see when I visit a what’s my IP address website.

Found the below article about xFinity and port forwarding and now wondering if others with xFinity are having problems?

https://www.purevpn.com/blog/xfinity-cgnat-port-forwarding/

I have a unifi UDM Router and virgin hub in modem mode. I have enable UPnP and NAT on the UDM but still no joy. When you say you put your ISP router into bridge mode - did you therefore turn it back into a router rather than a modem? Therefore negating the UDMP as a router? Thanks - Just desperate to get this ARC 2 working!

Try forwarding the required port on both your modem and Unifi Dream Machine. Its what I did on my modem and UDM Pro and it fixed the issue for me.

Thanks Gary - this worked for me just now after hours of messing. Made no change to ISP modem/router - just set up this port forwarding rule in your screenshots - however I used the suggested port in my Roon ARC settings page… Now working so pleased!

1 Like

UDM pro user here. No other routers, just a fibre modem. Auto setup wouldn’t work despite UPnP and NAT mapping being enabled. Added a port forwarding rule as described here and instant success! Thanks.

1 Like

Same here, UDM connected with port forwarding.
But, I keep getting “Something went wrong while syncing to your Roon Core”
Any ideas?

Do you have yours setup similar to mine?

Via unifi.ui.com head to settings and then internet.

Apologies for the mobile screenshot. My laptop is out of action.

I have the UDR, and I believe the menu/options are the same. I was pulling my hair out trying to find this last night and overlooked the internet settings section. Enabled as seen in screenshot. Re-provissioned and all good and working. Hope this helps.

No port forwarding needed with this config.

No, I have a ISP modem and then the UDM connected to it. With port forwarding the check box is ok, i can login to Roon Arc but then I get an error…

I have a UniFi EdgeRouter 12.
I have port forward port 55000, and same port selected in RoonCore.
But get this diagnostic data:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“193.90.241.35”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

I have tried different ports, but can still not get Roon ARC to work.
What can I do?