ARC: Port Forwarding with Linksys mesh system [Solved - Request Static IPv4 Address from ISP]

Dear @connor , I’m using a Linksys mesh system and UPNP & NAT are enabled. I’m getting the below error,

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“183.83.170.118”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“183.83.175.239”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:"<s:Envelope xmlns:s=“http://schemas.xmlsoap.org/soap/envelope/” s:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns=“urn:schemas-upnp-org:control-1-0”>\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n"}
}

I have configured Manual port forwarding though uPNP is active.


upnp setting.

Roon COre static ip 192.168.1.25

3 Likes

I also have a Linksys router and have the same exact issue. Port forwarding is set up and I get an error.

1 Like

If you manually specify a port, as you have, you should turn off UPnP.

Check out: whatismyip.com
Make sure that’s what shows up in the WAN part of your Ali keys router.

Next check
ismyportopen.com and put in 55000
Make sure that’s a green check or says: yes it’s open.

I noticed your Linksys is 192.168.1.1

And your room core is set to static 192.168.1.25

Dig around in your Linksys for DHCP settings. There’s a chance the Linksys will assign another computer, phone, laptop, IoT whatever the same IP as your room core which would create all sorts of weird occasional problems. Change the “DHCP Pool” to something like 192.168.1.150 - 192.168.1.230
Devices will get an ip ending in that range, 150-230, and the static up of the core, 192.168.1.25 won’t be an issue.

2 Likes

Hello @Drew_Kerlee1 unfortunately, I keep getting the PORT is closed message after I followed your recommendations.

Do I need to reach out to my ISP? Maybe something needs to be done from their end…

Did you find the WAN side of your router, and confirm the ip address is 183.83.175.239
?

Are there any other boxes that are part of your home network?

To help visualize the network, I made a picture over on this thread-post

Here are general port forwarding instructions for Linksys routers. Looks similar to your screen shots above

I would also look at portforward.com and try to find your specific model. Sometimes steps can vary from model to model.

If you followed the steps correctly, but still have no joy, there are two possibilities:

1 there is another networking box somewhere on your network that you haven’t thought of
2 you ISP blocks that specific port. Some testing

If your ISP blocks the port 55000, tell Roon ARC to use a different port in:
1 Roon ARC
2 port forwarding rule

2 Likes

thank you @Drew_Kerlee1 . I’m looking into the recommendations, I’ll update once I complete them. further, my ISP confirmed that no ports are blocked from their side, and I’m using Linksys Mesh architecture. The Nucleus Plus is connected to the Child node via LAN.

I’ve always found it best to stay in the range of 49,152 through 65,535.

I’ve also always felt higher the port, the better. So make that range more like 63,152 through 65,535. :wink:

1 Like

I’d still check myself.

NO Luck, Yet… :frowning:

@Tushar_das , I have the same error with my “Ubiquiti UniFi Dream Machine | UDM-US” router. Disabling UPnP and manually entering a new rule fails miserably. If I plug my NUC directly into my modem, instead of my router, ARC works perfectly. My guess is it’s a NAT or Firewall issue with my router, but after trying everything Roon suggested, and everything else I can think of, it’s highly unlikely this will work with my modem/router. Bridge mode on the modem failed and port forwarding on the router leaves an ambiguous (and very poorly parsed) JSON response which doesn’t translate into anything useful. Very disappointing.

It’s difficult to think Roon Subscribers will go through this… :frowning:

1 Like

Hi @Neil_Small I ordered an RJ45 to USB converter (Surface do not have a LAN port) to connect to my switch and have a look if there is any PORT configuration that needs to be done… Further, I’m on a Linksys Mesh and N+ is connected to a child node, maybe this child node also need the PORT Forwarding manual entry (in the mesh configuration, even though i try to connect to the IP of my Child node, I get redirected to the parent node IP), my N+ is located in such a way that to move it and connect to the parent Node is going to be too much work…

Opening the port isn’t enough, you need to also forward it to your Roon core. Different routers have different interfaces which is why specific instructions are tricky. If your core changes it’s IP address, the port forward rule will probably also need updating, but usually you can assign a fixed dhcp lease and prevent this happening.

It’s a pity that this is all so geeky, there must be a better way?

2 Likes

Unfortunately, @mikeb I have done all the stuff, No luck yet.

1 Like

@mike , update: Finally got hold of my ISP; working with them to find out why I lose my connection when I put my modem in bridge mode. Hopefully this gets resolved and I stand a chance of testing ARC. After a dozen attempts trying different settings and rebooting Core (NUC), there is no solution on my router that will work. Fingers crossed…

Hey @Neil_Small – is there a thread where the team is tracking these issues for you?

@connor has been out the last few days but I want to make that him and @benjamin have a thread with all the details so they’re able to look over the errors and what you’ve tried so far, and get this resolved for you.

You’re in good hands (you too @Tushar_das) and you should hear from the team soon. Appreciate your patience folks!

1 Like

@mike only what I’ve posted here (that I know of). I should hear back from my ISP tomorrow (Tuesday the 26th). Cheers.

2 Likes

I heard from my ISP, they are saying that from their end they do not block anything or any services. My parent Linksys is directly connected to the ISP Switch.

Reading down this, it looks to me like a few people have an ISP device which then plugs in over Ethernet to their own router which they have configured port forwarding on.

I have a similar (but slightly more complex) setup. There is more than one network address range on the inside of the ISP device (inside meaning the ISP’s router inside Ethernet port and onwards into your premises).

My money is on you needing to configure port forwarding on the ISP router as well as your internal router - same port etc, but point it inbound at your internal routers outside IP address.

1 Like

I have the same feeling… I have a PPPoE connection. The website Open Port Check Tool - Test Port Forwarding on Your Router (yougetsignal.com) says " Port 55000 is closed on 183.83.39.229." The IP 183.83.39.229 must be the external WAN Address… I’m in contact with the ISP for access to the switch to have a look at the configurations it has…

On your linksys, what are the ip addresses on the physical ports configured as (with subnet masks if you can get those too)? Don’t know your graphical interface on the linksys, so am guessing the interface will have the info in two sections; inside will be labelled something like “LAN Address” and the external will be labelled likely as the “WAN Address”.

1 Like