ARC set up with BT hub

Can’t use ARC, I tried several times.
I have at BT hub 27CGGC.
Roon is running on ROCK.
Can anyone tell me what settings are required on the Hub.
Thank you

@Peter_Hayes, please identify your hub using the following page. Likewise, please describe your network, and core in more detail, and share the diagnostic message from Settings > Roon ARC.

If your hub has a similar setup to the Smart Hub, which is what we use, you’ll have to set it up manually.
Here’s the info I entered in my hub settings:-

You’ll need to enter the port number into Roon’s ARC setiings too.



Hi done all this on my Bt smart hub 2

Got a Roon core kit

This error shows

Kind regards

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

The following thread provides a solution for this error, and your modem

1 Like

Hi @Peter_Hayes,

Fortunately, as @Martin_Webster suggested, the majority of BT Hub users have been able to resolve their ARC connectivity issues without too circuitous or technical of a troubleshooting process.

BT usually has IPv6 enabled by default in the settings of the Hub’s web administration page. I recommend disabling that as a first step. Next, follow the bullet points provided by the moderators above. We’ll be here to support if you hit any snags.

1 Like

Hi managed to connect finally . The most critical point is to assign the port to the router which is shown when the core is setting up connection,
The port in this case was 55002 . Another user mentioned 55000 . It will show the port needed when you are trying to connect Arc .
Hope this makes sense. From a novice :blush:

Peter Hayes


Great to hear, @Peter_Hayes. In case you have any issues going forward, please start a new dedicated topic thread, and we’ll keep an eye out.

We hope you enjoy ARC!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.