BT Smart Hub 2 and Arc

Roon Core Machine

iMac Late 2014 OS 11.7 24gb RAM

Networking Gear & Setup Details

SON products connected by wifi

Number of Tracks in Library

54,000

Description of Issue

I have tried to get Arc working but without luck so far.
I have followed a few threads and was hopeful that changing the IPv6 configuration from Stateless to Off may solve the issue, but sadly not.
Following is the diagnostics data
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.254”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}
Any help much appreciated

Do you have a screenshot of your port forward on the BT Hub?
Also have you got Upnp on?
Does the core have a fixed IP connected by ethernet?

disable UPnP and create the port forward manually.

Thanks Phil. I’m afraid I’m a bit of a duffer when it comes to networking.
UPnP is on and here are a couple of screen grabs of settings.


Hi Jez

The screenshots do not show what you have setup for the port forward?

I don’t seem to have anything set up for port forwarding?

This is mine as an example.

Go to room and double check the IP of the core, and then select it from that ‘select device…’ option. Back at Roon, settings → ARC, check the port number, and add it to the start | end boxes. Check that it looks similar (port number might be different). Then, restart the hub and your core. Let us know if that works.

Hi really appreciate your help but still no go! I’m getting the same diagnostics data as before.

Can you do screenshots of the Arc port and the port forwarding on the home hub?

If you test the port number below does it show open or closed?

that is one of the sites that doesn’t give a true indication of whether the port forward is correct.

If you have a port foward setup for 55000 but nothing internally that site will say its closed even if the port forward is correct.

Much better to use GRC shields up as an indication of the port is open

On GRC it will have one of these results if you test with your roon arc port:

Open – connectivity ok through to roon
Closed – port forwarding is ok but can’t see roon
Stealth – port forwarding is not working, ISP is blocking or traffic is not reaching your public IP (cgnat etc)

Look here…

Thanks Phil - screenshots attached. I have tested the port as you suggest and get Closed Port 55000 is closed on 192.168.1.253.


Thanks Chris - I got a ‘Stealth’ rating on this test - Unknown protocol for this port


GRC Port Authority Report created on UTC: 2022-09-27 at 07:03:22

Results from probe of port: 55000

0 Ports Open
0 Ports Closed
1 Ports Stealth

1 Ports Tested

THE PORT tested was found to be: STEALTH.

TruStealth: FAILED - ALL tested ports were STEALTH,
- NO unsolicited packets were received,
- A PING REPLY (ICMP Echo) WAS RECEIVED.

I’ve also got a BT business FTTP circuit at home but don’t use the hub (I have a meraki firewall) but the port forwarding works ok over that circuit so it must be an issue with the hub.

Do you have a static IP assigned?

Thanks Chris

I’m afraid I’m pretty clueless on router settings / networking etc. I don’t seem to have a static IP

for BT it’s not done in the hub, it’s assigned in their network for your account. You would have had to have ordered it as an add-on or during the original purchase.

Thanks - and is this necessary to get Arc working?

nope just makes things simpler.

When I get a chance later I’ll plug my hub back in and test the port forwarding on it.

Cheers - much appreciated

Private message sent.