“Are you online? Please check your internet connection and try again" [Solved Xfinity firewall]

Roon Core Machine

Intel NUK 10 Intel Core i3 Processor
SK hynix Gold P31 500GB PCIe NVMe Gen3 M.2 2280 Internal SSD
Crucial 8GB Single DDR4 2400

Networking Gear & Setup Details

Roon Core hardwired to the internet via Ethernet to Xfinity Wifi Modem

Network Properties:
Protocol: Wi-Fi 5 (802.11ac)
Security type: WPA2-Personal
Network band: 5 GHz
Network channel: 157
Link speed (Receive/Transmit): 585/585 (Mbps)
IPv6 address: 2601:647:5500:8310::5864
Link-local IPv6 address: fe80::acaf:f3cf:c459:fd5c%11
IPv6 DNS servers: 2001:558:feed::1
IPv4 address:
IPv4 DNS servers:
Manufacturer: Intel Corporation
Description: Intel(R) Wireless-AC 9560 160MHz
Driver version:

Roon was up-to-date ( build 227). The latest version is installed last week.

Connected Audio Devices

  1. Hegel 190 Internal Streamer/Internal DAC > speakers
  2. miniDSP SHD Studio > DAC > pre-amp > amplifier > speakers
  3. Bluesound Node 2 > integrated amplifier > speakers
  4. Schiit Modi 3 to Magni to headphones
  5. Apple Home Pod Mini

Number of Tracks in Library

Mainly in Tidal & Qobuz library (c. 150,000 tracks)
Music on flash drive c. 250 GB. (currently 499 albums)
No NAS, 2 Samsung USB Flash Drives (128 GB x2) inserted to NUK.

Description of Issue

I’ve been using Roon for the last 8 months and had the same problem 2 months ago. Yesterday Roon lost connection. I logged out of Roon and tried to log back in after restoring a backup. The ever-so-problematic “Are you online?” message popped up. Thereafter I couldn’t log in to my Roon account as I am stuck in the “Are you online? Please check your internet connection and try again” page.
Thoroughly checked the internet connection but it has no problem. Tidal, Qobuz or Apple Music are streaming without any issues via Airplay. No problem accessing \ROCK\data. This is the second incident within 2 months.

I renamed “Roon Server” folder to “RoonServer_old in the ROCK’s database, restarted the RoonServer (ROCK) in the WebUI to generate a new Roon database folder, which had fixed the same incident 2 months ago. It didn’t help this time.

I am also having a problem log-in to the Roon community page on my desktop. This issue is new and hadn’t this problem before. When I tried to log in from Chrome (or Fire Fox) browser, after a lengthy loading time, “This site can’t be reached” message came out: “community-sso.roonlabs.net took too long to respond” is the additional remarks.

Fortunately I am still logged in the community with my iPad and able to post this report. What’s the problem? @Roon Please run diagnostics and help!

Screenshots below (x3):

This may be a DNS issue. Comcast may not allow you to change your DNS setting on the Xifinity router, but is this an option? Google (using or or Cloudflare ( and many other addresses) may help with this.

1 Like

Can you teach me how to try this? I never changed my DNS setting. I will need experts advise. Thank you.

I have not used an Xfinity router, but there should be an admnistration web page that you can log into by typing into your web browser and using your Comcast login informaiton to open the administration page.

The link below shows how to change your WiFi name, but the screenshot shows an “Advanced” section where you may be able to change the DNS settings. Comcast may not allow this to be changed, but if so, you should be able to type in the Google DNS server numbers (either or and click a “Save” button to save it.

May be worth checking. If the DNS cannot be changed or changing it does not fix your “are you online” issue, there may be other options still open to you.

1 Like

@Robert_F Many thanks for the instruction. I will have to call Xfinity tomorrow and find out the username and password for Gateway. I wasn’t successful logging in. I will keep you posted.

1 Like

Best of luck David, hope this helps.

1 Like

Yes it worked like a charm! Thanks millions! Xfinity agent was able to help me reassign my IP. I am now able to log-in Roon and the Roon community. Not really sure how it had happened but I am now restoring the back up. Thank you again for help, @Robert_F !!!

Now back up restore has been finished and Roon trying connect to my ROCK. Still connecting. Having my finger crossed. Jelly fish is still swimming.

1 Like

Before the backup restore, Roon was loading, but after the backup restore, the “are you online” popped up again!! :((

1 Like

It seems that there may be a configuration issue on your Roon Core. I am tagging @support, but the approach outlined by this thread from Benjamin on the Roon technical support team:

Great to see you again @David_Waring!

I’m sorry to hear you’re running into issues with gaining access to your Roon account. While you mentioned you tried various other suggestions within our support site, I’m wondering if you’ve tried creating a new Roon database? If not, follow the steps below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

While it may resolve the issue entirely, it will primarily create stable conditions for further troubleshooting steps.

If possible, I would also try uninstalling and reinstalling the Roon Remote app on your device. In the meantime, we’ll take a look at your account logs to investigate further.

A good thing to note here, the double restart you tried will only have an effect if we’ve made a backend change on your account, which if we confirm that your issue is tied to the same issue previously mentioned, we can proceed with.

This is that thread’s link:

1 Like

Now I rebooted my ROCK, my PC and the router. I was able to log back into Roon. Adding music to library from external drive. Was able to log-in Qobuz but cannot log in to Tidal. The interface is not working. I am now scared to touch anything if I will be led back to “Are you online?” screen… :frowning:

Are you able to share a screenshot showing what you mean by the interface is not working?

1 Like

@Robert_F Yes, sure. Btw, thanks for the help!

From “services” from the Roon setting, I tried to log in to my Tidal and Qobuz accounts. Logging into Qobuz was successful but music from Qobuz is not loading to my Roon library at all. For Tidal, screenshots show every step I made to link Tidal to Roon. The last step was supposed to show Tidal << >> Roon connected (as I remembered) but the last screenshot popped up.


The next screenshot is the status of adding music to Roon library. After adding 486 albums (which are in my external drive), adding music from Qobuz and Tidal stopped (obviously Tidal is not connected). The blue circle keeps spinning but no more music is being added. I have about 8500 albums from both Tidal and Qobuz combined.

Tags and bookmarks are all lost, some of the albums in my library I merged were all fragmented and scattered. I think I need to restore a back up but I am afraid I will be losing the connection (Are you online?) again.

You may have to log out of both Tidal and Qobuz from within Roon, then shutdown and restart the Roon Core, and then log back into Tidal and Qobuz from within Roon. This has helped resynchronize your subscribtion with both services that other users say works.

1 Like

I will try that and report back to you shortly. Thanks!

Btw. is there anyway I will be able to store a back up without losing connection (Are you online?)? I tried to restore a back up after having changed my DNS (renew IP), I lost the connection to Roon server (Are you online?).

I did as instructed. Before signing into Tidal and Qobuz, I checked the status of adding music from my external drive (connected via USB). The loading seems stuck at this (screenshot). Btw. is there any way I will be able to store a backup without losing the connection (Are you online?)? I tried to restore a backup after having changed my DNS (renew IP), but I lost the connection to the Roon server (Are you online?) immediately. My backup has playlists and tag information and want to bring them back.

Now I will try to log back into Tidal and Qobuz.

@Robert_F Signed back in. I couldn’t go any further than the following two screens. Tidal account isn’t able to establish a link to Roon. I signed into Qobuz but the music is not loading from Qobuz.

I don’t know if it’s a common error but it looks like links between my Roon account and Tidal and Qobuz accounts are completely disabled. I pressed the “Tidal Start Free Trial” button to give it a try and ended up here: This site can’t be reached go.roonlabs.com took too long to respond. I suspect that the Roon is not allowing me to link to those accounts.

I am going to tag @support as there may be more than one issue involved here, especially since you were able to get the system working for a short period of time.

1 Like

I am suspecting that my backups have my old IP information (DNS) which takes me back to “Are you online?” screen as soon as I had done “backup restore”. @support needs to run diagnostics on my account from their end.