Are you online Please check your internet connection

Roon Core Machine


Roon Server Software Version 2.0 (build 1259) production

Networking Gear & Setup Details

Linksys routers, Ethernet, No VPN

Description of Issue

After logging out and re-entering roon,Roon Core is ready,click “Connect” then app prompts “Are you online,please check your internet connection…”.Network is fine,I can access Rock webui and receive the New sign in detected email.

Have you tried rebooting the nuc/Rock?
If that does not do it try rebooting the everything starting at the modem/router.

Thank You bearFNF.
I have tried rebooting Modem/Router/Switch/NUC,reinstalling ROCK OS and modifying dns server in webui.But nothing changes.

Is your ROCK on the same sub net as your remote device, I see, your main router may be on

Out of interest what is your remote device and it’s IP address?

Just a thought.

I see this regularly as I recover from a power cut where the NUC automatically starts up quicker than the network . A few clicks normally fixes it

Logging out of where?

Main router ip address is
All devices are on subnet.

I have used roon for several years and everything is OK. This week I updated roon arc app to 1.0.36 and found it couldn’t connect roon core remotely while roon app was normal.So I logged out(in windows app),but can’t log in any more.

In windows app,sign out.

1 Like

You’re talking about here, right?

Since you say you tried modifying the dns in the web UI, is the web UI set to static IP or DHCP? Have you checked the NUC/ROCK’s ip showing in the router’s interface to see if it matches what is showing on the web ui and windows remote. If not, you might try resetting the network settings on the Roon OS.

I had to do this once when the I lost connection to my NUC after working on the DNS settings in the web UI and inadvertently setting the static IP incorrectly. Might be worth a shot.

Hopefully someone from #support will show up soon and offer more reliable help. I hope you get this sorted soon.

Thank you SisyphusStone.

Still unsolved

As far as I know,several people face the same problem.

Hi @Q_XY ,

Sorry to hear about the issues you are facing here. Can you please use these instructions to access your ROCK RoonServer logs and upload a set for review here?

One other thing you can try is to navigate to your Web UI and try setting a custom DNS server and a static IP. You can try to use google DNS ( or Cloudflare (

I would also confirm if a firewall could be blocking access to our authentication server.

Hi @noris ,

Thanks for your reply.

I have uploaded the log files.

Changing DNS dosen’t work.

I guess the reason is ROCK can’t visit *,and ISP can’t give me any help.

Hi @noris ,

Could you please check my log files and give me some advice?Thanks!

Hi @noris ,

I have updated the roon server to 1272 via web ui,but nothing changes.My roon has been unavailable for two weeks.

Would you please check the log files and find some possible reasons,such as FW or abnormal account status?

Thank you!

Anybody can help me?It’s driving me crazy.

I think I have the same problem.

But before the last logout my roon was normal.

My roon has been dead for 20 days.I have done everything I can imagine.Now I even can’t unauthorize the rock and move core to a local PC.

Could support team provide me any solution?The log files have been uploaded for a few days.


Maybe you could shut down your Roon core and install Roon on your PC. With your current Roon core shut down, that might allow you to unauthorize the old core and authorize the PC core. You could then connect with Tidal and/or Qobuz and import your music files from wherever you have them stored outside of Roon.