Argon Audio Solo Streamer disappeared from "Roon Ready", only works as AirPlay

Roon Core Machine

MacbookPro (M1pro, 2021, 16gb RAM)

Networking Gear & Setup Details

ASUS ZenWifi XT8 - AX6600 (wireless, VPN activated on the Mac)

Connected Audio Devices

Argon Audio Solo Streamer (wireless), connected to Argon speakers with optical cable

Number of Tracks in Library

25000 tracks

Description of Issue

I use Argon Audio Solo as a streamer and it shows up in Roon as “Roon Ready” and I’ve used that as my primary way of playing tracks. After a few days it disappears and the only option that is left Is the “Argon Audio AirPlay” which continues to work. When I reset the Argon Audio Solo to factory settings it’s back as “Roon Ready” but after a couple of days it disappears again.

Hello Martin.
Do you use live radio, by any chance?

Argon Audio is aware of a problem with the Solo and is actively working on it.
See here:

https://community.roonlabs.com/t/live-radio-stops-playing-on-argon-solo-endpoints/224203

Please contact Argon Audio per Mail, so that they are aware of this problem, too.

Thanks for the reply, no I don’t use live radio at all. I don’t have Tidal or any streaming service either btw. Just files on my Synology server.

I will contact Argon audio too, thanks for the tip.

Hi @Martin_Nilsson,

My apologies for the slow response. We’ve been doing our best to get caught up and we’re almost there.

I have sent a request for diagnostics logging that will return to me once you bring the core back online. I want to check and see what Roon thinks is happening when this happens. That said, I want to explore a few of other options too:

  1. A RAAT refresh. I’m hoping something here is corrupted and is the source of the issue.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder
  1. Try disabling sleep for your Mac. If for nothing else, to see if the devices are being lost as a result of sleeping.

  2. If using Time Machine, please either disable or ensure you’re excluding Roon.
    Exclude files from a Time Machine backup on Mac - Apple Support

Please let me know!

Wes