Argon Audio Solo Streamer disappeared from "Roon Ready", only works as AirPlay

Roon Core Machine

MacbookPro (M1pro, 2021, 16gb RAM)

Networking Gear & Setup Details

ASUS ZenWifi XT8 - AX6600 (wireless, VPN activated on the Mac)

Connected Audio Devices

Argon Audio Solo Streamer (wireless), connected to Argon speakers with optical cable

Number of Tracks in Library

25000 tracks

Description of Issue

I use Argon Audio Solo as a streamer and it shows up in Roon as “Roon Ready” and I’ve used that as my primary way of playing tracks. After a few days it disappears and the only option that is left Is the “Argon Audio AirPlay” which continues to work. When I reset the Argon Audio Solo to factory settings it’s back as “Roon Ready” but after a couple of days it disappears again.

Hello Martin.
Do you use live radio, by any chance?

Argon Audio is aware of a problem with the Solo and is actively working on it.
See here:

Please contact Argon Audio per Mail, so that they are aware of this problem, too.

Thanks for the reply, no I don’t use live radio at all. I don’t have Tidal or any streaming service either btw. Just files on my Synology server.

I will contact Argon audio too, thanks for the tip.

Hi @Martin_Nilsson,

My apologies for the slow response. We’ve been doing our best to get caught up and we’re almost there.

I have sent a request for diagnostics logging that will return to me once you bring the core back online. I want to check and see what Roon thinks is happening when this happens. That said, I want to explore a few of other options too:

  1. A RAAT refresh. I’m hoping something here is corrupted and is the source of the issue.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder
  1. Try disabling sleep for your Mac. If for nothing else, to see if the devices are being lost as a result of sleeping.

  2. If using Time Machine, please either disable or ensure you’re excluding Roon.
    Exclude files from a Time Machine backup on Mac - Apple Support

Please let me know!


Hi @Wes
I just ran into the same issue, is there any other "soft* way of resolving the issue ? My Argon Solo is visible as a Chromecast and airplay device but no more as a roon ready endpoint.

I fully understand the steps you described but was wondering if we could skip the whole reset ?


Hi @Sky-Watsher,

This action only resets your audio devices and DSP settings. A full reset may become necessary but I was hoping this reset of devices would do the trick.


Hi @Wes
I contacted Argon guys, and they have no clue, and they also sent me to discuss this here on roon forums (i’m not really sure how and why they are still selling a device advertised as roon ready that it isn’t (at least my device).

Before i do the steps mentioned above, will the RAAT refresh also wipe my listening queues on the end points ? (i kinda have a style per device since they are located in different atmospheres).

Awaiting your feedback.


Hi @Sky-Watsher,

This only sets your audio devices back to disabled and wipes DSP settings. No database-stored items like plays, favorites, or playlists are affected.

I believe this to be the next logical step. I could ask you to do a fresh install of Roon but am hoping this is all it takes.


Hi @Wes
Reporting back : i did the steps mentioned above, but the Argon Solo is still not visible as roon ready (only visible as Chromecast and Airplay).
Worth noting that despite renaming the folder “RAATServer” to “RAATServer_old” adter restarting the core, the new folder was created but nothing was lost (the simple crossfeed DSP im using with headphones was still saved).

Have you tried turning off your VPN as Roons network discovery may have issues with this for RAAT based zones, AirPlay and Chromecast rely on different discovery methods. It would be my first port of call to try this if not all ready.

1 Like

Hi @Martin_Nilsson,

Any update on your status? Did you get a chance to try things with your VPN disabled? (you may need to ensure it’s disabled and restart the Mac for normal network operation). I have one more thing to address and will address it below.

@Sky-Watsher, your issue appears to be slightly different. The SOLO is refusing your connection and your Roon diagnostics logging is full of these errors. Today from 15:11 UTC to 15:33 there are over 20,000 connection errors to the device. I recommend you wipe Roon and RAAT folders on your ROCK with the instructions above.

There was a known issue with the Argon SOLO where their firmware update changed how the device reported to Roon. Does either of you show an unknown device in Roon>Settings>Audio? Do you have the option to find your device?

When I look at diagnostics logging I can only see @Martin_Nilsson’s SOLO initialize and this was back on 2/13. At that time, the device was running firmware version p15235.125.0 but it has since disappeared from the account. Was there a firmware update around the time that the issue started? Can you both confirm your current firmware version?


One more question, are you guys using live radio?


Hi @Wes
1- This is the list of sub-folders i have on the data folder :

  • Codecs
  • MachineSettings
  • RAATServer (& RAATServer_old)
  • Reinstall
  • RoonGoer
  • RoonOS
  • RoonServer
  • Storage

Which one shall i flush with the method above (adding _OLD at the end) ? And will this mess-up my queues and listening history per device ?

2- I can’t find the device under roonready devices on Roon>Settings>Audio; however it is visible as an airplay and chromecast endpoint

I can’t say if there was an update or no, however this is the current firmware showing on the device ip : p15245.125.0

No i’m not.

Hi @Sky-Watsher,

I think I know what’s happening here. For you at least :slight_smile:

The steps I quoted above are what I’d like to see done. This won’t in any way affect your databases but will reset audio devices. You might have to re-enable your devices and lose custom DSP configurations.

I’m thinking that the device identifying itself differently post-firmware update is causing this never-ending connection loop. This will help greatly.


1 Like

Hey @Wes

I’m afraid this is exactly what i have done and reported 2 messages above.
Let me re-do it a second time and report back (in few minutes).

Hey @Wes
Same story, did the steps, device not visible as roon ready (still visible as Chromecast & Airplay end point).

Worth re-noting : after the steps above, roon creates a new RAATserver foldr, but i’m not loosing the DSP applied to my primary endpoint (a desktop dac), Crossfeed is applied and it is still there after the steps.

Hey @Wes
For what it’s worth, the Argon Solo is blinking now although i haven’t sent any stream (neither roon nor LMS Nor Dlna).

Could it be that it is being pinged by Roon ?

So here’s what I see and it’s no different than what I have seen before you made changes.

02/22 22:19:45 Trace: [raat] [Argon Audio SOLO () @] lost client connection. Retrying

It’s repeating continuously. It’s worth a complete power cycle of network elements, Roon core, and endpoints for this reason.

After that, it’s possible there’s a DB issue at play but only one sure way to know and that’s to wipe Roon folders completely and see if connectivity is restored. Do this with a fresh DB and test it before re-importing the DB to test again. Please note, you should back up your database before embarking on this!

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

I am hoping to see something in the logging change and will check as soon as possible.


Hi @Wes
i actually did something i should’ve tried first, which is the well-tried troubleshooting method : Reset the endpoint !
I did reset the Argon solo, and set it again through the google home, and it’s now showing again as a roon ready end-point.

I will watch it for a couple of days and see if it will function properly.

1 Like

This is great news!

@Martin_Nilsson, can you give that a shot too?