Argon Audio uncertified but it appears as a certified device on the Roon website

Roon Core Machine

I’ve recently bought an Argon Audio Solo streamer as a Roon ready device as by Roon website and Argon audio website… Unfortunately Roos says it’s “Uncertified” and won’t let me enable it.
Am I missing something?


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

This is on the Roon Ready list so not sure what’s going on here.
Maybe try restarting Roon Core to see if it pops up.
Failing that @support

Tried a restart to no avail… Waiting for @support

This may have some relevance

1 Like

Hey @Normando_Marcolongo,

Thanks so much for letting us know. I’ve gotten in touch with our partners team and I’ll follow up as soon as I hear back :nerd_face:


Hey @Normando_Marcolongo,

I’m so glad that I just heard back from our team.

It looks like a firmware update should resolve this. If you have questions about how to do that for the Argon Audio SOLO, would you please reach out to the dealer or manufacturer?



I’ll try to reach out to them. Thanks.

1 Like

It worked. For all Argon Audio users out there, despite the lack of documentation, just go with a browser on the IP address of your Solo and click “Update”. That’s it.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.