Astell & Kern announces Roon support - Finally

Too early for April’s Fool so it may be true :laughing:

1 Like
2 Likes

That’s great news. Now to hope they will extend Roon Ready certification further down their line of products launched in the last 12 months and beyond!

@kevin can this be moved to a new Astell & Kern section.

1 Like

I hope it also comes to the excellent SR25.

3 Likes

aahhh… Finally…

Unfortunately this is a “Roon Ready” implementation, meaning the SP1000 and SP2000 are enabled as Roon endpoints, but there is no front end on the AK players. This means you must still use another device to initiate playback on the AK. For my purposes this is hugely disappointing and basically useless.

So, that means if I am in my home and connect the AK player to wifi I can essentially use Roon on my phone or Mac or iPad (via Roon remote) to play out on the AK? That’s terrific, and means I don’t have to type out and search on the screen when using Qobuz or Tidal on the AK.

Exactly. You can listen via headphones or plug the AK into an amp or powered speakers and use it as a Roon endpoint.

1 Like

This is how I play Roon on my Hiby DAP. I installed the Roon app as its not Roon Ready but screens to small to use it effectively so I control it from my phone.

Personally I find this great. Just updated the software on my SP1000 and now it works as a roon endpoint. Can control it from my phone or my computer. Nice display on the screen, and I don’t have to use the screen on the A&K. I really like that the volume control is exposed too and controlled from my other devices. Very nice. And it works with switches of sampling rates which my Focal Arche does not.

1 Like

The SP1000M now shows as Roon Ready on the Roon partners site, but my SP1000M with the latest firmware (1.62CM) does not show up as a Roon endpoint. I searched for a while but I could not find any documentation on how to enable Roon on this device. Suggestions?

You’ve at first to enable Roon in the SP1000 settings.
Then you should see it in Roon as endpoint and you can enable it here.
For playing something through Roon, you need another Roon remote (the SP1000 don’t has one!)…

I can’t see a Roon option in Settings…

Do you’ve really the lastet firmware?
In the settings, there must be a point Roon Ready with a slider for activating it.

The device tells me it has the latest firmware, 1.62CM. No Roon slider in Settings.

SP1000M Roon Ready firmware not released yet, scheduled in August

1 Like

released today

Must be still rolling out, checked my SP1000M and it still claims it’s up to date with 1.62CM.

Just for SP1000 not SP1000M