At end of queue, Radio was kicked off, but the queue failed to advance

Radio is still not working correctly after latest update. I just played the full album of U2 - The Unforgettable Fire and once ended nothing started. See screen capture. @brian

For clarity, is that U2 album in your Roon library (local files or Tidal) or is it just playing from Tidal?

The U2 album was through Tidal, but the same thing happened yesterday when playing a local (AIFF) album. Same exact thing, the radio picks a song to play after the last song on the album has finished which stops playback.

If it just didn’t advance into radio when the queue ran out, that is not really a problem with Radio (at least, not the subsystem that we worked on in the recent update).

That is more likely to be an issue with and audio device not making it through a format transition without getting stuck, or an issue with the play queue itself, not pulling the next track from radio.

Moving this into #support. Hopefully they can tease out what this is and turn it into a bug report.

1 Like

It’s choosing the first radio song to play after the album has finished, if I give the thumbs up that selected track and hit play, there is never any more issues, it’s always on the first song I chosen to play and what Radio wants to choose next, comes after the song has ended… This was the same issue that seemed to be happen a couple updates back, but came back as of update 306. It happens on my ultraRendu and also playback through my iPad.

Hi, @anon94274355, may I ask you to describe your setup here?

Could you, please, reproduce the issue once again? Could you please also remember the timestamps actions you performed to get into this state, post them here and then send us logs from your Core machine. I will contact you via PM with more details.

Thanks!


Ivan

MacMini late 2012 running RoonServer / HQP (polysinc-mp-2s, DSD256) / ultraRendu and using an iPad.

I don’t know what you mean timestamps action?

sorry, @anon94274355, it was a typo. I meant, timestamps of actions you performed to get into this state and time when issue happened, so we’ll be able to find a pattern in your logs.

Thanks!


Ivan

Hi Ivan, I sent you the logs and the very last thing I’ve done with Roon today was to chose a song to play and after it ended Roon stopped and Radio actually chose the next song to play about 2 sec after playback has stopped.

Thanks for info, @anon94274355, confirming that your logs were received. I will write back after we analyze them.


Ivan

Hi Ivan, This issue went away and has now come back. I use an ultraRendu and 2 days ago ran the software update and since this, same issue is back. It’s only the initial song once your queue ends which stops playback, if you chose to play the song that Radio does select (2-3 seconds after end of queue) there will not be anymore playback stopping issues with radio.

EDIT: I think I figured out the problem. I unplugged my router to reset and so far things are working correctly. I wonder if this was the case before, after a software update to the ultraRendu I just restarted the unit and maybe I needed to also reset the router?

Hello @anon94274355,

Glad to see your edit and that things are working correctly (for now). Yes, a router reboot is recommended as a first troubleshooting step when there are network issues at play or when you perform changes to DACs such as firmware upgrades.

I have also gone ahead and enabled diagnostics mode on your account and what this will do is next time that your core is active, a set of logs will automatically be generated and uploaded to our servers for further analysis. Even though the problem seems to be resolved, I wanted to enable this mode in case you run into additional issues. If you do, I kindly ask you to please let me know the exact local time in your country that you see the issue occur at (ex. 1:50PM) and then we can check the logs at that time to see if there are any errors displayed.

Thanks,
Noris