Audio device in use

Core Machine (Operating system/System info/Roon build number)

Nucleus

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

nucleus connected to Devialet 250 via ethernet ( apple router)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

devialet 250 connected via ethernet

Description Of Issue

I start via ipad roon to play music, devialet powers up as it should but then I get message ‘audio device in use’.
I need to restart nucleus core to make it work.
Not a major problem but still annoying…

This happens to me, but very rarely. My solution: switch Devialet to another source (eg UPNP), then give “play” in Roon.
No restart required for Roon.

Hello @Ralph_Dum,

Does this behavior only occur for the Devialet zone or does it occur on other endpoints as well?
Are you using the latest firmware on your Devialet?

Indeed this may be a solution to help ROON understand that there is no audio device in use!

At this point I have only one Devialet input so cannot test it but will do so soon by creating a second input.

best R

I have only one endpoint (devialet). Indeed initially I had kept my ipad as second endpoint ( and even used it now and then) but got rid of it because I thought this could be the reason for the problem.

firmware on my 250 is as up-to-date as it can be given that I have not (yet) upgraded to 250 pro.

best Ralph

If you activated Ethernet input, you don’t have multiple options on source remote button? I do have this on my Expert (UPNP, Roon Ready, Airplay, Spotify, Air etc.).

I could indeed put USB wifi line etc input but I desactivated this via devialet configurator as I use only ethernet. But indeed putting another source input might allow me to solve my ‘Audio device in use’ problem

I have the same setting in configurator (one input only - Ethernet). But, when I press “Source” button on remote, I have multiple Ethernet sources on display. They are all Ethernet inputs, but different protocols (UPNP, Roon Ready, Airplay, Spotify, Air etc.).
Did you tried to press “Source” button on your remote?

I don’t believe the iPad could affect it in this way unless it was communicating with the Devialet through another app/connection.

Are you using any apps to control your Devialet immediately before using Roon, either in the iPad or on a PC?

A post was split to a new topic: “Audio Device in Use” - D200

I avoided using any other app to control devialet. Still it is telling me ‘audio in use’.
Not sure whether pertinent but normally this happens if I play something in say the eveningand then want to play something the next morning…

Best Ralph

Hello @Ralph_Dum,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here.

The next time that this behavior occurs, please note the local time and reply in this thread with the noted time and the behavior you witnessed.

-John

Hi John

Thank you for your help.

The problem occurred again today 17-03 at 09.50 Central European Time.

I restarted the Nuceleus and after it worked again. The problem mainly ( I think even exclusivly) occurs after I have not used the Nucleus overnight ( but again sometimes it works even after a night of non-use).

I repeat it is not a big deal but I am still curious to know why.

best Ralph

Hello @Ralph_Dum,

Thanks for your patience while the tech team looked over the logging information.

What we can see via the logs is that the device is sometimes failing to respond back to Roon when it returning from standby while buffering a track:

Trace: [devialet] [9] waiting for power on...
Trace: [devialet] [9] waiting for power on...
Trace: [devialet] [9] power is on!
Trace: [zone devialet] Unsuspend
Info: [devialet] [zoneplayer]     Open Result (Playing):Result[Status=Success]
Info: [devialet] [zoneplayer] Performing initial seek to 157000
Info: [devialet] [zoneplayer] Starting playback
Trace: [devialet] binding feedback socket
Trace: [devialet] ==> success
Info: [zone devialet] OnPlayFeedback Playing
Trace: [devialet] [Lossless, 16/44 FLAC => 16/44] [100% buf] [PLAYING @ 2:37/6:32] Money - Pink Floyd
Trace: [prebuffer] ready 149940/441000 (34%) @ 157/392 sec
Info: 
Trace: [devialet] device in use (feedback timeout)
Trace: [devialet] releasing feedback socket
Trace: [devialet] ==> success
Warn: Track Stopped Due to DeviceInUse

I suggest that you reach out to the Devialet support team with this report, based on the logs shown above it appears that the device is at fault for not returning the proper status to Roon when returning from standby. We’re here to assist if they are unable to find the cause of this behavior.

-John