Audio Devices in Group are not Synchronized

Roon Server Machine

Roon ROCK on Intel NUC 11 Core i5.
Roon Server Software: Version 2.0 (build 1357) production.

Networking Gear & Setup Details

  • 600 Mbps FTTP (County Broadband), measured 588 Mbps.
  • TP-Link TL-SG1024DE main switch.
  • Netgear GS105 switch between my Dutch & Dutch 8C speakers and the TP-Link TL-SG1024DE main switch.
  • No VPN.

Some audio devices are connected by Ethernet, some by Wi-Fi (see below).

Connected Audio Devices

Roon Ready devices involved in this problem are:

  • Dutch & Dutch 8C (ethernet, via Netgear GS105 - see above).
  • RoPieeeXL on Raspberry Pi 4B (ethernet) feeding Arcam ARV850 receiver.
  • Bluesound Pulse Mini 2i (Wi-Fi).

Number of Tracks in Library

9480 tracks in library.

Description of Issue

When I create a group between two Roon Ready devices (see 3 devices above), they are not synchronized, not even close. I’m not sure when this problem started because I don’t use the group function very often, but I wanted to use it to pipe Christmas music around the house.

1 Like

Caveat, I’m just a fellow user, not support…

…and I’m not at all familiar with your smart switch, but it might be related to how you’ve set up traffic prioritizations or the like.
Best to temporarily try and remove your smart switch from the picture to see if that does wonders, and then go from there.

You haven’t said if you’ve done any troubleshooting, if you haven’t already reboot everything from the router outward.

Blusound products have a known issues with group sync and Roon. There is a thread about it. Take this one out and see if the rest kept in sync. You may need to adjust the sync delay to get them in sync but then should stick.

I don’t have any traffic prioritization set up on the TP-Link TL-SG1024DE. I haven’t changed any settings on it for years and group synchronization used to work.

I’ve power-cycled the router, the main switch, the secondary switch between the D&D speakers, the Pi-hole (forgot to mention that), the Roon ROCK, the speakers, etc. No difference.

I have another Roon Ready device too, which is Roon running on Wine on a Pop!_OS (Linux) desktop computer, and I’ve experimented with that too.

When I create a group of two devices, sometimes they are synchronized (to my ear) and sometimes they are slightly off, and sometimes they are not even close. If I ungroup and recreate the same group, sometimes it gets better and sometimes not.

It does not seem to be specific to a particular device, e.g. the Bluesound player. One time I grouped the Bluesound player and Roon on Wine and they were synchronized. Another time they were not. Then I tried two other devices (not Bluesound) and still it’s no good.

I have a hunch that it’s the secondary switch between the D&D speakers. I’ll have to go down into the cellar and change how things are connected.

Back soon.

I powered off the secondary switch (Netgear GS105) that connects the two D&D speakers so that those speakers are isolated from the network.

Still no good.

I’m now at my second home where I have another Intel NUC running Roon ROCK. It’s an Intel NUC 10 Core i7 this time. I have one Roon licence, so I deactivate one core and activate the other when I arrive.

I have the same problem with bad synchronisation in a group of two audio devices. It tends to happen when I start playing a different album. If I then restart the track or go to the next track, it is OK. Then I switch to another album and the problem starts again.

As before, the devices are Roon Ready. This time they are:

  1. Bluesound Pulse Mini 2i (same as in the main house).
  2. Weiss DAC 501.

Are other people having this problem?

Hi @bananasareyellow,

Thank you for your patience.

@Simon_Arnold3 is correct. Issues affecting Bluesound grouped Zones are tracked and ticketed with both our team and Bluesound’s developers, who will be releasing a fix via future BluOS update.

The relevant tracking thread in this forum is here: https://community.roonlabs.com/t/nad-bluesound-grouped-zones-out-of-sync-stopping-playing-and-or-skipping-tracks-investigating/243606

If you have issues affecting the Weiss only, without the Bluesound devices active at all, please let us know. Otherwise, we recommend following the aforementioned thread.

I don’t think this is to do with Bluesound players. Or maybe there are problems with other Roon Ready endpoints too.

I first experienced the problem at my main home over Christmas between the Dutch & Dutch 8C speakers and RopieeeXL in the next room. This was not involving the Bluesound player at all.

I also found the problem occurred with the RopieeeXL and Roon on Wine on a desktop computer.

The common denominator in those cases was RopieeeXL.

I’m still at my second home. I tried the Weiss DAC 501 grouped with Roon on Wine on my laptop and it works fine.

My tentative conclusion is that there is a known problem with Bluesound players and there might also be a problem with RopieeeXL.

There have been two software updates to RoPieee recently, so I tried again just now to see if this has fixed the synchronization. It hasn’t.

Started playing on Dutch & Dutch 8C and then added RoPieee to create a group. It is not synchronized. Not even close.

This is not a Bluesound problem.

I also have Dutch speakers in one room and a Ropieee in an adjacent room. I added a delay to the Ropieee of about half a second and it’s been fine since then. I determined the delay by setting a mic at the doorway between the rooms and measuring the time difference between the 2 pairs of speakers in the group.

Having to add half a second delay shows that something is not working properly. Also, it used to work just fine, about 6 months ago.

Doesn’t it just mean that the Dutch has a longer delay because of its processing for dsp? How would Roon know the time between when the endpoint receives the signal and then outputs the sound?

I didn’t have the Dutch until recently so don’t have an earlier comparison.

All I can say is that it used to work fine, without having to add any delays.
The D&D speakers are Roon Ready, so I would assume they worked with Roon to do whatever is required to achieve synchronisation.

What firmware version do you have in the Dutch & Dutch speakers? There were reports of sync problems in Grouped Zones back in October, which appear to have been fixed by firmware 2.4.59… See:

I have 2.4.53, which it says is the latest firmware. Maybe 2.4.59 has not been released yet?

Perhaps you should contact Dutch&Dutch; I see nothing in that thread I referred to that suggests that 2.4.59 was not yet available…

1 Like

Thanks, I will.

I contacted Dutch & Dutch support and they did something to make the latest firmware version available. I am now on 2.4.78 and this has fixed the sync problem between the D&D 8C speakers and Ropieee.

My Bluesound Pulse Mini 2i also showed an upgrade, and now I can sync all three of them and it all works fine.

3 Likes