Audio Dropouts and High CPU % Utilization

Core Machine (Operating system/System info/Roon build number)

2017 iMac running Catalina with 40GB of RAM. Library on FreeNAS Server. Just upgraded to Roon 1.7 (Build 500)
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired Ethernet going through a 1GB Netgear Switch then to a Comcast Router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Schiit Modi 3 connected via USB to iMac described above.

Description Of Issue

  • Just upgraded and I’m getting audio drop outs at irregular intervals, but they happen over and over again. This is happening with songs from my local library, using Tidal or using Qobuz.

  • Scans on start up are taking 4X-5X longer than previously.

  • CPU % is being driven at or over 100% at irregular intervals.

I have closed all other applications, rebooted, run network diagnostics. All is good otherwise with the system. Roon is my only problem.

Hi @Steve_Kaye,

Is your library currently being re-scanned after the update? Depending on the library size and performance of the Core machine, this process can use up quite a bit of resources until it completes, but things should return to normal after that.

No. The rescan is done. I left the system alone to do the re-scan after the upgrade.

Hi @Steve_Kaye,

I propose a test here to eliminate some variables. Can you please:

  1. Select “System Output” as the audio destination
  2. Have no DSP active on this zone
  3. Try to start playback of material that was causing issues before
  4. Note the exact local time + date of failure (if any)
  5. Send me a copy of your logs by using these instructions?

Will do. First thing in the morning.

1 Like

Test completed. Link to logs sent via message.

@noris @Dylan Logs sent yesterday. When can I expect a reply?

Hi @Steve_Kaye,

Thank you for sending those logs over. I took a look through them and I’m not noticing anything particularly interesting, I don’t see your buffers dropping or traces for dropouts, it looks like the track is playing as expected in logs. We just released Roon build 505 which contains some improvements with regard to buffering, can you please try upgrading and let me know if the issue is still the same?

Full details here:

@noris @dylan I’m cautiously optimistic. I have installed the update and also tweaked some settings on applications that were hogging some system resources as well. I have been playing music from my NAS (FreeNAS using SMB) for the last two hours and there have been no skips.

A couple of questions:

  1. What should I look for in the logs if there is more skipping? I’m comfortable combing through them if you can highlight areas of potential concern.
  2. What priority does Roon run at? It appears to be quite low when using Terminal and the following commands – ps -fl -C PID . Renice could be an option if applicable.
1 Like

Hi @Steve_Kaye,

Thanks for the update, glad to hear that there’s been an improvement!

Ideally, you wouldn’t need to check logs for this behavior. The Roon History tab should provide some useful info without needing to dig into diagnostics. If you see a track skip prematurely (and you didn’t press next/prev track) that would be a good indication that something occurred for that track.

I wouldn’t mess with the priority for Roon. This is not something that we test for and changing the priority might cause unexpected behavior.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.