Audio Settings Error - 2 computers listed as same device

Core Machine (Operating system/System info/Roon build number)

Mac OS X 10.15.5 - iMac 3.6GHz 8 Core Intel i9
Roon Version 1.7 (build 555) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ubiquiti UniFi multi (3) Access Point network, with many devices including iMac running Roon Core connected over gigabit ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

6 Sonos devices - 4 connected over ethernet to main switch, others connected over wifi / sonosnet
Chord Mojo/Poly (wireless)
several iPhones and iPads connected wirelessly as controller and output devices
iMac running Roon Core (called Steve’s Pro iMac) is set up as an Endpoint / output device
Additional iMac (called StevesiMac) connected wirelessly as both controller and output device
MacBook Pro (the problem device - called Steve’s MacBook Pro) connected wirelessly as controller and output device - was working correctly until now, but problem is now that Roon Core sees this MacBook Pro’s output device as if it were on the same physical machine as iMac running Roon Core!

Description Of Issue

As stated above, set up was working correctly until today. However now, under Roon > Settings > Audio the MacBook Pro is no longer is listed as a separate computer and Roon Core seems to think the audio device of the MacBook Pro is part of the same machine / the iMac on which Roon Core is running! The output devices of the iMac running Roon Core and the output devices of the MacBook Pro are shown in settings as “These devices are connected to your Core directly”

The additional iMac and it’s output devices are listed separately in Settings > Audio:

Viewing Settings > Audio from the additional iMac itself is listed as “This Mac” with it’s correct network bios name. However there is no separate listing for the MacBook Pro.

Aside from the other non OS X devices (which all appear and work normally) the only other listing in Settings from the additional iMac is for “Connected to the Core” which lists both the iMac running Roon Core (with it’s network name “Steve’s Pro iMac Output”) and also the MacBook Pro (with the name “MacBook Pro” - if disabled it is listed as “Built in Output” in addition to the main built in output for the iMac running Roon Core)

Viewing Settings > Audio from the iMac running Roon Core, the additional iMac can be seen listed with its own local IP address and network name, but nothing for the MacBook Pro, other than it appearing as a further built-in output device for the Roon Core iMac.

For clarification, the MacBook Pro is connected to the network correctly with it’s own IP address and can be seen separate and connected to in Finder along with both the Roon Core iMac and the additional iMac. There are no networking problems other than how the MacBook is seen by Roon Core.

I have tried uninstalling and reinstalling Roon on the MacBook Pro, each time being asked if it wishes to connect to the Roon Core already set up on the main iMac. Once reinstalling the MacBook shows as a device which needs updating and restarting, but it still does not show up in Settings > Audio.

If you select the MacBook Pro as the output device and play music, the MacBook remains silent and the music is routed to the built in speakers on the iMac running Roon Core.

I am completely at a loss what else to try. All other endpoint devices show up when connected to the network and the MacBook previously was listed until now.

Any help would be greatly appreciated. Apologies for the lengthy explanation.

Did you clone one Mac to another Mac?


Do you mean clone the whole Mac or just moving the whole Roon Core from one Mac to another?

If you mean the former then I had wondered myself if this was something to do with it.

Before the iMac that now has Roon Core on it, Roon core was originally located on the other iMac (when began Roon trial period).

Then when new iMac arrived (before Roon Core was installed on it) it was set up from a TimeMachine backup of the MacBook Pro (not the original iMac). However I specifically didn’t copy over ‘Computer and Network’ Settings in Migration Assistant to new iMac from the MacBook, and both new iMac and MacBook have different net bios names (so can see each other and connect normally as you would expect).

I then did a migration of the Roon Core from other iMac to new iMac, having to deactivate old iMac from Roon in the process.

However I was thinking along similar lines and wonder if somehow the new iMac has acquired something from the MacBook in the process which makes Roon think they are the same device!

I have AppCleaner on all my macs and so when I have tried uninstalling Roon from the MacBook AppCleaner finds and removes all associated system files, but perhaps not well enough?

I could try migrating Roon Core back to old iMac and uninstalling Roon on iMac which currently has Roon Core (using AppCleaner) and reinstalling to see if Roon Core first sees them as separate devices while Roon Core still on old iMac? Maybe if that does the trick not sure how I should make transition back to Roon Core on the new iMac? What do you think?


I mean a clone or, at least, a partial clone in some manner. Moving Core from one machine to another wouldn’t result in what you’re seeing. People do that all the time.

I once cloned one RPi to another and got somewhat the same confused results as you have.

Roon identifies the machines it’s running on with unique ids and when you clone one to another the new machine ends up with the same non-unique id.

De-install Roon from one machine, of your choosing, and re-install it. Make sure you get all the Roon pieces. See if that makes a difference.

1 Like

Hello @Stephen_Dixon and thanks for the detailed information! Our development team is aware of this issue and is actively working towards a solution. I can’t offer any timelines on that release just yet, but we appreciate your patience while we resolve this issue. Please let me know if you have any questions.

Out of curiosity what “unique ids” is Roon Core using for each machine?

Just to rule out the obvious, both machines have different local IP addresses and MAC addresses - the iMac obviously has 2 MAC addresses; one for the LAN port and another for the WiFi card - both of which are different to the MAC address of the MacBook Pro’s WiFi card (in fact having checked they are not remotely similar!). There’s no LAN port on the MacBook and it can’t be connected that way without using a thunderbolt/ethernet adapter of similar.

When you say to de-install and “Make sure you get all the Roon pieces” are you aware of what those pieces are. As mentioned before, I use AppCleaner to do all deinstalls and this finds and removes all associated Plist files any everything. Once used this I have even done a full system files included finder search and there are no results for any related Roon files unless there are some less obviously named ones you can tell me about?

Will also do a complete un-install on the new iMac which is running Roon Core too to see if this helps. Can anyone confirm if the Roon backup files will contain anything I would not want to have put back after re-installing in this instance? Or should I just set up Roon Core from brand new, without using an old backup? Haven’t been using it for that long, so wouldn’t be the end of the world.

Presumably this would lose album’s I’ve added to my library through Roon from Qobuz though would it?

As was in the above link -

For the Core, everything that’s in these folders -

You shouldn’t need to do this, but as long as you have a Backup then it can’t hurt.

Yes, a Restore will put everything that you want back to where it should be, without causing you your present difficulty. If you are going to Restore then I would do that first, before you deal with the endpoints. Out of superstition, I would disable the endpoints before you reinstall to them, just to be sure you’re generating and using a new UniqueId. Of course, before you do anything always Backup using Settings==>Backups.

Here;s a couple of useful links -

Your Qobuz selections are in Qobuz Favorites and that will repopulate Roon.

In an above post, @nuwriy seemed to imply that this problem was caused by something that Roon Devs were working on to change and that you had to wait for that to fix your problem, as least that’s how I read it. I think that the reference to the Devs was that they were going to change the process so that one wouldn’t run into this problem. You should be able to fix the problem without waiting for the Devs to change something. Is that true, @nuwriy?

Hello @Stephen_Dixon, are you running the latest update version 571? We added some fixes there for this issue and if you aren’t on it yet, give it a try and let me know!

@Stephen_Dixon, Settings==>About will display the Unique ID for each endpoint running RoonBRidge -


Sorry for the slow response. Not been too well. However thank you @xxx for this (hadn’t realised the Device Info was there, or it was so informative) and also for your hard work trying to help with this so far.

As it happens, since looking into this further I started to discover some other bizarre behaviour of the 2 Macs concerned outside of Roon - won’t bore you with the details, but even though I would consider myself to be fairly competent (certainly by most home user standards / non IT professionals) some of these issues simply defied all basic logic and the results were consistently inconsistent! In the end, I did a complete fresh install of OS X Catalina on both affected Macs and, low and behold, Roon reinstalled perfectly without the same problems occurring and all the other mysterious issues were suddenly fixed.

I guess after you’ve spent too long trying to find the source of a problem to try to fix it sometimes it’s quicker to go for a more draconian approach, which at least rules out a lot of potential causes. So still no idea what was causing this (but it clearly wasn’t Roon!), or the other problems, but for my money it was something strange that had been picked up the first time around via Migration Assistant that hadn’t been resolved with the hours wasted trying to find it or change settings. Oh well, I’ll live to fight another day but thanks again for your input :wink:


Hello @Stephen_Dixon, glad things are working again! Please let us know if you need help in the future.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.