Audio Tracks Get Skipped [resolved: was realtek driver issue]

I am running into the same issues no audio, tracks get skipped.
Firewall disabled
windows 10 - 2004
Roon server running on separate windows 10 system
used to work.

uninstalled roon, renamed raatserver, reinstalled - didn’t fix.
Roon plays fine to other devices, phone (android), PS audio DS, etc.

Hello @bullclan,

Can you please clarify which devices are impacted in that case?

Please provide a clear description of your setup according to this thread so that we can better understand the issue:


1 Like

I started to reply to you. It wasn’t working, but while troubleshooting it started to work. Below is the thread as I typed and troubleshoot.

Thanks for the request, haven’t signed in for a while. Other audio sources work (web browsers, media players (i.e. Plex; vlc). Only issue is (was) Roon.

Issue is with Windows 10: 2004 (OS Build 19041.450)
Just upgrade Roon versions to latest
core: 1.7 build 667
PC: 1.7 build 667

I have multiple audio device and haven’t had any work recently. The behaviour is the following:

gamingputer: Audio device that maps to system default. Tracks are skipped. You pick an album to play, click play and it skips though all tracks to the end.

Realtek (analog): WASAPI device: it plays, but no audio.
Realtek (optical): WASAPI device (2): skips

It used to work.
I did uninstall/reinstall - no change.

Roon DSP disabled
Audio devices, did reset to default in Roon
In windows I have tried disabling all devices not in use or needed (NVIDIA audio, Realtek Optical, etc.)
Audio output via 2.5 audio cable.
I do have two audio device plugged in to the Realteck Audio device (ports on the motherboard). One as Headphone, the others as Front Audio 2.1 speakers.
I did unplug one; no change.

I did try another USB DAC (PS Audio USB (via Sprout 100) WASAPI - it works
With the PS Audio device plugged in; I was also able to switch gamingputer (default device; PS audio is). It also works (expected).
I removed the PS Audio (borrowed from the kitchen); Windows switched back to Realtek High Definition Audio) and roon still works.

Not sure if this behaviour has happened before? I was testing some pre-release audio driver around the time this stopped working, but not exactly). As all other audio worked I didn’t expect it and didn’t mention to the end as to not squeue what it might be.

At this point not quite sure. If you want me to grab any logs happy to send over, glad I fixed it, but to be honest was trying the PS Audio to say I tried a 2nd device.

If you got this far, thanks for reading. Again, let me know if logs would help?
if not, you can close this one out.


Hello @bullclan, and thanks for the update! I’m glad things are working again! Given the timeframe, I’d say the logs we’d need are likely overwritten by now. But if this issue happens again, please reply here with a timestamp (your local time) and we’ll enable diagnostics for your account!

rebooted my computer and it just happened again. 21:07. 10.28.2020

Thanks, @bullclan. We’ve enabled diagnostics and will take a look!

Great news. I tried to play multiple albums and a radio stream. All failed, both local media, qobuz and radio. When it ships over it’s not increasing the last played info.

This is happening on the audio device 'gamingputer". Windows 10 has the default device correctly assigned and other sources still work.

Hello @bullclan, could you please use the directions found here and send us over a set of logs using a shared Dropbox link.

Logs from Roon Server here (no client logs):

Any known issues if I upgrade to Windows 10 - 20H2?

Let me know if you need more information.

did you see anything in the logs?

Hello @bullclan,

Please accept our apologies for the delay here! I took a look at our internal tracker today, and I can see that your ticket is still in our review queue. A member of our QA team should be reviewing this soon and providing feedback.

I’ve requested an update from the team and upped the priority in our tracker so I should be able to get back to you soon with an update. Thanks in advance for your patience!

There is more information I can provide to our QA team to help them diagnose the issue. I see you’ve tried radio, local, and Qobuz content to system output of “gamingputer” but could you please elaborate on how this remote is connected to your network? I’d also like to know what router you’re using and how it connects to the core. Thanks!

All 1GbE connected
Cisco 2960g switch
Routing via SG300~10 and FW is UTM

Again if plug in a DAC (audio quest colbalt or pa audio sprout) it works.

Let me know if you beee anything else.

Hello @bullclan, and thanks for the info! On your PC, could you please point system output to your PS audio in the “Select Playback Device” window in Windows and see if you’re allowed to play to system output then? I’d like to bypass the realtek drivers windows is currently using for system output to see if this changes things. Thanks!

when I connect a DAC to the PC it works (colbalt/ps-audio sprout)
doesn’t play with the realtek drivers

how can we make troubleshoot the realtek?

No other issues with audio, web browser, vlc, plex…

thoughts on how to troubleshoot further?

Hello @bullclan, so we found that pointing the PC to the cobalt works fine. Can you try reinstalling the realtek driver?

a full uninstall, reinstall of the realtek driver and installing the realtek control panel manager fixed the issue. Can you turn of extended logging for my account?

Hello @bullclan, will do! Glad things are working again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.