Audio zones disappearing on Mac Mini

I’ve noticed this as well in the past few days. Seems it’s the latest version of Roon Core, as I’ve made no changes to my setup. I’m running a MacMini (latest version with fastest processor and 8GB memory and external USB attached drive with all my music). Does not happen when “tuned” to radio stations. Notice that the iPad app shows that the music seems to have been paused waiting to have me start it again. I don’t think it’s the apps fault. It would be great to have some means for capturing what takes place (meaning what caused the sudden stop).

One other thing to mention: seems to happen on the first track of an album I’ve just added to my queue. But that’s about all I can tell. It’s infrequent enough that it’s simply inconsistent otherwise. By the way, I’m at the bleeding edge as I’m running the very latest public beta of Sierra on the server. That’s likely good news for testing (though it might foretell problems going forward), but not helpful to others. I’m game for trace/trap if that would be useful to development…

Hi @stevebythebay ----- Thank you for the report and sharing your feedback with us. To hep me better evaluate this “skipping” behavior you are reporting, may I kindly ask you to please provide the following information:

  1. A brief but accurate description of your current setup as seen here.

  2. Please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a complete understanding of how your devices are communicating and what tools are being used to make those connections possible.


Roon 1.3 209 64bit / OS X 10.12.4 v4 / Mac Mini late 2014 2.8 Ghz i5 8BB mem / music stored on USB 3.0 attached WD 5TB hard drive as AIFF / 37650 tracks. The Mac Mini has an Ethernet wired directly to the microRendu and an additional Thunderbolt to Ethernet adapter wired to a port on an Eero WiFi access point - these using a virtual network setup. The microRendu outputs USB to Berkeley Alpha USB convertor which feed a Berkeley Ref. v2 DAC. One thing I noticed is that one setting I didn’t think I’d missed was improper on the system settings - namely BlueTooth. Toggled it off. Also verified that InfraRed was disabled. I’ll need to continue playing music to see if the symptom of sudden stopping reoccurs. I’m suspicious that a recent Apple OS update may have switched the BlueTooth on, though I’ve nothing in my room that should cause the system to react adversely to this setting (my iPad does not have it enabled). But what with such technology, you never know what might trip up an application. Let me know if there is a list of apps/processes/setting for OS X I should review to minimize issues and enhance performance of Roon. I will say that at one point I placed a Cisco switch between the Mac Mini and Eero, thinking it would prevent any Eero interference with the Mac Mini network, electrically or otherwise. Wondering if I need to reintroduce that bit back into my system. My normal inclination is to use the KISS (keep it simple, stupid) principle but that doesn’t always apply.

Hi @stevebythebay ----- Thank you for following up with and taking the time to answer my questions. Both are very appreciated!

I think it would probably be worth putting the switch back into place and plugging everything in. Can you please reintroduce the Cisco switch back into your setup to see if these triggers a change in behavior?


I’ve not experienced any sudden stoppages playing back music from my library since changing the Mac OS X setting and disabling BlueTooth. Obviously that may not have been the culprit. I’ll consider adding the Cisco switch back into the mix if needed.

By the way, not sure when the change took place or if it was with a Roon or Roon app update, but using the Internet Radio feature of the app has improved immensely. I rarely, if ever, run into problems requiring me to kill the app and start it again to allow using this feature. And the response to switching to different stations within the app is now much faster, especially for stations closer to home (S.F. Bay Area), vs. those overseas.

1 Like

Hi @stevebythebay ---- Thank you for the follow up and sharing the results of your testing with the BueTooth connection being disabled. Please due keep me updated on any other observations that are made, should you find yourself at a point where the switch is added back into the chain of communication.

Just to make sure I am on the same page as you, would you say that things have stabilized and are remaining that way thus far?