B1182 Android app can't find Roon Core

Roon ROCK - build 1180 (early access)
Android app - build 1182 (Google Play beta)

The Roon app on my Android phone was showing Connecting with a red dot. Tried reinstalling the app and tried reinstalling Roon ROCK from the web page. Now the Android app shows this:

This happens on my wife’s Android phone too. She is not on the beta stream but has the same build (1182).

Other Roon remote apps in the house work fine:

  • Roon on Bottle (Wine) on 3 different Pop!_OS computers.
  • Roon on iPad Air.
  • Roon on iPhone.

How can I fix this?

Restarted the Wi-Fi access point in case there was a network connection problem. Now it’s back to the screen I saw first:

I think this might have something to do with my network, although everything was working fine yesterday, so I can’t think why this has started to happen.

I have 3 Wi-Fi access points in my house, one is the broadband router and the other two are re-purposed old routers connected to my wired network. They all have the same SSID and password.

The problem with not being able to find the Core only happens when connected to one of the re-purposed old routers, which is in the study, although this Wi-Fi access point is one I connect to most of the time. If I move to a different place in the house so that I connect to a different Wi-Fi access point, the Core can be found with no problem.

I haven’t made any changes to the network since yesterday when it was working fine, and the problem only occurs with my Android phone and my wife’s Android phone. The problem does not occur with my iPad Air, my daughter’s iPhone, or my laptop (Roon on Bottles), even though they are in a part of the house where they would have to connect to the study Wi-Fi access point.

I’ve restarted the Wi-Fi access point, the router, the network switch, and my Pi-hole but the problem persists. I’ve also restarted my Android phone, but that didn’t help either.

Does anyone have an idea what the problem might be?

They changed it so that all remotes need to be on early access. So in your last screen shot it shows a mix of Production and early access.

You will need to go to your app store and join the beta programs on all remotes or conversely “leave” the early access on the core and all remotes.
See this KB (how do I join or how do I leave sections):

I went through the same thing and as soon as I “joined” the early access on all remotes it sorted itself out with a few updates and a reboot of the core.

I have a problem where my Android remote just can’t talk with the core. I start a playlist, go on my way, come back to the phone and now it has no clue where the core is.

Reboot the phone.
core returns every time.
same version on core/remote

It isn’t your network.

Everything is on Early Access except for my wife’s Android phone.

The only thing I have done since yesterday is I restored the automatic backup from the early hours of this morning.

Note that my Android phone is on the beta stream and my wife’s phone is not, but they are both at build 1182.

ALL remotes and the core either need to be on early access or ALL remotes and core need to be on production. If they aren’t there will be issues (incompatible version warning, inability to connect to the core, etc.) and instability potentials. It may have been working but it wont anymore as Roon changed it on their end and require either all early access, or all production.
See the answer to this question here:

1 Like

The problem occurred on my phone which is on the Google Play beta stream. After a long time I checked my wife’s phone (not on beta but it is the same build number) to see if it is a problem just with my phone and found her phone has the problem too. I installed Roon on her phone several weeks ago but she does not use it. Both phones work if connected to a different Wi-Fi point.

That screenshot does not show a mixture. The production label refers to RoonOS but the Roon ROCK is Early Access (not shown in that screenshot).

I’ve been in town for the last few hours. Just got home and now the problem has gone away!

I wondered whether the Android app had been updated to a new version, but according to Settings/About, it is still at build 1182, and looking at Google Play to see what has recently been updated, Roon is not listed.

Very strange indeed.

I’ll see if it is still working fine tomorrow.

1 Like

It is now tomorrow and it’s still working. A mystery.

It has happened again. I was away at our second home for two weeks, just got back to the main home and restored a backup from the second home. Both have a Roon ROCK.

A few weeks ago, I put everything back onto the production stream, so nothing is using beta now.

Same symptoms: Android devices connected to one particular WiFi access point can find the core but they can’t connect to it. My iPad is connected to the same WiFi access point and has no problems. If I move my Android phone to the other end of the house so it uses a different WiFi access point, it is fine.

Very strange.

This happens to me far too frequently. I reboot the phone and it can find the core again. Not sure what’ the cause is, but that gets it working again for me at least.

I restarted my Android phone, but this made no difference.

Sometimes it seems to get stuck trying to find the core, and other times it finds the core but gets stuck connecting.

1 Like

Roon on Bottles (Wine) on my laptop (same WiFi access point) is now having intermittent problems, but sometimes it works. Go to the other end of the house (different access point) and it works fine.

Just like last time, after several hours, the problem went away. I wish I knew why.