(B334) Pause causes Roon to lose control of Sonos device

Roon Version 1.5 (334)

As soon as I press Pause on the Sonos, Roon displays “Transport Roon lost control of the audio device”.

Everything works on Airplay devices (Play, Pause, Skip)

Hey @ascot — Thanks for reaching out with your report!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

So we can gain some additional insight into what may be happening, please verify the following:

  • Were you experiencing this before the 334 update or is this a new behavior?
  • Just to clarify, you are pressing pause in the Roon app when playing to the Sonos device when this happens?
  • Since the update have you tried power cycling your Sonos device and Core machine?


1 Like

I experienced the problem even before the update 334 and had hoped that the update prevents this.

I press the Play / Pause button on the SONOS speaker when this happens.

For Airplay devices, I can press the buttons on the devices themselves.

Thanks for the clarification, @ascot.

When using the pause button (or any other transport control options) on the Sonos hardware or within the Sonos app, this is the expected behavior. Using these controls will take the control away from Roon. Instead of using the hardware pause button you will want to use the Roon application for pausing.