Backup from Nucleus to iMac

Roon Core Machine

Running a Nucleus Plus on LAN
iMac is running Big Sur, version 11.6

Networking Gear & Setup Details

network is a cable modem and the Google Nest System

Connected Audio Devices

Number of Tracks in Library


Description of Issue

Just moved Roon from my iMac to the Plus. Want to do the Roon backup to an external HD connected to the iMac (or can do it to the iMac if that’s the only way). Cannot get a valid network share link. Have reviewed your instructions about a Watched Folder and the rest of the posts on the community forum. Sharing is turned on on the iMac. I know the correct smb path. also tried using the IP address.

Is File Sharing enabled on the iMac? Is the mac’s external drive listed as a Shared Folders in the File Sharing setup?

Yes on both questions.

Since the backup and transfer may be a one-time process, can you backup to your external HD via USB and then restore from that backup to your Nucleus from its USB port?

Not sure I’ve been clear what I’m trying to do. I want to set up a regular process to do a Roon database backup. When my Core was on the iMac I could do it to the external HD connected to the iMac. Now my Core is on the Nucleus Plus connected into my LAN. I want to start doing regular backups now since I’ve loaded a considerable amount of music into the internal HD on the Nucleus. I assume I can do it over the LAN through my iMac (or to it). Prefer to not move an external HD and connect to the Plus by USB. What am I missing?

That should do it as long as you are using the correct credentials. Can you post screenshots of how you are going about this? I assume you are using your mac as a remote and attempting this through settings? Do you get any error messages?

Mark, are you trying to backup the Core database, your music, or both? The Roon Backup process backs up only the Core database and leaves it to users to determine how/when to backup their music libraries.

Going back to the Nucleus Plus/Mac file issue, you should be able to see from the Plus a Mac that has been configured for a network share. Agree with the above, can you please post a screenshot?

Appreciate the help. Right now I’m only trying to backup the Core database, not the music. What screenshot would be helpful to see?

Probably the file path you need to connect to the Mac from the Plus. Do you see the Plus from the Mac as an available network connection?

Have you looked at this for guidance:

Yes. I can see the Plus connected from my iMac connected using the LAN. The path is simply Network-nucleusplus. Where I’m not succeeding is getting the Plus to let me add the iMac as a network share.

I’ve looked at that link. Don’t plan on using a watched folder at this point for adding music. All I want to do is setup doing Core database backups.

Your referring to the manual/scheduled backup setting correct?


My error message on the network share add is invalid network path. the file sharing info tells me to use smb://marks-imac-2.lan. i’ve tried it with and without my user name and password for the computer. Same message.

The process for a backup neywork share should be similar. Under Backup->Backup now->Manual, there is an option to select backup location, and once selected, on the bottom left of the next window is the option to “+ Add network share”.

Instead of smb://marks-imac-2.lan, can you try smb://marks-imac-2.local/X where “X” is the path of your backup directory?

I’ve tried that idea too but will try again.

That isn’t a full path. marks-imac-2.lan is just a DNS name which is fine but you need to specify the actual share, so it would be smb://marks-imac-2.lan/drive_attached_to_mac. The FAQ linked above notes this as smb://host/share. And you will most likely want to secify a folder on that drive instead of the root of the drive itself so the final path would be something like smb://marks-imac-2.lan/drive_attached_to_mac/_some_folder_for_my_backups.

got an unexpected error this time. Can’t find the correct path info for G-DRIVE #3 and the Roon Backup for the folder. How should that appear?

The #3 is probably the problem. Can you re-name that drive to something simple like RoonBackup or backups and then try again? If that doesn’t work try via IP instead of hostname (or at least try without the .local).