Backup network share: cannot add [Resolved]

My Roon Core is running on Synology NAS. I’m trying to add my Macbook as a Roon backup network share. I’m doing that from an iPad remote.
The closest I get is getting stuck at ‘adding…’ (before that I received errors).
Location I enter is smb://192.16…/Users/username/directory. 192… is static IP.
I also tried smb://computername.local/Users/username/directory unsuccessfully.
Synology can be seen from Macbook. SMB sharing has been enabled for the backup directory on the Macbook. Please advise how to enter the location of the Network Share. Thanks for any help.

Hi @Highfi ---- Can you verify for me if you are able to access the back up network share (on the Macbook) from another device on your network?


Hi @Eric and thanks, good call, but yes, I can connect from another Macbook in the same LAN using my user credentials to log in.
I can see my Public Folder, my Documents folder and the RoonBackups folder.
A funny thing, though: in Get Info, the URL of the Roonbackups folder appears like this:


This doesn’t look normal, does it? I mean these underscores and the _tcp part?

Anyways, copy/pasted that into Roon Preferences, does not work.
Removing underscores or trying smb://mycomputername.local/RoonBackups does not work.
Also smb://mycomputername.local/username does not work (Host not found).
Trying simply smb://mycomputername.local/ gives unexpected error: Invalid network path.

Thanks again, and let me know what more info I can provide.

Hi @Highfi ---- Thank you for the follow up and confirming that information for me, both are appreciated!

Moving forward, I would get rid of the “…smb.tcp.local/” part, as it should just read "smb://mycomputer/RoonBackups. Are you including your username and password when trying to access this share?

Lastly, can you please provide a screenshot of the SMB settings being used on the NAS. If I am not mistaken it should be under advanced SMB settings, apologies if I am off on that :innocent:


Excellent news, your instructions to add 'smb://mycomputer/RoonBackups’ worked! In the Synology Roon Core settings this afterwards appears as \mycomputer\RoonBackups’ by the way. Yes, entered Username and Password in Add network share.

Also attaching two screenshots of Synology > Control Panel > File Services > SMB > Advanced Settings for good measure.

Many thanks for your help!
I :heart_eyes: Roon!

1 Like