BBC stations breaking up requiring coreaudiod force quit

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

The topic I started is closed so can’t add to it so will continue here. The radio stops reared their ugly heads again. Restarting the router (Synology RT2600ac) fixes the problem for a while. I’m wondering if there is a setting in there that could be causing a problem?

Hello @GraemeM. I’m sorry to hear your problem has returned. I’ve re-opened the topic for you, moved the post here and @noris will be back to help in due course.

Hi @GraemeM,

Sorry to hear that the issues are back and thanks @BrianW for flagging me down! @GraemeM - If you try to bypass all of your switches and have the Core connected to the router, do you still see the same behavior?

Last time I checked logs, there were signs of more general networking issues and this would be a good test to simplify the setup and verify where exactly the system is encountering issues.

I’ve done some more testing. Removing all switches makes no difference.

Strange thing is if I reboot the router when the stopping problem occurs it will be fine for a day or so. The router is scheduled to reboot every day at 5 am anyway but that does not seem to prevent the problem occurring.

Same radio stations are fine played in Auralic Lightning DS app and Naim app and by airplay to the Auralic. It is just Roon that has a problem. At it’s worst radio seems to stop every 5 minutes. Do you have a process that runs every 5 minutes?

Today I noted stops at 6:58 approx, 7:11, 7:43, 14:22, 14;50, 15:42. 15:48?, 16:00?

Hi @GraemeM,

That’s interesting to note, it sounds like the router itself is dropping out in that case. Do you have the latest firmware install on your router?

What happens if you try to up-sample all of your content to one sample rate, does the issue still occur?

Latest firmware installed on router.

Upsampling made no difference.

One other thing I’ve noticed while having the Zones tab open when the stops occur is that all active zones stop and most zones in the list disappear and reappear within a second or two. While it is doing this the cursor sometimes turns to a spinning coloured ball if over the Roon window. If another zone is playing a locally stored or streamed album it will also usually stop but not always.

Hi @GraemeM,

Thanks for those additional details.

This sounds like the router itself is dropping these connections or you have a multicast issue going on.

Do you by any chance have IGMP Snooping or IGMP Proxying setting on the router you can try to toggle?

In case it is the router itself, do you have another one around the house you an try to temporarily use in place of the current one?

Router has IGMP settings. It has “IGMP querier timer” which is set to 260 seconds which is not far off 5 minutes which is the time interval between radio stops when it is at it’s worst. IGMP snooping is enable, proxy is disabled.

Hi @GraemeM,

Try this, have a ping test running in the background (to Google or a big provider) and see if you are getting packet loss when the issue occurs:

Been monitoring ping. There is no packet loss or slow ping associated with the radio stops.

Hi @GraemeM,

Thanks for performing the ping test. Next, I’m wondering if there will be any change in behavior with a fresh database in place. Can you please:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Do not restore from backup
  • Verify if the fresh database has the same issue

Sorry. Been away. Once I have done that test do I restore my database?

Incidentally when I view backup schedule it says last successful backup was 11/8/20 but when I go to select a backup to restore the most recent backup available is April 2019.

Forgot to ask if this switch works with roon:

The green switch was fried by global warming induced thunder storms.

Hi @GraemeM,

I would use a fresh database for a day or two and then restore.

Are you certain that you are selecting the proper folder? Perhaps there are multiple sub-folders, I would check that or if you have the backup saved to another location. Or you can also create a new backup as well.

While I can’t recommend specific switches, you can look into what other have used in the past:

If it’s unmanaged, it should work.

I’ve tested using a new database as instructed and it made no difference I’m afraid.

I wonder if there’s some process on the iMac that is causing the radio stream to be dropped. It seems to drop the stream frequently for a while then will not drop again for a long time. Is there any way to view a log of what events may be causing a problem on the iMac?

Console output around a stop:

default	09:42:16.323144+0100	mDNSResponder	[R103894] DNSServiceQueryRecord(15000, 0, <private>, Addr) START PID[56009](Roon)
default	09:42:16.323306+0100	mDNSResponder	[Q370] InitDNSConfig: Setting StopTime on the uDNS question 0x7fb672812eb8 <private> (Addr)
default	09:42:16.323354+0100	mDNSResponder	[R103894->Q370] GetServerForQuestion: 0x7fb672812eb8 DNS server (0x7fb670110430) <private>:53 (Penalty Time Left 0) (Scope None:0x0:-1) for <private> (Addr)
default	09:42:16.323599+0100	mDNSResponder	[R103895] DNSServiceQueryRecord(15000, 0, <private>, AAAA) START PID[56009](Roon)
default	09:42:16.323718+0100	mDNSResponder	[Q58589] InitDNSConfig: Setting StopTime on the uDNS question 0x7fb671818eb8 <private> (AAAA)
default	09:42:16.323741+0100	mDNSResponder	[R103895->Q58589] GetServerForQuestion: 0x7fb671818eb8 DNS server (0x7fb670110430) <private>:53 (Penalty Time Left 0) (Scope None:0x0:-1) for <private> (AAAA)
default	09:42:16.324050+0100	mDNSResponder	[Q370] Sent UDP DNS Message 44 bytes from <private>:62708 to <private>:53 via en0 (0x4)
default	09:42:16.324079+0100	mDNSResponder	[Q370] DNS Query (44) (flags 0100) RCODE: NoErr (0) RD:<private> 0/0/0 <private>
default	09:42:16.324181+0100	mDNSResponder	[Q58589] Sent UDP DNS Message 44 bytes from <private>:49799 to <private>:53 via en0 (0x4)
default	09:42:16.324207+0100	mDNSResponder	[Q58589] DNS Query (44) (flags 0100) RCODE: NoErr (0) RD:<private> 0/0/0 <private>
default	09:42:16.328469+0100	mediaremoted	Set: origin-iMac-27-2015.local-1280262988/client-com.roon.Roon-56009 (Roon)/player-MediaRemote-DefaultPlayer setting playback state from <Playing> to <Paused>
default	09:42:16.328501+0100	mediaremoted	[MRDNowPlayingPlayerClient] PlaybackState changed from Playing to Paused for origin-iMac-27-2015.local-1280262988/client-com.roon.Roon-56009 (Roon)/player-MediaRemote-DefaultPlayer
default	09:42:16.329834+0100	mediaremoted	[MRDNowPlayingPlayerClient] isPlaying changed to false for origin-iMac-27-2015.local-1280262988/client-com.roon.Roon-56009 (Roon)/player-MediaRemote-DefaultPlayer
default	09:42:16.330179+0100	mediaremoted	Posting with <Not Playing>
default	09:42:16.331155+0100	CDN - initialize client context retry
default	09:42:16.331192+0100	CDN - client setup_remote_port
default	09:42:16.331219+0100	CDN - Bootstrap Port: 2307
default	09:42:16.331902+0100	CDN - setup_remote_port: bootstrap_look_up() => unknown error code (1100)
default	09:42:16.334685+0100	sharingd	NearbyInfo sending activity level, original: 0xb encrypted:0x8
default	09:42:16.335587+0100	AirPlayXPCHelper	Request: playbackState<3898626D-360A-456B-9D82-7A9593305BE0> for origin-iMac-27-2015.local-1280262988/client-com.roon.Roon-56009 (Roon)/player-MediaRemote-DefaultPlayer
default	09:42:16.335469+0100	mediaremoted	Posted Active Now Playing Notification kMRMediaRemoteNowPlayingApplicationPlaybackStateDidChangeNotification for path origin-iMac-27-2015.local-1280262988/client-com.roon.Roon-56009 (Roon)/player-MediaRemote-DefaultPlayer
default	09:42:16.335715+0100	AirPlayXPCHelper	Response: playbackState<3898626D-360A-456B-9D82-7A9593305BE0> returned <Paused> for origin-iMac-27-2015.local-1280262988/client-com.roon.Roon-56009 (Roon)/player-MediaRemote-DefaultPlayer in 0.0002 seconds
default	09:42:16.338205+0100	Roon	NPIC: setNowPlayingInfo: sending to MediaRemote
default	09:42:16.338687+0100	contextstored	Request: playbackQueue<B70B9BA3-8687-4B32-805F-177306FBBB89 contextstored-262 /M/L/R[0:1]> for origin-iMac-27-2015.local-1280262988/client--0/player-(null)
default	09:42:16.339080+0100	contextstored	Request: clientProperties<F3EF9EBC-CBA1-4DE1-9DCC-930282BADB32> for origin-(null)-0/client--0/player-(null)
default	09:42:16.339951+0100	Roon	[NowPlayingInfo] Setting nowPlayingInfo with mergePolicy Replace: <NSCFDictionary 0x60000535a920 {
	kMRMediaRemoteNowPlayingInfoDuration = 0
	kMRMediaRemoteNowPlayingInfoArtworkMIMEType = image/jpeg
	kMRMediaRemoteNowPlayingInfoTimestamp = 2020-08-17 08:42:16 +0000
	kMRMediaRemoteNowPlayingInfoTitle = BBC Radio Scotland
	kMRMediaRemoteNowPlayingInfoArtworkIdentifier = 876f9243fa0e6ffe2d303ce5666d86c9ed2aa457
	kMRMediaRemoteNowPlayingInfoElapsedTime = 0
	kMRMediaRemoteNowPlayingInfoPlaybackRate = 1
	kMRMediaRemoteNowPlayingInfoMediaType = kMRMediaRemoteNowPlayingInfoTypeAudio
	kMRMediaRemoteNowPlayingInfoArtworkDataHeight = 768
	kMRMediaRemoteNowPlayingInfoContentItemIdentifier = 09E79A73-EE5E-44A0-AB5A-8B2C7A0DDE01
	kMRMediaRemoteNowPlayingInfoIsAlwaysLive = 1
	kMRMediaRemoteNowPlayingInfoArtworkDataWidth = 768
default	09:42:16.339287+0100	contextstored	Request: playbackState<A38160F5-8163-4B65-91EF-96DE57E1F872> for origin-iMac-27-2015.local-1280262988/client-com.roon.Roon-56009 (Roon)/player-MediaRemote-DefaultPlayer

Hi @GraemeM,

Can you note the exact local time + date of the next issue (on the fresh database) and then send me a copy of your Roon logs by using these instructions?

Hi @GraemeM,

Thanks again for sending those logs over and your patience while I had a chance to review.
I do see the issue occurring, I will post a snippet below:

08/18 09:39:45 Trace: [System Output] [LowQuality, 32/48 AAC => 16/48] [100% buf] [PLAYING @ 5:04] BBC Radio Scotland
08/18 09:39:50 Info: [stats] 10678mb Virtual, 270mb Physical, 346mb Managed, 97 Threads,  FDs 
08/18 09:39:50 Trace: [System Output] [LowQuality, 32/48 AAC => 16/48] [100% buf] [PLAYING @ 5:09] BBC Radio Scotland
08/18 09:39:55 Trace: [System Output] [LowQuality, 32/48 AAC => 16/48] [100% buf] [PLAYING @ 5:14] BBC Radio Scotland
08/18 09:40:00 Trace: [System Output] [LowQuality, 32/48 AAC => 16/48] [100% buf] [PLAYING @ 5:19] BBC Radio Scotland
08/18 09:40:05 Info: [stats] 10681mb Virtual, 231mb Physical, 358mb Managed, 97 Threads,  FDs 
08/18 09:40:05 Trace: [System Output] [LowQuality, 32/48 AAC => 16/48] [100% buf] [PLAYING @ 5:24] BBC Radio Scotland
08/18 09:40:07 Warn: [streammediafile] error reading stream: Error: NameResolutionFailure

It looks like BBC was streaming fine until you hit a Name Resolution Failure.

I know you tried Google DNS, but have you tried any of the other ones yet? This DNS change is meant to be made on the router-level.