Bell Canada: Bell HH3000 aka Bell Hub 3000 Doesn't Offer Bridge Mode [See Staff Post for Workaround]

Roon Core Machine

Networking Gear & Setup Details

My internet service provider (Bell Canada) doesn’t support bridge mode. Evidently this is a considered decision on their part as it can reconfigure the modem. Is there an alternative which would enable me to use Roon ARC?

Thanks

Connected Audio Devices

Number of Tracks in Library

Description of Issue

@NiHo, it’d be really helpful if you describe your Roon setup, including network details, i.e., modem, router etc., and what you have tried so far, and what message is shown in Settings > Roon ARC. Thanks.

So they support their modem/router. Drop the question how to enable portforwarding to a single host (your Roon-core) But I think you are able to do it yourself using this handson…

[How to Open Ports in a Bell Home Hub 1000 Router]

Bridge mode isn’t really a thing for ISPs to support… technically no different from when back in the day we would plug in a single access point (non-gateway) to our home internet connections. Bridge-mode is a setting on your “smarter” WIFI systems like Eero where you’re telling it to not bother doing gateway/router stuff and just provide WIFI in the house.

Thanks for all of the above responses.

My set-up is a Bell Home Hub 3000 which links to the internet. The wifi is handled by Netgear Orbis, of which the base unit is connected to the Home Hub by ethernet.

When I spoke with technical support at Bell I was informed that they have eliminated access to Bridge mode in the Home Hub. The technical support person knew exactly what bridge mode is and why access to that functionality has been cut-off (I had the impression that she had had to deal with that question many times previously). None of the screens that I, a consumer, can access on the Home Hub even hint at that functionality. It may be that some of their older Home Hubs permitted that access, but that path has been eliminated.

The error message is as follows:
{
“connectivity”: {“status”:“NetworkError”“status code”:504. “error” :“error: Error: ETIMEDOUT, response
code: undefined, body: undefined connected? undefined”},
“external ip”: {“actual external ip”:"142.112.165.134’“router external ip”:null},
“natpmp_autoconfig”: (“status” :“NotFound},
“upp _autoconfig”: (“server ip”.“192.168.1.1” found upmp”:true}

Thanks

Well, you could try and put the Orbi in bridge mode so that it functions more like an Access Point. Unless, the Orbi is doing something you need it to be a router.

Exactly the same error message here too ! I have my personal router “Asus RT-AX92U” plug into my internet provider router (Bell Hub 3000). I have no issus with any of my home integration, but with ROON… All my connected object are connected to my Asus router with no issue at all ! I would say I’m a little deceived and would have liked a flawless solution from ROON. I guess will have to wait a couple of upgrades…

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xx.xxx.xx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“xxx.xxx.xx.x”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}
}

The general “internet recommendation” is to configure your Bell 3000 to put the Asus into its DMZ list. This may require moving the PPPoE config into the Asus. There is some risk here but its similar to putting the device into bridge mode.

The added risk is you never want anything but the Asus connected to the 3000 and that includes any wifi clients. Your Asus will then be your security / firewall.

2 Likes

Hi @Andre_Lafreniere,

To add onto @ipeverywhere’s helpful suggestion: the Bell 3000 doesn’t support “Bridge” mode, the common solution for the double NAT issue you’re encountering in your two-router setup.

You can read a more detailed forum description of the PPPoE route using the Asus router here: [Internet] HH3000 remote access and port forwarding - Bell Canada | DSLReports Forums

If it’s helpful, here’s a ground-level breakdown of the situation:

  • You have two routers in your setup, so there is a double layer of NAT preventing your Core (hardwired to downstream router) from reaching ARC.
  • Normally, users would place the modem/router unit in “Bridge” mode as a solution, but the Bell 3000 does not provide this feature.
  • As a workaround, you can configure your Asus router as an “Access point,” placing it behind the security layers on the Bell 3000 router. That would allow your Core to communicate to the Bell 3000 directly via the Asus, without the NAT in between. As @ipeverywhere, it’s a rigged bridge mode.

That means the Asus router will be providing your only network firewall at the router-level. So, if you choose to configure your network this way, please don’t connect Wi-Fi devices directly to the Bell Hub 3000 (only the Asus).

Please let me know if you have any questions.

1 Like

Hi @Andre_Lafreniere and @NiHo,

I’ve merged your topic threads together as two Bell Canada customers dealing with what appears to be the same issue: their modem/router unit not offering Bridge mode. Please see my previous post (staff yellow).

I would like to add to prevent any mishaps if someone try’s this is, to turn off the wifi on the Bell Hub.

1 Like

My Wifi is deactivated on the Bell hub since 3 years :slight_smile:

2 Likes

I’ll try that tonight ! Thanks for the fast response !!

1 Like

Hi @Andre_Lafreniere,

I wanted to reach out to confirm whether or not the Bridge mode workaround for the Bell HH was successful in your case. We’re here to provide further assistance if not.

Hi Connor,
Yes it works but I also had to add a port forwarding to make it work ! I really think the way it connect should be easier nor transparent for users like for today’s other kind of integrations. Not all users are tech savvy and has the proper knowledge of complexe configuration.

Hi @Andre_Lafreniere,

Glad to hear it’s functioning now, although I’m sorry that you’ve had to tinker in order for port forwarding to work. While port forwarding is the solution we’ve implemented for the initial release of ARC (1.0), we recognize that it creates laborious workarounds for users with certain service providers, router combinations, or unique network infrastructure.

Rest assured the team is researching a constellation of more sustainable solutions that will allow for simple setup of ARC for a greater percentage of our users. There’s not a one-size fits all solution, but we’re exploring every avenue for how to make this easy. Thank you for your feedback in the meantime, and we hope you enjoy the app!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.