Bell Home Hub - How to Set Up "Bridge Mode" by (Safely) Configuring Advanced DMZ

Hi folks, I’ve run into this problem off and on with Bell over the years. The bridge mode with pppoe works ok but I recently discovered that there is a simpler way to obtain an ip with an external router. No more bridge modes needed!

I have the HH4000 which has the same interface as the HH3000 and can be set-up the same way. Simply set up an Advanced DMZ for your router and have the router obtain an external IP. Here are some screenshots:

Setting up the Advanced DMZ:

Select your router to be in the Advanced DMZ:

Ensure you also tick the “Advanced DMZ”, if you do not do so your router will only be assigned a local IP (eg. 192.168.2.x).

Then go to your router settings, and change settings to obtain an IP automatically:

No more fussing with pppoe and login information either:

Just leave any login info blank, if you try to but in your b1 number and password the connection will work for a minute and then fail (that took me awhile to figure out!).

Using this Advanced DMZ method prevents you from being double-NATed and could even increase your speed. Also, it’s best not to plug anything else in to your modem directly as they won’t be behind your firewall and could be exposed (I’m breaking my own rule here :-P); it’s better to plug into your router instead for the best security.

If you run into connection problems, I found this useful document from Bell which explains the troubleshooting steps and especially the order you need to reboot things:

Also, a side note, do not agree to receive the GigaHub modem if Bell offers it to you. They may eventually fix the problems associated with it but for now, it caused nothing but headaches and internet downtime. The HH4000 (or 3000) will work perfectly fine and the only difference is Wifi 6E which practically no device has anyway (as of Oct 2022).

Good luck!

1 Like