Bluesound and multizone sync (via Roon)

(Yiannis Kouropalatis) #1

Dear friends,

Does anyone own / use multiple Bluesound units (2 or more)? If so, are you finding that they can be grouped and play in sync for extended periods of time? Do they say in sync?

I have been using a Flex successfully and when grouped with my Windows 10 PC zone (Roon Bridge), the playback is in perfect sync for hours. Problem occurred as soon as I acquired a second Bluesound (Pulse 2). It which sounds amazing but unfortunately it does not stay in sync with the Pulse Flex. Playback starts in perfect sync but after about 15/20 mins the echo begins and the two are clearly out of sync.

I have opened a support request to try and resolve this but in the meantime maybe I can benefit from people’s experience.

Many thanks

(Chris ) #2

I have no trouble with this. Pulse 2 and Pulse Mini. I can group them via BluOS or via Roon. If I play the zones individually the same thing, they won’t sync. As expected.

(Yiannis Kouropalatis) #3

Chris, thanks for the input. So you can group the Pulse 2 and Mini via Roon and they play in sync. Can i ask if you change the settings in some way? for example do you set the clock priority in some way?

If it works well with your setup it probably means I am doing something wrong with mine.

Cheers

(Chris ) #4

I don’t do anything in Roon. No DSP etc. I just play as is. All my zones are hard wired to the network. I only use wireless for control.

1 Like
(Yiannis Kouropalatis) #5

Mine are using the WiFi (not hard wired)… I wonder if this is the cause of the sync problems. Having said that, if I use the Bluesound app then they work great and in sync.

(Chris ) #6

Hmmm? I’m no technical expert so it will be good to know what’s going on.

(Bernard Crawford) #7

I have a couple of Pulses, a Soundbar, a Node and PowerNode and they all sync fine with Roon or BluOS, that wasn’t always the case, I have them connected via ethernet…but not in a traditional way, my wireless is via Apple Airport extreme, and I have several extreme base stations (3) and airport expresses (3) that I use as “extenders” but not as wifi but essentially wireless ethernet bridges and they work perfectly, I also have a similar connection to an OPPO UDP-203 that I use as an endpoint. Even though the OPPO has 802. ac, in order to stream 24/192 having the faux/hardwire eliminates any drop outs and allows flawless streaming/synching.

1 Like
(Yiannis Kouropalatis) #8

Hi Bernard

Sounds like a form (even hybrid) of ethernet hardwiring is necessary for synced playback with many grouped zones. Great idea with using the Apply airports as access points and bridges. I am still waiting to engage with support about my issue. To be honest I was expecting that limiting the number of grouped zones would allow for wireless playback in sync. Kind of surprised that only two bluesound zones (via WiFi) are causing problems. Especially considering my super strong home WiFi.

While I appreciate the higher quality sound and I enjoy it via my Naim Nova in the living room, I was hoping to extend to other rooms for background listening as I move around. SQ in those other rooms is secondary while simplicity and reliability is primary. I am not sure which way to go if the wireless bluesound speakers cannot perform in my flat.

Many thanks
Yiannis

(Bernard Crawford) #9

It only takes a small hiccup for a stream to be disrupted and while a single endpoint worked very well I would have issues with several working simultaneously, my place is less than 2000 Sq. ft, but I enjoy having everything playing at once from the bedroom to the bathroom, kitchen, etc, and with these inexpensive legacy apple products I struck gold. Before going all in on Bluesound I used Roon with AirPlay in all the same areas but still had dropout issues so it could also be improvements to RAAT in general along with the superior hardware. But in any case I’m a happy camper.

(Yiannis Kouropalatis) #10

Hey Bernard,

That is super helpful info, many thanks! :slight_smile:
So it looks like you could stream wireless to a single Bluesound or other endpoint. Any more than that and sync / dropout problems occurred? If so then that is similar to my experience although it looks like the Bluesound is more sensitive compared to my mini PC (roon Bridge) and Naim Nova.

I have just connected the two Bluesound speakers with ethernet to see if that fixes it. What is very strange though is that the two Bluesound speakers work perfectly wirelessly and in sync when controlled via the Bluesound app (instead of Roon).

(Yiannis Kouropalatis) #11

Good news! all works fine now. Not entirely sure what fixed it but I tried a lot of things

Wired one of the speakers via ethernet, restarted the Bluesound speakers a few times and then the router.

Finally all works in sync and I am happy again :slight_smile:
Many thanks for the support guys

1 Like
(Yiannis Kouropalatis) #12

Ahh… looks like I spoke too soon :-(. As soon as I tried skipping a few songs, problem came back with a vengeance. music totally out of sync. Back to support…

Thanks anyway guys

#13

@Yiannis_Kouropalatis How are you getting along with this syncing problem? I’m experiencing the exact same problem: I have a BS Node2 and a Pulse Mini, Roon core running on a Mac Mini, all hard wired through ethernet.

When I group both BS devices in BluOs no syncing problems but as soon as I group the devices in Roon the problems start rather quickly.

Have you heard anything from @support ? I’ve read the thread over at BS and not much help there… :frowning:

(Yiannis Kouropalatis) #14

Hi @dibb

My experience is exactly like yours. I have a Node 2 + Flex and when I control them via the BluOs app then all is great and music is in perfect sync. If I use Roon (grouping the two) then music goes out of sync within 5-10 minutes.

Indeed Bluesound claim that the issue is network related but we are ruling this out by hardwiring our devices. So far the strongest indication is that the problem will be resolved when Bluesound roll out the latest RAAT version. Other than ‘we are working on it’, there is no indication of timeline offered by Bluesound. In general, they seem to take quite a long time in resolving issues and bugs so I would not hold my breath…

As things stand, I have had to adapt and compromise. I am limiting my use of Roon for single end points only. I really do not like the BluOs app but I am having to use it exclusively for multiroom playback. My listening is 80% multiroom and 20% single end point so sadly I have to use the BluOs app most of the time.

If I hear anything new I will update

Cheers

#15

Thanks for the heads up. I will give BS some time to integrate the latest RAAT SDK and see if that solves the problem.

Until that time, I’ll group my BS devices in the BluOs app. If you then select the one BS device in Roon, multi room does work and the devices stay in sync (as it seems now).

Just curious: what brand & model router are you using?

(Yiannis Kouropalatis) #16

Great to hear it was helpful :slight_smile:

I am definitely finding a better experience with multiroom Bluesound devices when they are controlled via the BluOs app. I still enjoy Roon but only when I use a single Bluesound endpoint.

On the other hand I also use two roon bridge endpoints (Win 10 PCs) and they sync perfectly via Roon as long as no Bluesound device is added to the group. To my mind this adds hope that if/when Bluesound rolls out the latest RAAT version then all will be fine again.

My Roon Core is installed on a MacBook pro and I carry it between two homes so two systems and two routers.

Router1 : Synology RT2600ac
Router 2 : ASUS DSL-AC68U

Best
Yiannis

#17

I really don’t think it’s a “network issue”, nor that it’s a problem at Roons end. So if the upcoming Raat update in BluOs doesn’t solve it, BS definitely will hear from me… :wink:

I won’t be going back to the BS app though. Only to group my players and set the relative volume. For music discovery and playback I will keep using Roon.

You can try to group your players in the BS app and then play from Roon to the group you’ve created (it has the name of the first player in the group)

Cheers!

1 Like
#18

@dibb - many thanks for that tip, hadn’t realised it works fine if grouped via BS first - that’s good enough for my use case, even if not as it should be.

#19

@dhusky :+1: Glad I could help you with that. Indeed it’s a workaround that kinda works, but don’t let the kind people at BlueSound know… :wink:

[EDIT: after having read multiple threads here regarding clock drifting / sync issues, I’m starting to believe that this problem might be caused by Roon, and not by BS]

#20

@dibb, interesting, must have completely missed those - are they recent? Any links? I’m not sure whether that gives me more or less hope!