Bluesound Flex 2i speakers not consistently Roon Ready

Roon Core Machine

SurfacePro7

Networking Gear & Setup Details

Everything on Wifi

Connected Audio Devices

Bluesound Pulse Mini 2i and Two Bluesound Pulse Flex 2i

Number of Tracks in Library

Description of Issue

I’ve had Pulse Mini for few months and this connects and works flawlessly with Roon Core. I recently purchased and setup two Pulse Flex 2i. After about 5 continuous hours of playback on all three devices the two Roon Flexes no longer are “Roon Ready” but only show up as “other network devices” for connection via AirPlay. Clearly these devices were Roon Ready and are currently being seen by both Roon and network so why are they no longer “Roon Ready”? Repeated attempts to restart router, Roon Core, and unplug / replug the three devices does not help. Pulse Mini ALWAYS connects as Roon Ready. Other two do not. Two new Flexes were also updated to latest firmware prior to first usage and the Bluesound app will always show all three speaker (just not “Roon Ready” for the Flex). Is this something with the Flex? or amount of Bluesound connections? But again I’ve tried reconnecting in all different scenarios (staring with Mini, starting with one of the Flexes, etc.) Any advice appreciated as none of these speakers are cheap and if two Flex cannot consistently connect there’s no use to keep them and I’ll have to return.

Have you tried resetting your Flex 2i speakers? Sometimes a hard reset is needed on Bluesound devices to enable them to be seen by Roon correctly.

1 Like

If by resetting you mean unplug, wait 10 seconds, then re-plug back in than yes I have. If a hard reset means something else I’m all ears…(the bluesound manuals are terribly vague)

Dan, on page 4 at the end of the manual there are the precise instructions to do a factory reset of your Flex 2i. This I think is what is meant by ‘hard reset’.

2 Likes

Thanks @Andreas_Philipp1, that is what I meant.

I have two Bluesound Flex running as a stereo pair and they are no longer showing as Roon Ready but only through airplay which is a pain. I haven’t changed anything and everything is up to date? Both play perfectly in the BlueOS app, I only have an issue in Roon

Simon, have you tried the factory reset option to determine if they become visible in Roon as “Roon Ready” again?

Not yet, generally when I find out it’s not working I’m turning then on to listen to music and don’t want to faff about restoring so just end up not using Roon. I will try though but there’s not much point if its going to happen again. I don’t see having to restore every time as a fix really …cheers though :+1:

The factory reset may be a one-time action, some users have said that it solved completely their problem with Roon having reset it only once.

Thanks guys for the tips on factory resetting. I kind of agree with Simon as that’s not something I want to do consistently (since now you’d have to wait for the software to update and such as well). What I did find out is if I restart my Xfinity Gateway (modem) via the app, the two flex speakers now will show as Roon Ready. Interesting enough restarting the Xfinity modem by unplugging and replugging did NOT help, but only by restarting the gateway via the app does it work. That tells me it’s an IP Address communication thing. There ARE times where I have to restart Gateway and then unplug and replug the mini for all three to work, but at least this seems to be more viable than hard resets everytime it drops (restarting gateway maybe a 5 min process and of course unplugging / replugging is seconos). Odd but has worked. Simon maybe give this a whirl and see if it helps…

1 Like

Ah when you guys were discussing this did not realize a one time action. Will definitely try this then thank you.

1 Like

There are more than a few threads here describing issues with Comcast’s networking equipment and settings. Not great that a gateway reboot may help, definitely seems to be network related at this point. Plesae let us know what works/is working.

I’ll reboot the modem and Flex’s before I go to bed tonight and hopefully that will work. Cheers everyone

1 Like

Hey @Dan_Murphy1 & @Simon_Tippett,

We’re sorry to hear that you were having issues with your Flex speakers. Bluesound devices tend to be very reliable in Roon. In checking your system diagnostics it appears that you were able to get things restored and have been enjoying music. Can you please update us on your current status? If you’re still having trouble and need help we’re happy to lend a hand! Thanks!

It started working again but I’ve literally just gone to play Roon on them again and they are not there. Bluesound is working, Tidal connect is working and Roon isn’t.


Hi @Simon_Tippett,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating. Did the Flex speakers stop showing up in Roon when you created the group, or was it happening before that as well?

Hi,

I have my Roon core running on a dedicated Mac Mini M1 direct to BT home hub disc via ethernet and the Flex run as a Stereo pair with one of them hard wired to another BT home hub with ethernet. I don’t use the Flex that often so it’s hard to know when it happens but I never turn the Mac or speakers off. More often than not both speakers are not there when I go to play Roon. They are always available on Bluesound app and Tidal connect.

Thanks

Simon, can you confirm that both BT Home Hubs are on the same network subnet (having the same network address with the first three numbers as 192.168.x.y or 10.0.x.y)? I’m assuming they are on the same subnet but if not, this could be a cause of what you are seeing in Roon.

They are…thanks