Bluesound Node will not resolve through Roon as Roon ready device

I have a BlueOS Node that worked fine for a few years. Now suddenly it will work via airplay via Roon but not at the higher-quality Roon ready. I only really care because I’m grouping with two other speakers that are Roon certified and they won’t group unless I go with the airplay route… and, anyway, just find it annoying. Whenever I try to play the Node I get “unexpected error connecting with the audio device” but it works fine with airplay. Anyway, just wondering if anyone has any thoughts. I have restarted everything, updated everything, no change.

You’ve posted in the Nucleus Support category of the forum - can you confirm that your Roon Server is a Nucleus? If not, please give more information on what your Roon Server is running on. Thanks.

Yes, it’s a nucleus. Thank you,

Have you tried rebooting the Node?

Yes. I also rebooted the nucleus.

Hey @kit_roane,

Thanks for writing in! Could you please reproduce the issue and share the specific date, time and name of the track playing when the issue occurs?

Once you let me know this info, I’ll go ahead and enable diagnostics for your account so I can review the logging for clues.

If you’d rather do it yourself manually, please use the directions found here and send over a set of logs to our File Uploader.


Thanks. It happens with every track that is streamed (like Tidal). It doesn’t happen with downloaded ACC files that are Just tried On Your Own by Blur, January 18, 5:47 p.m.

Hey @kit_roane,

Thanks for the update! I’ve activated diagnostics for your Nucleus and it looks like you have a few grouped zones, and the issue here is that one of your zones only accepts 2 channel content:

Warn: [zoneplayer] failed to start stream System.ArgumentException: only supports 2ch content

I would first power down your server, as well as all your endpoints. Power cycle your router and remotes, and then boot everything back up, and let me know if you run into the same issue. :+1:

I’ve actually done all that, and also made sure everything had the latest firmware/software. The endpoint is a Blueos Node and it never had this issue before (it’s been working great for a few years). Is there some setting that might be the cause?

I have three Node 2is and one Node, all are on Ethernet, and they are normally problem free. I have had three issues in the past five years, and the issues have always appeared after a Bluesound firmware update. When rebooting and power cycles do not work, a factory reset has always corrected the problem. After seeing your post, I do recall one instance where Roon Ready disappeared and Air Play was the only option. The factory reset is a last-ditch effort but has always worked for me. If you have Network Shares, copy and paste them into a Word document to make it easier to set the Node back up after the factory reset. Hope you get it corrected!

1 Like

Thank you so much. I’ll try that and report back.

I have my fingers crossed for you, because when this stuff does not operate correctly it is frustrating.

So, tried that but it didn’t work. I’ve found that some Tidal songs will play and some won’t though. Most won’t. I don’t see a clear link to the quality of the file or anything but very very very frustrating given that it worked fine for a couple of years and now nothing seems to fix it. I guess I could try reverting to an earlier Roon build on my nucleus but that shouldn’t be necessary in a somewhat perfect world… :slight_smile:

Ben, Any ideas?

Sorry to hear that. Are you able to Roon Ready group the Node now?

Yes, however I believe I was able to do this before as well. The repeated issue is that most Tidal tracts error out. This doesn’t happen with some and it doesn’t happen with local media as far as I can tell. It was working perfectly for years but now nothing, so thinking it must have something to do with a software update, although no word from Roon.

And it still plays with no issues as an Airplay endpoint, just not as a Roon ready one.

Is your Node and/or Roon Server on an Ethernet switch?

Yes, they are on ethernet via a switch.

Is there any way you can bypass the switch and put the Roon server and Node directly to the router to see if it corrects the Node’s issue?