Bluesound Powernode 2I not appearing under Roon Ready in Settings-Audio

Roon Core Machine

Macbook Pro, 2.6 GHz 6-Core Intel Core i7, RAM - 32 GB 2400 MHz DDR4 running MAC OS 13.2.1.

Networking Gear & Setup Details

Netgear router, On WiFi. No VPN.

Connected Audio Devices

Bluesound Powernode 2i using WiFi

Number of Tracks in Library

7725 tracks

Description of Issue

I cannot see my Bluesound Powernode 2i listed under roon ready devices. I do see it under other network devices. Due to this, it is airplaying my library to the Powernode 2i from my Core on my Macbook Pro.

How can I get my Powernode 2I under the Roon Ready section (I assume it is Roon Ready).


Maybe this is related to this known problem with the latest Bluesound firmware update:

I have restarted the Roon core as well as my Mac multiple times. But does not seem to help so far. Thanks.

I had a similar issue to you and wanted to share how I solved it. Last year, I purchased an NAD M10 V2 all-in-one streaming amplifier, which was always Roon-ready and I always upgraded to the latest firmware online. The latest upgrade version is BLUEOS 3.20.45.

A few days ago, I accidentally restored the machine to factory settings, and after rebooting, I encountered the same issue as you: the device only appeared in “other network devices” in AirPlay mode, and disappeared in Roon-ready mode. I contacted technical support from our country’s distributor, but the methods they suggested couldn’t solve the problem.

Finally, I found BLUEOS v.3.20.25 from last year’s web-ftp directory list on NAD’s official website, which is applicable to M10V2. I downloaded and extracted the .img file to a fat32 USB drive and inserted it into the machine to revert to version 3.20.25. After that, the problem was solved, and Roon-ready came back. I then upgraded to the latest version 3.20.45 online, and Roon-ready did not disappear.

Perhaps as Suedkiez mentioned, there are still some issues with Roon-ready in BLUEOS after version 3.20.45 that have not been fixed yet. Restoring to an older version of BLUEOS may solve this problem.

I hope this can help you.

1 Like

Thanks. I will try this out.