Bookmarking a Focus Search causes Year range to change [Fix underway]

I set up a Focus Search to include a range of years less than a decade and I bookmarked it. When I returned to the saved bookmarked search, the last year in the range had increased by one. I verified this with 2 different searches:

  1. I searched on several negative (red) criteria and the positive (green) year range set to 1970 - 1976. When I accessed the bookmark again, the year range was 1970 - 1977.

  2. I searched again on several negative criteria and the positive year range of 1987 - 1989. When I accessed the saved bookmark again, the year range had changed to 1987 - 1990.

Can anyone else reproduce this issue?


EDIT: Changed 1988 to 1989. 1988 was incorrect as part of the second date range.

Seems to work for me. Can you post some screenshots of the process as you go along?

  1. I start by creating a Focus Search

  1. Then I save the bookmark

  1. I open the saved bookmark

  1. And this is the result

The change is always consistent – it’s always +1 to the upper end of the date range.


Time Zone??

Nice crisp reproduction steps, but I can’t reproduce @Jeff_Bellune :frowning: Very strange.

Are you doing anything in between when you’re saving the bookmark, and loading it? Resetting focus? Anything?

Can you tell us the basics of your setup, especially the platforms your Core and (if applicable) Remote are running on?

Ha! I was able to reproduce this.

In tracks view, I set up a focus just like above, except the 1 and 2 stars (how did you get those?). Then I saved it as the bookmark as “test”. I then reset the focus to clear it. When I selected the test bookmark, the tracks appeared and the upper date range increased by one year. Seems to happen the first time you use the bookmark.

Once it goes to the extra year upper date range, it seems to stay at that date.

Cheers, Greg

Edit: interesting. I created and am testing this using my iPad. If I leave the focus displayed, then close the app and swipe it away to shut it down, when I restart the app, it increases by another year. I can keep doing this which continuously increases the years.

The first time I noticed it I had been moving around various parts of the app and doing Roon stuff before I returned to the saved bookmark. When testing I went directly from saving to loading and saw the same result. Sometimes during testing I re-opened the Focus window to see if anything was amiss and then closed it again without making any changes. Same result.

  • Roon 1.2 (build 142) stable (64-bit)

  • Windows 10 Pro 64-bit

  • Dual 6-core Intel Xeons with hyperthreading; 64 GB RAM; Dual nVidia GTX 780 Ti

  • Music files are stored locally on the PC, which has almost 15 TB of internal storage, 8 of which is RAID0. The music drive is a 2 TB SATA drive.

  • Remote is on an iPhone 6S running iOS 9.3. It’s not been used very much so far.

I put text versions of my iTunes star ratings into iTunes’ Grouping field as a backup because, believe it or not, iTunes Match and the iCloud Music Library will trash my ratings from time-to-time. I know!

Anyway, apparently Roon sees Grouping as just another Genre. Happy accident there, because filtering out my 1- and 2-star tracks is a real blessing!

But going forward I think I’m going to see if I can work in Roon’s rating system. 1- and 2-star ratings will get banned, 3-star ratings will get no rating, and 4- and 5-star ratings will get marked as Favorites. That grouping of ratings is pretty much what I ended up using in iTunes for most of my playlists anyway, so hopefully I won’t miss the 5-star granularity. My only remaining hurdle is what, oh what, to do about ratings in Tidal when I’m mobile.


Yup, me too. I was in Albums, but I can reproduce in Tracks.

Appreciate the report @Jeff_Bellune – I’ll get a ticket open and we’ll get this fixed.

Thanks guys!

fixed for next build.

1 Like