Bricasti M5 Network Bridge Not Detected

Core Machine (Operating system/System info/Roon build number)

Dell 5530 running Windows 10 and Roon V 1.6 Build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Computer connected to Viasat modem via WiFi. M5 connected to modem via ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bricasti M5 Network Bridge connected to modem via ethernet

Description Of Issue

Roon does not detect the M5 bridge. Audirvana detects the M5 and plays perfectly.

Hi @Anton_Bokal,

Welcome to the Community. Can you please share a screenshot of your Roon Settings -> Audio tab? You can upload screenshots by using these instructions and this tab should look something like this:

Hi @Anton_Bokal,

Thanks for sharing that screenshot.

It appears that a firewall may be blocking proper communication through Roon. Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the exceptions and the executives themselves would be located in your Database Location/Application folder path. I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have.

Can you please give that a try and let me know if helps? Thanks!

You’re right! My McAfee firewall is an issue. I haven’t figured out how to deal with that in a durable way. Any thoughts?

Roon and RAATServer are enabled in McAfee for incoming and outgoing connections on designated ports, and Net Guard is active.

Hi @Anton_Bokal,

Thanks for confirming that the issue is the McAFee firewall. I can’t comment on specific settings you may need to use but I would ensure that Roon is added as an exception to the McAFee firewall, this guide may be helpful. I would set the exception on an application level for both Roon and RAATServer.

Hi @Anton_Bokal,

I wanted to follow up with you to see if you were able to use the instructions listed in my last post to add exceptions for Roon to the McAFee firewall. As a note, all the blue links contained in this thread are click-able. Do let me know how it goes, thanks!

1 Like

The links do not map to my new McAfee. And, Roon quit working even with that firewall disabled. No idea what’s up.

Hi @Anton_Bokal,

We can try to reinstall Roon to see if it will help. Can I please ask you to use the following instructions to install a fresh copy of Roon on that machine?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Do not restore the backup just yet and verify if everything performs as expected
  • Note: If Roon asks to be allowed past the firewall please add this as an exception

Thank you Noris. Finally had a chance to follow up on this and am up and running now. I ditched McAfee, followed your reinstall instructions and restarted the M5. Victory!

I may try to reinstall McAfee to better understand if that was the issue, but don’t really care (it’s not necessary and adds complexity to my system).

Thanks again!

1 Like

Noris - Back to broken. Roon will not find the M5. I changed nothing.

HI @Anton_Bokal,

Did you re-install McAFee or perform a Windows update by any chance? I would take a look at the Windows Firewall if the was perhaps an update performed as I have sometimes seen Windows updates revert these settings. A reboot of your Core, Networking gear and M5 would be helpful as well.

Just so you are aware, ISP-provided routers can sometimes cause issues with Roon because they are unable to properly pass multicast traffic through. Roon uses multicast for device discovery, so generally speaking it’s important to have a consumer-grade router that is able to properly handle this type of traffic.

I did not reinstall McAfee.

Windows firewall still has exceptions for Roon and RAATServer after a Windows update. I have uninstalled Roon multiple times by uninstalling the app and by manually deleting its folders from the Windows file system. Each time I reinstall Roon, Windows Defender asks permission to allow access by Roon and RAATServer and I enable those permissions. I double check the permissions on Windows Defender to make sure Roon and RAATServer are allowed access. And, I then restart the network bridge hoping to see it show up as a network audio device. That worked the first time I tried it yesterday, but has not worked since (whether or not I remove the previously granted Defender access permissions before trying the sequence again).

Audirvana works perfectly in the system, and Roon played wonderfully at the same time for a few hours yesterday, allowing A/B functional and sound quality comparison. I am willing to go out and buy a router if that will make Roon work too. I ditched my top line routers a year ago because the ViaSat router performed at least as well. What do you recommend to satisfy Roon’s special requirements?

Hi Noris,

A few hours ago I repeated the steps of unninstalling Roon by manually deleting its folders from the Windows file system. After reinstalling, Windows Defender asked permission to allow access by Roon and RAATServer and I enable those permissions. I double checked the permissions on Windows Defender to make sure Roon and RAATServer were in fact allowed access. The M5 was online but not detected. So, I turned off the M5 and then restarted it and it was detected as network audio device! Just like the other day, it worked for a few hours and then quit.

More data Noris!
Roon seems to find the M5, but only if the M5 is cycled completely off and then on when Roon is running. If Roon is playing through M5 and M5 drops, the M5 must be powered completely off (not just standby) and then back on and it seems to work. That pattern has repeated 2-3 times. I may try again later to see if that’s what’s going on. Does that make any sense to you?

Hi @Anton_Bokal,

Thanks for those additional data points.

This seems like a multicast issue to me, I would check the router software to see if you have the option to “Enable Multicast Routing” and/or IGMP Proxying/Snooping as these settings have helped in the past with similar behavior.

Can you expand a bit on when the M5 is dropping? Is it between tracks switching or in the middle of tracks playing? When the M5 drops, do you see any error messages being presented?

While we can’t recommend specific routers, we have generally seen Netgear/TP-Link/Asus routers have good performance with Roon. There is some more feedback from users in the following thread:

The M5 seems to drop when no music is playing, without any error message. That data set is pretty small because Roon has detected the M5 only a handful of times. I did identify a Router setting “Filter Multicast” and when I enabled that everything failed. Again, Audirvana functions perfectly, as does everything else in my system.

Hi @Anton_Bokal,

I have gone ahead and enabled diagnostics on your Core machine to get some more insight into this issue and what this action does is automatically upload a set of logs to our servers for analysis. I can confirm that logs have been received and I wanted to share a small snippet of them with you here:

10/01 21:05:32 Trace: [raat] Endpoint discovered: Sooloos.Audio.Raat.DiscoveryData
10/01 21:05:32 Info: [raat] Initializing RoonReady Device
10/01 21:05:32 Info: [raat] Address: 192.168.1.1
10/01 21:05:32 Info: [raat] Port: 56825

What the above snippet is indicating is that your DAC is having the same IP address as your router (192.168.1.1), which means that there is very likely a networking issue somewhere along the line.

How exactly have you set up your M5 DAC on the network? Is it using a Static IP address or have you reserved this in your router settings as 192.168.1.1? If so, I would advise to set the M5 to use DHCP and let the router assign it a valid IP address instead of reserving it to be the same address as the router.

Once you have ensured that the M5 is not on static IP and it receives a different address than the router itself, we can proceed with troubleshooting, as I suspect that this is at least part of the issue (if not the entirety of the issue). Also, do please keep this in mind as well: