Bridge install on Raspberry Pi fails

I’m new to Roon and on my trial period. I am trying to install the bridge to a raspberry pi 3 (modelB).
I have rasbian setup, updated and configured to work with the HiFiBerry DAC+ I have installed.
However I am unable to get the roon script to execute. Following roon’s how-to page I am running the 3 commands below. They all run, except for the 3rd command to execute the script.
$ curl -O <---- Runs OK
$ chmod +x <---- Runs OK
$ sudo ./ <---- Fails

The last command to run the script comes back with 2 errors:
“cannot open html: No Such File”
“Syntax error: redirection unexpected”

Using the “ls” command I am sure the script file is there, executable and spelled correctly.

Can anyone tell me why this is failing?
I’ve also tried the same routine with an older ver 7 file and I get the exact same error.

You need the armv7hf script for Raspberry Pi:

Got closed out in the other thread as I was typing … you may be using DASH (I think that’s what ships with Debian) whereas the script is referencing BASH (#!/bin/bash).

Install DietPi. Everything you need and drop dead simple.

If you use it, don’t forget to donate. :wink:

Sorry @Martin_Webster – bit of a Solomon’s choice… :wink:

Raspbian out-of-the-box is bash, isn’t it? It’s been ages since I tried the easy installer on Raspbian though.

Slim is right: DietPi or Ropieee are better choices for running Roon Bridge on a Pi these days.

1 Like

Sorry, for the double post (1st post was in wrong sub-forum).
I was unaware Roon worked on DietPi. I’ve used DietPi before, so I’ll give that a shot.

OK, got DietPi installed. However, I’m stumped on how to get the drivers or whatever I need for the HiFiBerry DAC+ hat? The green LED isn’t on for the HiFiBerry, so I know it’s not enabled. I’ve looked through all the option on dietpi-launcher and dietpi-software and there’s no drivers. I looked in Roon and while it sees the dietpi on the network, there’s no option there for audio being directed out via the HiFiBerry.

When I go to the HiFiBerry site, they say that to use Roon with their board, you should download and install their own HiFiBerry-enabled Pi Rasbian image. Well, I’ve already tried that much earlier - and I can say that their image fails to run. It puts the pi in perpetual reboot (tried it on 2 different pi’s and 2 different micro SD cards). Their image just plain doesn’t work.


  1. Audio Options > Soundcard

I am an idiot.
I ran that but since it was labelled as rpi-bcm2835 I figured it was for some other sound card. Had no idea it went to another sub-menu.

Not sure. Thought I’d seen the redirect issue with DASH before.

I agree with Slim though; I use Ropieee for my endpoints. Couldn’t be any easier.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.