Brittleness - AGAIN

When I travel, I often shut down the NAS upon which my files reside and the iMac which runs Roon. We were away until Sunday, when I returned I power up the NAS (Freenas 10 on Dell R710, 48TB). Later I power up the iMac and Roon declares that I have no storage !
54 AM|689x500

I go to settings>storage and sure enough Roon says my devices are offline. I check by navigating in Finder to the NAS. Finder (which is fussy in the extreme) lets me navigate to all the relevant folders and assures me that I am logged in, not viewing via Guest access. See screen shot below.

I have rebooted both the NAS and the iMac a few times, nothing makes a difference - Roon insists that the Has/folders are not there. I decide to remove and relink a folder. I do so. Roon scans the floder WHILST TELLING ME IN THE SAME PANEL THAT THAT NAS AND FOLDERS ARE NOT AVAILABLE. See below:

I was raising the fragility / brittleness issue in the usability thread a couple of weekends ago and had a couple of users reassure me that their systems ran without any problems and had so for a considerable time (months / years). So I pondered if indeed my systems (or me!) was where the problems lie. I decided to do a bare metal build of the iMac.

Setting aside the issues of AFPS on Fusion drives I ended up with a clean bare install, to which I added my iCloud info (which populates SOME ‘system’ settings such as email, wireless settings etc) plus newly installed apps from scratch (that is, NOT via the migration tool). It seems unlikely that any issues could be carried across via the iCloud sync.

Nonetheless, the system that worked perfectly on shutdown, would not restart, as described above. As you know @eric, this is not the first time I have had the system rebuild everything and it is getting rather frustrating.

More so that technical intervention is required to simply run Roon. I have talked before about the high level of commitment required to run Roon satisfactorily and make the point again, that whilst I and other of a similar mind-set might slog at this stuff, families will not.


May not be anything, but I wanted to point out that in the case of the cannot connect

while the one which is working is:


the H is capitol instead of lowercase. To some OS’s these are two different locations.

1 Like

How odd, each was created by browsing to the folder within Roon. I’ll check when I get home again.

Turns out that the capitalization of NerdHouse did, indeed, change upon reconnection. All three sources on nerdygirl now have the same capitalization, which is different to the previous settings.

HOWEVER, the previous folder paths were setup using the Browse functionality in Roon - as were the previous folder paths.

No response from support to this I see. Disappointing.

Hi @Graham_Bird — Thank you for the post(s) and my sincere apologies for the slow response.

Moving froward, we have many Mac users that are using NAS drives without issue, but clearly something is going in your setup that’s not working as well. We need to identify what that might be, and then we can determine whether this is an issue in Roon, or whether this is related to something unique or misconfigured in your setup.

My gut feeling is that this is a result of how the FreeNAS is configured or the settings being used to connect to the device. We had a similar issue reported recently (NAS + ROCK) and our QA techs are still looking into it, but based on your feedback it seems like something different maybe occurring in your case.

As per my conversation this morning with a few members our tech team, may I very kindly ask you for the following information:

  1. While in this state (i.e the share not being recognized by the application) are you still able to access the FreeNAS via the OS?

  2. Based on your report it sounds like this behavior is easily reproducible. I have went ahead and enabled diagnostics on your account so our team can try to get a better sense as to what is going on with the mentioned storage unit but if possible, can you please reproduce the problem and note the time when the app loses communication with the FreeNAS?


Hi Eric,

I was traveling again over the weekend, so I shutdown the NAS and rebooted when I returned. All worked as expected.

NB I did do a bare metal install of MacOS between these two trips/ re-starts. One of the issues with the Mac on which Roon resides was that it would sometimes connect as a guest rather than with the login that enabled full privileges, but I can’t see how that would mess anything up.

The Freenas is a ‘standard install’ that seems to have no issues with a mixed network of Mac/Windows/Linux machines. So, on 1 above, in all cases I could access shares on Freenas from both the Mac in question and from other machines.

I’ll see if I can get the system to fault, but as I say startup yesterday went OK.



Hi @Graham_Bird ---- Hope you are well. Just wanted touch base and see how things were holding up since we last spoke.


Hi @Eric, so far so good. Since last weekend’s reboot things seem to be working well…

Touches wood…


3 posts were split to a new topic: IOS App can’t connect when screensaver activates on core machine