Bug: Roon misidentifies discs 100-126 in a box set a disc 1

Continuing the discussion from GUI needs attention for large box sets:

Not the case in my library. Can you give more details?

There are details and a screen shot in the linked issue. Happy to provide more info, but not sure what would be relevant beyond what has already been provided. Do you have a specific question or something for me to research about the problem?

I don’t quite see why you opened a new topic with no information in it. Maybe @andybob can sort it out.

As for your problem, a screen shot of some file tags from the relevant CDs would be useful. I have not had this problem and have many big boxes.

Ok not sure on the protocol. Seemed to make sense to xref it to the support tag since it is clearly not behaving the way I think everyone would agree it should behave.

I’ll send out additional screen shots tonight. But the one that already exists should the disc number and track tags clearly. All of the tracks have the same album name.

I see only Roon screenshots. What I mean is a view of your file tags in a metadata editor.

1 Like

I’m a bit late to the party on this one, but I am curious how you navigate 114 discs. I just ripped the Complete Bach Edition (142 discs), but Roon won’t even show me discs in the collection over disc 99. So I effectively have a significant part of the box set that I cannot even navigate to. Has anyone else seen this? Is there a fix/workaround?

Strange, the Mozart set I referred to is 200 and Roon shows them all

I have others over 99 as well

Have you looked in the disc groupings to see if some disc numbers are duplicated

Maybe your ripping software puts a limit in ?


The discs are all numbered correctly, and tags are quite clean. I’ve just spent the last couple of days working on them.

I wonder if it is a track limit that is just manifesting itself as a disc limit - there are over 3200 tracks…

As a workaround, I ended up splitting the set into 5 major volumes by type of work. This seems to have resolved the problem, but now I have 5 sets instead of one :frowning:

Well I spoke too soon. One of the 5 volumes (the one that spans discs 96-127) is massively wrong.

The 5th volume (the one starting at 128 and going through 142) processed fine.

When I look at the track groupings for the disk, they are way out of whack:

It looks as though Roon thinks that every disc over 100 is disc “1”. (See: Warning: This album has more than one track with the same disc and track numbers - that error is clearly incorrect.) Most of the 800+ tracks on this volume are lumped under “disc 1.”

I’ll XRef this under bugs. I see no logical reason why discs 100-127 would be considered disc 1.

@Dan_Petit ----- Thank you for the reports, I have condensed everything into this thread to avoid any information potentially going missing.

Continuing forward, we just did a test on our end and we were able to import a box set without any issues:

I agree with @Ludwig’s request, seeing what file tags are being used via the metadata editor will be a good next step here in addressing this behavior you are experiencing.


I was able to resolve the problem the other day by renumbering the disks (which started in the 90s and went over 100) to start at 1. I will restore them to their original values, see if I can reproduce the problem, and take additional screen shots.

The fact that spanning 99-100 seems to be related to both problems suggests to me that they are related.

I have restored my collection to its original disc numbering (and filenames). The discs now span from 96-127. I deleted the original files, did a library clean, then copied the modified files back to the location where Roon could see them. All the files are in a single directory.

The files copied in alphabetical order, so the file named 100-01-… (Disc 100, track1 1) copied first, etc. This means that files for discs 96-99 were among the last to copy. As Roon was processing the album, it did see it successfully process discs 100, 101, etc. But when it reached the end, it had rolled all files under discs 100-127 back under a new “Disc 1” as before (828 files, as shown in the screenshot above).

Here are a few screen shots from JRiver (which is what I use to manage tags). I have tried to show all of the tags with values for a particular file on the left, and a list with what I think are the most relevant tags on the right. I’ve also included a screenshots of windows explorer from the beginning and end of the directory listing containing the files.

If there is specific tag information you are looking for, just let me know.

The only other item of note is there is also a PDF of the liner notes in the same directory as the FLAC files. It’s filename begins with a “9” - not sure if that is important.

A couple of more notes:

I thought that maybe the order the files were copied might have something to do with it, so I started over and copied just 96-99. These were loaded fine. Then I copied the rest over and from disc 100 to 103 things looking like they were working, but then at disc 104 Roon reverted back to grouping all discs > 99 into disc 1 as before.

I also thought maybe robocopy (the tool I use to do copying) might be causing the problem, so I copied them by hand without robocopy and was still able to reproduce the problem.

I was also able to reproduce the problem without involving the PDF file, so we can rule that out.

Finally, while processing the files, Roon repeated switches between being able to identify the album and not being able to identify it.

It’s been said elsewhere that best practice, when copying across large numbers of files, is to stop the Roon Core during the copying. Throwing large numbers of files at Roon at once does seem to confuse it. Better to stop the Core, copy across the files, and then turn the Core back on so that it can deal with the new files in its own sweet way…

That might help. It would be good for Roon to include a pause button or manual mode if that is the case. I shouldn’t have to log into some other system to stop the load process and the restart it later.

@eric Just keeping this fresh. I’m about to rollback my changes using the workaround I described. If you need more debugging information while it is still in the “broken” state, now is the time…

@eric Just circling back on this to see if it is on the radar. I provided the requested information below but haven’t gotten an update in a while.

I have worked around the problem by breaking the boxed set up into multiple groups of discs, but i’d like to see if this can be resolved.

Hi @Dan_Petit ---- Thank you for reaching out to me. Hope all has been well!

I discussed your most recent post with a few of our tech team members this morning and as per the conversation the team has asked if you could please provide us with the following media samples in a PM addressed to me:

  • A track from a disc that is not showing up correctly in Roon.

  • A track from a disc that is showing up correctly in Roon.