Build 354 - Displays Feedback

Ok, after keep testing the new (and great) Roon Web display, I get it. Every browser running the Roon display IP in different devices in the intranet (different computers, phones, tablets) creates a different display entry, so must be activated per device.

I think that may be explain a bit more clear, specific, in the Roon instructions related to the display feature.

Loving the new feature, both in chromecasts and Browsers!

No. This feature is built as a “10 foot” experience–meaning it is for TV’s with the user sitting approximately 10 feet away, in an environment with no mouse/touchpad style controls, just like the places where the Chromecast runs. The main purpose for the web-based zone is to enable other tv-connected devices that aren’t Cast-based to show the display on a TV–XBox, Fire, Roku, AppleTV, etc.

There’s a subtle clue to this intent in that we didn’t provide a clickable link in-app for opening the web zone from Roon Remote–since that would almost definitely leave you running it on a tablet or computer.

We are not trying to turn this into a web-based remote. It would look totally different if that were the goal.


Great feature love it. It works like a charm, I suggest to try on Rap God by Eminem. I then played Paint it Black and was surprised there were no lyrics. How can I make my neighbors happy with both my music & my voice on this song?


Hmm. I don’t get a Displays section in the Settings panel.
Core is updated, so is my Windows laptop and my iPad.
What is missing?

Try rebooting.

Yes. Duh.
I restarted the Roon server software, that worked, didn’t needed reboot the Nucleus.
Strange, since the server was restarted after it was updated yesterday.

Another strange thing: on my iPad, I go into Safari, open a new tab and enter the URL I got from Roon. Get the black screen with “Roon” on it.
Go into Settings/Display and I see the Safari entry, next to the Chromecast, as below.
But a second later, Safari disappears from the list, second image below.
And Safari never shows up among the available displays on the zone UI, only CC.
I wonder, is this because iOS is such a single-threaded OS, so Safari disappears when it doesn’t have focus?
Has anybody succeeded using Safari on iOS?

I was getting that with my shield TV unit last night. I ended up factory resetting the shield as other devices stopped casting to it as well. It would show up on boot then I’d add it and it would drop off. Not sure if it’s Roons code or there is something up with Chromecast.

for the iPad you need be in safari then on another remote you can enable it…seems safari and roon don’t multi task well on iOS that I have found thus far.

1 Like

Use Chrome

Firefox and Silk on the FireTV-Stick 2 are working so far (including real-time lyrics), except for the issues mentioned above with the scaling issue with the ‘artist’ picture.

The only problem is that the screen goes into standby after 15 minutes. This only happens when the browsers are idle, and thus should not be a matter of setting my TV or FireTV stick. Perhaps there is a way to pretend to the browser that the mouse / remote control is being operated or that a movie is playing to prevent this.

Lots of chopped off heads in the artwork. Been fiddling with the display settings and that isn’t helping. Love the fact that it works, just needs some tweaking.

I only get a black page with roon written in white.
Copy the url from my app on iPad to chrome also on the iPad.
Same result with safari and firefox.
What do i do wrong?


Hey @Peter_Leinslie,

First try to give your Core machine a reboot. If that doesn’t yield any change, can you please share a screenshot of the following once you’ve opened the url in your browser:

  • Settings > Display
  • The Display selection menu
    • This can be found by selecting the volume icon and then the display icon during playback, as seen below:


A lightweight internet browser remote would be far more desirable for me than a now playing display.

I don’t have a need for it, but I can definitely see a use for now playing or lyrics on a TV screen. But genuinely struggling to find a situation where a now playing web browser page would be useful…

Stranger still that the same display isn’t available in Roon itself?

1 Like

Works perfectly, thanks!

After reboot:

Um, don’t you need to click on the “Enable” button? Once enabled, you should see it replaced by the gearwheels icon.

The Roon team are working on the “forehead problem”:

1 Like

Made some changes, same result: