Build 69 Crashes - Roon quit unexpectedly

Yeah!!! I am next!
You guys rock.
One day without Roon and I am already depressed! :smile:

@petridish also had an issue with the file. He provided us with this file, so we will try to fix the issue from our end.

Yes, fast response and resolution. Excellent service attitude and performance as always.

YEP…Can’t be a happy situation haven’t used Roon for a few days, opened it up on my Windows 10 computer to play through stereo. Started the latest upgrade on all devices , watched the circle for a few seconds and put on some music , Tidal tracks I believe. Switched on my Surface Pro 3 to use as remote as I enjoyed dinner, 45 minutes later… music stopped. " A problem has caused Room to stop working"… windows will look for a solution …on both machines. On the remote machine option offered to choose another library, with warning I would then lose myth existing one… which has all my favourites and playlists… this is not so cool. What should I do…Roon has previously been faultless and seamless… who screwed up my evening ???

What should I do having opened Roon tonight …it started to do latest update, I chose update all devices. The circle spun I started playing music on Windows 10 computer plugged into my DAC attached to stereo, went into other room opened up my Pro 3 as remote, it started updating. 45 minutes or maybe 30 later music stopped , pop up on both machines, Roon has stopped working. Closed that window, an offer to choose another library with warning that will no longer be able to use old library…first error in a year with Roon, what shall I do?? I don’t want to lose my playlists and favourites…help …:frowning:

OSX/elCapitan?

Hi Keith,

It sounds like your main Roon install has stopped for some reason, if that’s not running then the Remote Roon will not be able to connect to it hence the message.

I would ignore the warning on the RoonRemote install for now, I suggest you restart your main Roon and then report back on how it progresses or not.

Can you also provide information on the hardware you are running Roon (computer, NAS, LAN, WiFi, etc.)

@Mike, I think the warning on RoonRemote library selection change should be reviewed.

Hey @kjwho – sorry for the trouble here. I’m going to follow up via PM and we’ll figure out what happened here. Stand by!

MacBook Pro 2010, i7 2.66GHz, 8 GB RAM, 2 TB SSD, OS X 10.8.5, QNAP NAS, 25k Tracks in Library, iPad Retina Remote
Roon was very stable. I was a very happy camper.
Since upgrading to the latest build 1.1 (Build 69) I had several crashs immediately after starting roon app:


Reinstalling roon from download didn’t help. Replacing the roon directory in /library from backup solved the problem – until roon crashed again…
What to do to regain confidence?
Thanks
Markus

Jip same problem, after update it crashes.

Sorry for the trouble here @kon @oradba69 – I’ll be in touch via PM and we’ll get this sorted.

Stand by!

1 Like

I’m having issue on latest build using newest 2015 27" Retina iMac.

My workaround was downloading app from site and not upgrading to latest build. If I use latest build it crashes right after it fully loads.

Hey @iamoneagain – sorry for the trouble here. We’ve found the issue that was causing these problems, and we’re currently testing a fix.

That said, we can probably get this resolved for you even before the fix is released, so I’m going to follow up via PM. Stand by!

Doing a system restore to a Windows safe point last week worked for me. Roon now running ok and boy does it sound great compared to my 24 hours without it. My old media player just doesn’t have the natural detail and excitement.

Same issue, 1.1 (69) crashes even after a clean install, but it had been running well for weeks!

Are there any specific steps I can take (other than the reinstall) to try and debug? It’s completely unusable for me for the last few days… And I miss it!

Downloaded the update this mornig,
Ran it, and BOOM, Roon ceased to function.
Same problem as others users.
Waiting for a solution…

Hey @pszego, @Jacques_Legrand – we’ve found the issue that was causing these crashes, and the fix will be released very soon.

That said, we should be able to get you up and running even before the fix goes live, so stand by – I’m going to follow up with you both via PM.

Hi Mike

Just to add that I am having the same problem as mentioned above in that on my MBP 2013 version the Roon program is repeatedly crashing before even getting to the main library page.
This is using the latest build of the software - 1.1 (69)

I have uninstalled and re-installed several times and am now trying with the previous version (65) which was running without too many problems.
As I type this message version 1.1 (65) has been updating the database for some time now - but I am hoping this will get me up and running again.

If you have any specific solution to the repeated crashes, I too would be keen to try the “fix” please.
Thanks a lot

Quick update on my previous post - having deleted and uninstalled Build 69, I am now back with Roon working as normal using Build 65.

Build 70 fixed my problem!!
By the way, this build also fixed this issue.
You guys rock. Thank you very much!

2 Likes