Build 88 Add To Library Not Working Properly

Ever since the new build the add to library button has stopped working for me properly.

I will click on the button but nothing happens visually. If I reboot Roon however the album as usually be added to my library.

Many Thanks


This seems to be sporadic with different albums.

Just added 'The Miles Davis Quintet - Steamin

Cant add ‘Nick Drake - Pink Moon’

Cant add ‘Miles Davis - Jack Johnson’

Hello @Wayne_Bull1,
After pressing on ‘Add to Library’ button you should see a spinner in upper-right corner of the app:

This spinner means that Roon is in process of adding the album to your library - this procedure may take several seconds (you can click on spinner to check the progress). You need to wait while Roon finish this procedure (spinner will disappear from the screen) and after that album details page should update automatically.


Yes I’m aware of this procedure but it fails to happen on the above albums?

I also have problems with adding tidal albums to library. Sometimes it does not work at all - and sometimes it works but is really slow. In the early days this worked like a dream, not any more…

Hey guys – I’m not aware of any changes here, but once everyone is back from the holiday we’ll take a look and see if there’s something reproducible here, or we can identify any regressions.

Can you guys let me know a bit more about your setups? Are you running Roon, RoonServer, or a remote? What platforms? How many albums in your collection? How many Tidal favorites?

Hey Mike,

I’m using a macbook pro feeding an iFi nano dac.

I’m running Room direct from the mac.

I have 1040 albums in my collection at the moment of which only 36 are Tidal favourites.

Hope that helps.

I’m seeing this too.
RoonServer on a Brix (WS2012R2), HQP then USB ASIO to Auralic Vega
PC and iPad Mini Remotes.
1643 Albums of which 511 are Tidal

I can see the Beatles albums in Tidal now… However I can only add the White album. No other beatles albums will add.
Furthermore I have to disable Tidal for it to refresh. The syncing doesn’t add what I’ve since added in Tidal. There is no way for Tidal to automatically update in Roon?

Same with me. Can add on Tidal- but won’t show as added on Roon. Tried a random new album
(not Beatles) and it was added successfully. As Roon is supposed to recognize recent Tidal activity- seems there is still something missing with Beatles Tidal/Roon integration.

I have the same problem and this also includes a number of other albums for example the new Bruce Springsteen box set - The ties that Bind…I hope this problem with TIDAL will be solved soon. It is quite a while where it has been difficult to add albums from TIDAL to ROON in my system. Either it has not been possible for certain albums or it has been slow and cumbersome…

+1 with the Beatles tracks.

Just to even it out – no problems adding Beatles albums from Tidal here…

Thanks for the reports everyone – I’m able to add Beatles albums from TIDAL as well, but clearly something is going wrong here.

We’re going to investigate further guys, but I don’t think this is Beatles specific so I’ve merged the reports here. For now, this information would be good to have from everyone:

Sorry for the trouble all. :santa: Thanks guys!

1 Like

Tried clearing the cache, didn’t fix it.
I can add other albums from Tidal, even one of the Beatles ones (Beatles for sale) and others, but not most of the Beatles albums. (Don’t know why I care, haven’t listened to the Beatles in 50 years.)

Roonserver build 88 on Windows 10 NUC, Roon build 88 on Windows 10 remote, or iPad remote.

This isn’t a new issue - for me, adding to library from TIDAL has only worked half the time since the beginning. I just assumed (probably wrongly) some albums are protected in some way so they can be played but not added, but maybe it’s the same issue others are experiencing.

1 Like

@mike Take it back – the albums appeared in my library list, an hour after I added them (played some other music in the meantime).

But no spinner or other confirmation, and the delay was very long, not just a matter of me being impatient. I gave visited the album browser many times before it appeared.

I also cleared the cache and it did not solve the issue. I still cannot add the Beatles album or the new Bruce Springsteen box to ROON. Clearly the adding function of TIDAL is unstable or does not fully work for one reason or the other. And as pcwilliams writes this seems to be a general experience for months…

It won’t help but I just added the Bruce River box to the library with no issue. Wonder if it is location related…am in UK.

clicking add to library does absolutely nothing… this is clearly a bug that needs to be addressed.
I want to make the Tidal version my primary version but I can’t add it to Roon