Can no longer add network share to macOS Ventura

Nucleus+, running 2.0 (1303). MacBook Pro M1 running 13.3.1.

In the past I’ve been able to add a folder on my Mac as a network share using these instructions and then automated backups would run to it with no problem. Since installing macOS Ventura, I think, this has no longer worked. For a while I was able at least to add the network share once and complete a manual backup, but the subsequent automated backups would fail. Now I can’t add the network share at all, I just get a delay and then “Unexpected Error” from the Roon interface. I have tried creating a new shared folder on the Mac and have tried changing the password on the Mac user account that Roon uses to connect, to no avail. In the Sharing settings for the folder on the Mac, via SMB is checked and the Roon user account has read & write privileges for the folder.

I have noticed that since Ventura, the Sharing panel in macOS no longer gives the computer’s name with the suffix “.local” for sharing, as depicted in the Roon instructions above; it only gives the format as “smb://IPaddress.” So, I am typing into the Roon dialogue box this: “smb://IPaddress/folder-name” (or just “\IPaddress\folder-name” [I have typed two back slashes at the beginning but the text renderer here is not showing one of them for some reason]). Then the username and password for the Roon user account that I had created on the Mac (the account itself has only Sharing privileges and is not an Admin account).

Could Apple have broken the process that used to work by adding new security features or something?
Thanks for any advice anyone might have.

Hi @tc4972 ,

It looks like there were a few similar reports on Ventura, have you tried toggling File Sharing off and then back on yet? This has helped others in the past:

It does, as the local host name is now located at the bottom of the window. I use remote login/screen sharing on all my Mac’s.

I hope that helps.

Thanks, now that you mention it I had tried that earlier and gotten it to work for a while, but then eventually it would stop working and the automatic backups would also then stop. With your reminder I tried it again, toggling File Sharing off, restarting, and toggling it back on, and I was able to connect.

2 Likes

Thanks, good to know where it is now—I hadn’t scrolled down that far to see it!

1 Like

Update:

Thanks again for the above suggestions. Toggling File Sharing off, restarting, and toggling File Sharing back on did finally allow me to connect. But after a few weeks the situation is as follows:

  • Automatic backups do not succeed. Instead an error message appears indicating that the location was not available. Then I cannot connect manually, either.

  • Toggling File Sharing off, restarting, and toggling File Sharing back on again restores my ability to connect manually.

  • I can then manually force a backup to begin. However, Roon then gets stuck forever on the screen that says it is snapshotting my database for backup. I have to reboot the Nucleus. But then when I go back to Backups, it says that the backup I forced manually had in fact succeeded, and gives the time of its completion.

I hope that at least those manual backups are in fact fully completed and intact. If anyone has any other perspective or suggestions at this point, I’d be grateful. I guess soon macOS Sonoma will arrive, perhaps with a fix, or perhaps with more new problems. :roll_eyes:

Because the backslash is also an escape character (removing any special meaning from the next character). To see two backslashes in the post, type three

1 Like

Hi @tc4972 ,

Did Sonoma present any improvement with this issue?

Apologies, I haven’t gotten around to upgrading to Sonoma, and I may wait a while yet—but will try to report back when the time comes. For now, I’ve been just periodically doing the toggle file sharing off, restart, and back on thing, then forcing a manual backup.

If anyone else has upgraded to Sonoma and observed any improvement, I’d be curious to hear it.

1 Like